summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2015-07-29 20:51:17 +0200
committerAntonio Rojas2015-07-29 20:51:17 +0200
commit8bf3f6e4a24bf95dee79557415e45c6b290d0a0f (patch)
tree9ea6adb40a5017db180c6983a2f7fc47fb52c0ae
parent7354a79bc6a7410e567bd3b3ce04a46882502140 (diff)
downloadaur-8bf3f6e4a24bf95dee79557415e45c6b290d0a0f.tar.gz
Update repo
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD51
2 files changed, 20 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41c43a9630b6..96e5b429e76b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,17 @@
pkgbase = telepathy-morse-git
pkgdesc = Telepathy Connection Manager for the Telegram network
- pkgver = r47.e8dd644
+ pkgver = r82.4161790
pkgrel = 1
- url = https://github.com/Kaffeine/telepathy-morse/
+ url = https://projects.kde.org/telepathy-morse/
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
makedepends = git
- makedepends = telegram-qt4-git
- makedepends = telegram-qt5-git
- makedepends = telepathy-qt4
- makedepends = telepathy-qt5
- source = git+https://github.com/Kaffeine/telepathy-morse/
+ makedepends = telegram-qt-git
+ depends = telepathy-qt5
+ source = git://anongit.kde.org/telepathy-morse.git
md5sums = SKIP
-pkgname = telepathy-morse-qt4-git
- depends = telepathy-qt4
-
pkgname = telepathy-morse-git
- depends = telepathy-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 5f4f13d3c708..e9deae241f6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,38 @@
-# Maintainer: Antonio Rojas
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
-pkgbase=telepathy-morse-git
-pkgname=('telepathy-morse-qt4-git' 'telepathy-morse-git')
-pkgver=r47.e8dd644
+_gitname=telepathy-morse
+pkgname=telepathy-morse-git
+pkgver=r82.4161790
pkgrel=1
pkgdesc="Telepathy Connection Manager for the Telegram network"
-arch=('i686' 'x86_64')
-url="https://github.com/Kaffeine/telepathy-morse/"
-license=('GPL')
-makedepends=('cmake' 'git' 'telegram-qt4-git' 'telegram-qt5-git' 'telepathy-qt4' 'telepathy-qt5')
-source=("git+https://github.com/Kaffeine/telepathy-morse/")
+arch=(i686 x86_64)
+url="https://projects.kde.org/telepathy-morse/"
+license=(GPL)
+depends=(telepathy-qt5)
+makedepends=(cmake git telegram-qt-git)
+source=("git://anongit.kde.org/$_gitname.git")
md5sums=('SKIP')
pkgver() {
- cd telepathy-morse
+ cd $_gitname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- mkdir -p build{4,}
-
- sed -i 's|CTelegramCore.hpp|TelegramQt/CTelegramCore.hpp|' telepathy-morse/textchannel.hpp
+ mkdir -p build
}
build() {
- pushd build4
- cmake ../telepathy-morse \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_INSTALL_LIBEXECDIR=lib/telepathy \
- -DCMAKE_BUILD_TYPE=Release \
- -DUSE_QT4=ON
- popd
-
- pushd build
+ cd build
cmake ../telepathy-morse \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_LIBEXECDIR=lib/telepathy \
-DCMAKE_BUILD_TYPE=Release
- popd
-
-}
-
-package_telepathy-morse-qt4-git() {
- depends=('telepathy-qt4')
-
- cd build4
- make DESTDIR="$pkgdir" install
+ make
}
-
-package_telepathy-morse-git() {
- depends=('telepathy-qt5')
-
+package() {
cd build
make DESTDIR="$pkgdir" install
}