summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Andreyev2018-05-03 03:46:52 +0300
committerAlexey Andreyev2018-05-03 03:46:52 +0300
commit82fa540e04eff9efa45a72eda5adc7aa6cbda280 (patch)
tree39641506ace533172ced7f1bd5e6153f31341923
downloadaur-82fa540e04eff9efa45a72eda5adc7aa6cbda280.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db9f23a514c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = telepathy-tank-git-wip
+ pkgdesc = Matrix connection operator for the Telepathy framework. WIP git branch
+ pkgver = r6.ae032b2
+ pkgrel = 1
+ url = https://telepathy.freedesktop.org/
+ arch = i686
+ arch = x86_64
+ arch = armv7
+ arch = aarch64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = telepathy-qt-git
+ provides = telepathy-tank
+ conflicts = telepathy-tank
+ source = git+https://github.com/a-andreyev/telepathy-tank#branch=wip
+ md5sums = SKIP
+
+pkgname = telepathy-tank-git-wip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..174a34c28778
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Alexey Andreyev <aa13q@ya.ru>
+
+_gitname=telepathy-tank
+pkgname=telepathy-tank-git-wip
+pkgver=r6.ae032b2
+pkgrel=1
+pkgdesc="Matrix connection operator for the Telepathy framework. WIP git branch"
+arch=(i686 x86_64 armv7 aarch64)
+url="https://telepathy.freedesktop.org/"
+license=(GPL)
+depends=(telepathy-qt-git)
+makedepends=(cmake git)
+provides=(telepathy-tank)
+conflicts=(telepathy-tank)
+source=("git+https://github.com/a-andreyev/$_gitname#branch=wip")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../telepathy-tank \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib/telepathy \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQT_VERSION_MAJOR=5
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}