summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Muehlhaeuser2021-01-30 21:32:04 +0100
committerChristian Muehlhaeuser2021-01-30 21:32:04 +0100
commit5153a77cb64ac01a65d0a435e1a92e3a548437e3 (patch)
tree2000fe896682864bdd7158fbc12792fd6b957c26
parent1b1a89b58a630655ca3c26c843a82bda5cd176cd (diff)
downloadaur-5153a77cb64ac01a65d0a435e1a92e3a548437e3.tar.gz
Update build to use Go modules
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD31
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8bf45e90ce1..7ee056eb99bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = telephant-git
pkgdesc = A lightweight but modern Mastodon client, written in Go & QML
- pkgver = 20200303
+ pkgver = 20210130
pkgrel = 1
url = https://github.com/muesli/telephant
arch = x86_64
@@ -21,6 +21,8 @@ pkgbase = telephant-git
depends = qt5-multimedia
provides = telephant
conflicts = telephant
+ source = telephant-git::git://github.com/muesli/telephant.git
+ sha256sums = SKIP
pkgname = telephant-git
diff --git a/PKGBUILD b/PKGBUILD
index 78be5814e0b8..ee83bcf866b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Muehlhaeuser <muesli at gmail dot com>
# Maintainer: MOTT <ted.jameson at pm dot me>
pkgname=telephant-git
-pkgver=20200303
+pkgver=20210130
pkgrel=1
pkgdesc="A lightweight but modern Mastodon client, written in Go & QML"
arch=('x86_64')
@@ -11,35 +11,40 @@ depends=('qt5-base' 'qt5-declarative' 'qt5-graphicaleffects' 'qt5-quickcontrols'
makedepends=('go' 'pkgconf' 'qt5-tools' 'git' 'libpulse' 'glib2' 'mesa')
provides=("telephant")
conflicts=("telephant")
-#source=($pkgname::git://github.com/muesli/telephant.git)
-#sha256sums=('SKIP')
+source=($pkgname::git://github.com/muesli/telephant.git)
+sha256sums=('SKIP')
build() {
export GOPATH="$srcdir"/gopath
- export PATH="$srcdir"/gopath/bin:$PATH
+ export PATH="$GOPATH"/bin:$PATH
export QT_PKG_CONFIG=true
+ export QT_VERSION="5.15.2"
# Create dirs
- mkdir -p "$srcdir"/gopath
+ mkdir -p "$GOPATH"
# Qt Bindings
- go get -v -tags=no_env github.com/therecipe/qt/cmd/...
- #$(go env GOPATH)/bin/qtsetup -test=false
+ GO111MODULE=off go get -v -tags=no_env github.com/therecipe/qt/cmd/...
+
+ # Build bindings (not usually needed)
+ # $(go env GOPATH)/bin/qtsetup -test=false
# Build Telephant
- go get -d -v github.com/muesli/telephant
- cd "$GOPATH"/src/github.com/muesli/telephant
+ cd "$srcdir/$pkgname"
- $(go env GOPATH)/bin/qtdeploy build desktop
+ go mod vendor
+ $(go env GOPATH)/bin/qtdeploy build desktop .
}
package() {
- install -Dm755 "gopath/src/github.com/muesli/telephant/deploy/linux/telephant" "$pkgdir/usr/bin/telephant"
- install -Dm644 "gopath/src/github.com/muesli/telephant/assets/telephant.desktop" "$pkgdir/usr/share/applications/telephant.desktop"
+ cd "$srcdir/$pkgname"
+
+ install -Dm755 "deploy/linux/telephant-git" "$pkgdir/usr/bin/telephant"
+ install -Dm644 "assets/telephant.desktop" "$pkgdir/usr/share/applications/telephant.desktop"
for icon_size in 8 16 32 64 128 256 512; do
icon_dir="$pkgdir/usr/share/icons/hicolor/${icon_size}x${icon_size}/apps"
install -d "$icon_dir"
- install -m644 "gopath/src/github.com/muesli/telephant/assets/icons/telephant-${icon_size}.png" "$icon_dir/telephant.png"
+ install -m644 "assets/icons/telephant-${icon_size}.png" "$icon_dir/telephant.png"
done
}