summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten de Boer2021-09-05 17:36:18 +0200
committerMaarten de Boer2021-09-05 17:36:18 +0200
commit2c072ed75cc7053b93fe09d44637fbce66837e94 (patch)
treefc52f4e1e50060ff79637e65a1da0e4a0288453d
parent50132f0e703165221d454e246f6a57268adc2b71 (diff)
downloadaur-2c072ed75cc7053b93fe09d44637fbce66837e94.tar.gz
Merge teleport-client into split package and upgrade to v7.1.0 without BPF
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD49
-rw-r--r--no-bpf.patch39
3 files changed, 82 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7582939f751..918d471a0b92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,31 @@
pkgbase = teleport
pkgdesc = Modern SSH server for teams managing distributed infrastructure
- pkgver = 6.2.8
+ pkgver = 7.1.0
pkgrel = 1
url = https://github.com/gravitational/teleport
- install = teleport.install
arch = i386
arch = x86_64
arch = armv7h
arch = aarch64
license = Apache
- makedepends = go>=1.14.0
+ makedepends = go>=1.16.0
+ depends = glibc
provides = tctl
provides = tsh
- source = teleport-6.2.8.tar.gz::https://github.com/gravitational/teleport/archive/refs/tags/v6.2.8.tar.gz
- source = teleport-webassets-7820228a3ed3fac73aa74d12f2ef851eb2905058.tar.gz::https://github.com/gravitational/webassets/archive/7820228a3ed3fac73aa74d12f2ef851eb2905058.tar.gz
+ source = teleport-7.1.0.tar.gz::https://github.com/gravitational/teleport/archive/refs/tags/v7.1.0.tar.gz
+ source = teleport-webassets-07493a5e78677de448b0e35bd72bf1dc6498b5ea.tar.gz::https://github.com/gravitational/webassets/archive/07493a5e78677de448b0e35bd72bf1dc6498b5ea.tar.gz
source = teleport.service
source = teleport@.service
source = teleport.install
- sha256sums = bbc128d0778d253ec6e8af44286df750caec65d8c8e2616c85cf2656c267460f
- sha256sums = a7fac0f1bab9d73d6e60d94740bc7462f051fec9ac5febe38a22b260982a2b8e
+ source = no-bpf.patch
+ sha256sums = 0b716eb1cd02b1d41c017954c5a173ab5372ab4698276faab6c45e3f2aedaeae
+ sha256sums = 2074ee7e50720f20ff1b4da923434c05f6e1664e13694adde9522bf9ab09e0fd
sha256sums = 10ac25cea1b5c193d7f968ca28a1da0e54b847f29c2a0186b46fd853194be38a
sha256sums = 4bc17fdde981f91c5d9972ae0555ee5e8b63a6b67e007c28f83ada80823980fd
sha256sums = ce2dd61cae3c0c3684e7e629f98b77551e66ddedca2194250a34f0efbc674f3a
+ sha256sums = 12ba2a2b9d5efd5751799c2a1c3ddefe5aea4daf0f5d38fad4ec7923631e5ec0
pkgname = teleport
+ install = teleport.install
+
+pkgname = teleport-client
diff --git a/PKGBUILD b/PKGBUILD
index a3462c3da698..632579e9ec1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
-# Maintainer: Maarten de Boer <maarten@cloudstek.nl>
+# Maintainer: Jedrzej Nowak <pigmej@gmail.com>
+# Co-Maintainer: Maarten de Boer <maarten@cloudstek.nl>
-pkgname=teleport
-pkgver=6.2.8
+pkgname=('teleport' 'teleport-client')
+_pkgname=teleport
+pkgver=7.1.0
pkgrel=1
pkgdesc="Modern SSH server for teams managing distributed infrastructure"
arch=('i386' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/gravitational/teleport"
license=('Apache')
-depends=()
-makedepends=('go>=1.14.0')
+depends=('glibc')
+makedepends=('go>=1.16.0')
provides=('tctl' 'tsh')
-install=teleport.install
-_webassets_ref=7820228a3ed3fac73aa74d12f2ef851eb2905058
+_webassets_ref=07493a5e78677de448b0e35bd72bf1dc6498b5ea
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gravitational/teleport/archive/refs/tags/v${pkgver}.tar.gz"
- "${pkgname}-webassets-${_webassets_ref}.tar.gz::https://github.com/gravitational/webassets/archive/${_webassets_ref}.tar.gz"
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/gravitational/teleport/archive/refs/tags/v${pkgver}.tar.gz"
+ "${_pkgname}-webassets-${_webassets_ref}.tar.gz::https://github.com/gravitational/webassets/archive/${_webassets_ref}.tar.gz"
"teleport.service"
"teleport@.service"
- "teleport.install")
+ "teleport.install"
+ "no-bpf.patch")
-sha256sums=('bbc128d0778d253ec6e8af44286df750caec65d8c8e2616c85cf2656c267460f'
- 'a7fac0f1bab9d73d6e60d94740bc7462f051fec9ac5febe38a22b260982a2b8e'
+sha256sums=('0b716eb1cd02b1d41c017954c5a173ab5372ab4698276faab6c45e3f2aedaeae'
+ '2074ee7e50720f20ff1b4da923434c05f6e1664e13694adde9522bf9ab09e0fd'
'10ac25cea1b5c193d7f968ca28a1da0e54b847f29c2a0186b46fd853194be38a'
'4bc17fdde981f91c5d9972ae0555ee5e8b63a6b67e007c28f83ada80823980fd'
- 'ce2dd61cae3c0c3684e7e629f98b77551e66ddedca2194250a34f0efbc674f3a')
+ 'ce2dd61cae3c0c3684e7e629f98b77551e66ddedca2194250a34f0efbc674f3a'
+ '12ba2a2b9d5efd5751799c2a1c3ddefe5aea4daf0f5d38fad4ec7923631e5ec0')
prepare() {
- mv "${srcdir}/${pkgname}-${pkgver}" "${srcdir}/${pkgname}"
+ mv "${srcdir}/${_pkgname}-${pkgver}" "${srcdir}/${pkgname}"
rm -Rf "${srcdir}/${pkgname}/webassets"
mv "${srcdir}/webassets-${_webassets_ref}" "${srcdir}/${pkgname}/webassets"
@@ -47,14 +50,17 @@ build() {
cd "${GOPATH}/src/github.com/gravitational/teleport"
- make
+ patch Makefile "${srcdir}/no-bpf.patch"
+
+ make full
- rm -Rf "${srcdir}/go"
unset GOPATH
}
-package() {
- cd "${srcdir}/${pkgname}"
+package_teleport() {
+ install=teleport.install
+
+ cd "${srcdir}/${_pkgname}"
# Install binaries
install -Dm755 build/teleport "${pkgdir}/usr/bin/teleport"
@@ -69,3 +75,10 @@ package() {
install -dm755 "${pkgdir}/usr/share/teleport"
cp -r examples "${pkgdir}/usr/share/teleport/"
}
+
+package_teleport-client() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -Dm755 build/tctl "${pkgdir}/usr/bin/tctl"
+ install -Dm755 build/tsh "${pkgdir}/usr/bin/tsh"
+}
diff --git a/no-bpf.patch b/no-bpf.patch
new file mode 100644
index 000000000000..8bec5ca178e7
--- /dev/null
+++ b/no-bpf.patch
@@ -0,0 +1,39 @@
+--- a/Makefile 2021-08-24 21:17:32.000000000 +0200
++++ b/Makefile 2021-09-05 17:24:49.684217758 +0200
+@@ -81,36 +81,6 @@
+ # We don't compile BPF for anything except regular non-FIPS linux/amd64 for now, as other builds
+ # have compilation issues that require fixing.
+ with_bpf := no
+-ifeq ("$(OS)","linux")
+-ifeq ("$(ARCH)","amd64")
+-ifneq ("$(wildcard /usr/include/bpf/libbpf.h)","")
+-with_bpf := yes
+-BPF_TAG := bpf
+-BPF_MESSAGE := "with BPF support"
+-CLANG ?= $(shell which clang || which clang-10)
+-CLANG_FORMAT ?= $(shell which clang-format || which clang-format-10)
+-LLVM_STRIP ?= $(shell which llvm-strip || which llvm-strip-10)
+-KERNEL_ARCH := $(shell uname -m | sed 's/x86_64/x86/')
+-INCLUDES :=
+-ER_BPF_BUILDDIR := lib/bpf/bytecode
+-RS_BPF_BUILDDIR := lib/restrictedsession/bytecode
+-
+-# Get Clang's default includes on this system. We'll explicitly add these dirs
+-# to the includes list when compiling with `-target bpf` because otherwise some
+-# architecture-specific dirs will be "missing" on some architectures/distros -
+-# headers such as asm/types.h, asm/byteorder.h, asm/socket.h, asm/sockios.h,
+-# sys/cdefs.h etc. might be missing.
+-#
+-# Use '-idirafter': Don't interfere with include mechanics except where the
+-# build would have failed anyways.
+-CLANG_BPF_SYS_INCLUDES = $(shell $(CLANG) -v -E - </dev/null 2>&1 \
+- | sed -n '/<...> search starts here:/,/End of search list./{ s| \(/.*\)|-idirafter \1|p }')
+-
+-CGOFLAG = CGO_ENABLED=1 CGO_LDFLAGS="-Wl,-Bstatic -lbpf -lelf -lz -Wl,-Bdynamic"
+-endif
+-endif
+-endif
+-
+
+ # Reproducible builds are only availalbe on select targets, and only when OS=linux.
+ REPRODUCIBLE ?=