summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten de Boer2021-12-05 20:32:39 +0100
committerMaarten de Boer2021-12-05 20:32:39 +0100
commitba760a615df7ed26c568e8f0a08b1aea013f51b4 (patch)
treeff2d31ee1f78ec58a1bdde04028ce28cbbfe7f6d
parent169f43280131de4b96fdeaf22bfb2922f9eba5e3 (diff)
downloadaur-ba760a615df7ed26c568e8f0a08b1aea013f51b4.tar.gz
Fix build by moving cargo build dir to src dir.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bb6bfa9d12d..b71af1b95e5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = teleport
pkgdesc = Modern SSH server for teams managing distributed infrastructure
pkgver = 8.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gravitational/teleport
arch = i386
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 61b2b1271a67..fffd0d3ec562 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('teleport' 'teleport-client')
_pkgname=teleport
pkgver=8.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Modern SSH server for teams managing distributed infrastructure"
arch=('i386' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/gravitational/teleport"
@@ -47,6 +47,7 @@ build() {
cd "${srcdir}/${_go_srcpath}"
export GOPATH="${srcdir}/go"
+ export CARGO_HOME="${srcdir}/cargo"
# See: https://wiki.archlinux.org/index.php/Go_package_guidelines
export CGO_CPPFLAGS="${CPPFLAGS}"
@@ -56,7 +57,7 @@ build() {
export ADDFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
# Build
- PATH="${PATH}:${HOME}/.cargo/bin" make full
+ PATH="${PATH}:${CARGO_HOME}/bin" make full
# Make sure go path is writable so it can be cleaned up
chmod -R u+w "${srcdir}/go"