summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten de Boer2021-05-25 17:49:58 +0200
committerMaarten de Boer2021-05-25 17:49:58 +0200
commit7e7d1151a9c372fb5d2574be365683b9f329d878 (patch)
tree8ca7fd21be8bbf1084424d3eab7dea2d4c9a25f9
parent0013a53ff0b9d066ef577b79d96794af59d8070c (diff)
downloadaur-7e7d1151a9c372fb5d2574be365683b9f329d878.tar.gz
Update to 6.2.0
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD74
3 files changed, 65 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 137e9d79644f..7f23e708f903 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = teleport-client
- pkgdesc = Modern SSH server for teams managing distributed infrastructure client only
- pkgver = 5.1.0
+ pkgdesc = Client-only (tsh, tctl) package for teleport
+ pkgver = 6.2.0
pkgrel = 1
- url = https://gravitational.com/teleport
+ url = https://github.com/gravitational/teleport
+ arch = i386
arch = x86_64
- arch = arm
+ arch = armv7h
+ arch = aarch64
license = Apache
- depends = glibc
- options = !strip
- source_x86_64 = https://get.gravitational.com/teleport-v5.1.0-linux-amd64-bin.tar.gz
- sha256sums_x86_64 = 9b27eb994c94897fac776e7b8cee54038dc6b33f8126603a459e2d47eaa55dfb
- source_arm = https://get.gravitational.com/teleport-v5.1.0-linux-arm-bin.tar.gz
- sha256sums_arm = e9053afd6ea0f4a57e99501f464235859d7701046f941c92e238e6ef9e4ef8ae
+ makedepends = go>=1.14.0
+ provides = tctl
+ provides = tsh
+ source = teleport-client-6.2.0.tar.gz::https://github.com/gravitational/teleport/archive/refs/tags/v6.2.0.tar.gz
+ source = teleport-client-webassets-8c2812c169fa6bd5f31c13160bd93ef8b317bbc9.tar.gz::https://github.com/gravitational/webassets/archive/8c2812c169fa6bd5f31c13160bd93ef8b317bbc9.tar.gz
+ sha256sums = bf479d580dc0f9187493645b6e3aa7e5458e46ff4c632169fc688946a6265ba2
+ sha256sums = 14445b0864d759347c1f53dc144a346b1974b8ded49031d7f0b7227f5d49d407
pkgname = teleport-client
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f43100b7b874
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/src
+/teleport-client* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 2f8906f0d5a7..086c45f42ccb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,57 @@
# Maintainer: Jedrzej Nowak <pigmej@gmail.com>
+# Co-Maintainer: Maarten de Boer <maarten@cloudstek.nl>
pkgname=teleport-client
-pkgver=5.1.0
+_pkgname=teleport
+pkgver=6.2.0
pkgrel=1
-pkgdesc="Modern SSH server for teams managing distributed infrastructure client only"
-arch=('x86_64' 'arm')
-url="https://gravitational.com/teleport"
+pkgdesc="Client-only (tsh, tctl) package for teleport"
+arch=('i386' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/gravitational/teleport"
license=('Apache')
-depends=('glibc')
-source_x86_64=(
- "https://get.gravitational.com/teleport-v${pkgver}-linux-amd64-bin.tar.gz"
- )
-sha256sums_x86_64=(
- '9b27eb994c94897fac776e7b8cee54038dc6b33f8126603a459e2d47eaa55dfb'
- )
-source_arm=(
- "https://get.gravitational.com/teleport-v${pkgver}-linux-arm-bin.tar.gz"
- )
-
-sha256sums_arm=(
- 'e9053afd6ea0f4a57e99501f464235859d7701046f941c92e238e6ef9e4ef8ae'
- )
-
-options=(!strip)
+depends=()
+makedepends=('go>=1.14.0')
+provides=('tctl' 'tsh')
+
+_webassets_ref=8c2812c169fa6bd5f31c13160bd93ef8b317bbc9
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gravitational/teleport/archive/refs/tags/v${pkgver}.tar.gz"
+ "${pkgname}-webassets-${_webassets_ref}.tar.gz::https://github.com/gravitational/webassets/archive/${_webassets_ref}.tar.gz")
+
+sha256sums=('bf479d580dc0f9187493645b6e3aa7e5458e46ff4c632169fc688946a6265ba2'
+ '14445b0864d759347c1f53dc144a346b1974b8ded49031d7f0b7227f5d49d407')
+
+prepare() {
+ mv "${srcdir}/${_pkgname}-${pkgver}" "${srcdir}/${pkgname}"
+ rm -Rf "${srcdir}/${pkgname}/webassets"
+ mv "${srcdir}/webassets-${_webassets_ref}" "${srcdir}/${pkgname}/webassets"
+
+ install -m755 -d "${srcdir}/go/src/github.com/gravitational"
+ ln -sf "${srcdir}/${pkgname}" "${srcdir}/go/src/github.com/gravitational/teleport"
+}
+
+build() {
+ export GOPATH="${srcdir}/go"
+
+ # See: https://wiki.archlinux.org/index.php/Go_package_guidelines
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "${GOPATH}/src/github.com/gravitational/teleport"
+
+ make build/tctl
+ make build/tsh
+
+ rm -Rf "${srcdir}/go"
+ unset GOPATH
+}
package() {
- mkdir -p "${pkgdir}/usr/bin"
- cd "${srcdir}/teleport"
- install -m755 -t "${pkgdir}/usr/bin/" tctl tsh
-} \ No newline at end of file
+ cd "${srcdir}/${pkgname}"
+
+ install -Dm755 build/tctl "${pkgdir}/usr/bin/tctl"
+ install -Dm755 build/tsh "${pkgdir}/usr/bin/tsh"
+}