summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRajnish Mishra2020-03-16 04:14:28 +0530
committerRajnish Mishra2020-03-16 04:14:28 +0530
commitee598c3ef87379b6419805dbc934fcd9914d6406 (patch)
tree3bfa43b2ec7ca7006b5e28a1d8e2232c0a0af54a
downloadaur-ee598c3ef87379b6419805dbc934fcd9914d6406.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77e2b47b83a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = teleport-share-git
+ pkgdesc = Send files on the local network
+ pkgver = 0.0.1.r231.3610dff
+ pkgrel = 1
+ url = https://github.com/frac-tion/teleport
+ arch = x86_64
+ license = AGPL
+ makedepends = git
+ makedepends = meson
+ depends = libsoup
+ depends = avahi
+ depends = gtk3
+ source = git+https://github.com/frac-tion/teleport
+ md5sums = SKIP
+
+pkgname = teleport-share-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f639e2db9e52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Rajnish Mishra <contact.rajnishmishra@gmail.com>
+
+pkgname=teleport-share-git
+_pkgname=teleport
+pkgver=0.0.1.r231.3610dff
+pkgrel=1
+pkgdesc="Send files on the local network"
+arch=('x86_64')
+url="https://github.com/frac-tion/teleport"
+license=('AGPL')
+depends=('libsoup' 'avahi' 'gtk3')
+makedepends=('git' 'meson')
+source=("git+https://github.com/frac-tion/teleport")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ v=$(grep -R -A3 '^project(' meson.build | grep 'version:' | cut -d\' -f2)
+ printf "$v.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_pkgname}"
+ sed '/MESONTEST/s/^/#/' -i configure
+}
+
+build() {
+ cd "${_pkgname}"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "${_pkgname}"
+ make check
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 "${srcdir}/${_pkgname}/LICENSE.md" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE.md"
+}