summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2021-07-15 22:08:13 +0200
committerAndrea Feletto2021-07-15 22:08:13 +0200
commit4520b9639a4f0835fc61d6180c68326187625663 (patch)
treeaa592008dc0a486142899e66b9eb4166cf247423
downloadaur-4520b9639a4f0835fc61d6180c68326187625663.tar.gz
version 0.3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1631b40bc329
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = telescope-bin
+ pkgdesc = w3m-like browser for Gemini.
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://telescope.omarpolo.com
+ arch = x86_64
+ license = ISC
+ depends = libretls
+ provides = telescope
+ conflicts = telescope
+ conflicts = telescope-git
+ source = telescope-bin-0.3::https://github.com/omar-polo/telescope/releases/download/0.3/telescope.linux.amd64
+ source = https://raw.githubusercontent.com/omar-polo/telescope/main/telescope.1
+ source = https://raw.githubusercontent.com/omar-polo/telescope/main/LICENSE
+ sha256sums = 6e07c62db694791cb4c7ae8c159ea8ef169ab5f1b83c62ae3a8ac633cf6a648c
+ sha256sums = d7906b357c7bf32161b643f2f3d150b37b59f4ad2c7cfac03015add94a6971f6
+ sha256sums = d74e569d89bef32bc5b9b297e581022674b62e4f9317fa72b971947f9e7ecd67
+
+pkgname = telescope-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6c47335cefb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=telescope-bin
+_pkgname=${pkgname%-*}
+pkgver=0.3
+pkgrel=1
+pkgdesc='w3m-like browser for Gemini.'
+arch=('x86_64')
+url='https://telescope.omarpolo.com'
+license=('ISC')
+provides=('telescope')
+conflicts=('telescope' 'telescope-git')
+depends=('libretls')
+source=(
+ "$pkgname-$pkgver::https://github.com/omar-polo/$_pkgname/releases/download/$pkgver/$_pkgname.linux.amd64"
+ "https://raw.githubusercontent.com/omar-polo/$_pkgname/main/telescope.1"
+ "https://raw.githubusercontent.com/omar-polo/$_pkgname/main/LICENSE"
+)
+sha256sums=(
+ '6e07c62db694791cb4c7ae8c159ea8ef169ab5f1b83c62ae3a8ac633cf6a648c'
+ 'd7906b357c7bf32161b643f2f3d150b37b59f4ad2c7cfac03015add94a6971f6'
+ 'd74e569d89bef32bc5b9b297e581022674b62e4f9317fa72b971947f9e7ecd67'
+)
+
+package() {
+ cd "$srcdir"
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 telescope.1 -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
+}