summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2021-07-16 11:03:19 +0200
committerAndrea Feletto2021-07-16 11:03:19 +0200
commit6905346155ba14bfd7853a63b13a7ef49d3c0bae (patch)
tree5a6f477e7d507d7c44f281cf9000474a73da659a
parent08ca74d76cb3ca16467a4f90084fa16beda6298e (diff)
downloadaur-6905346155ba14bfd7853a63b13a7ef49d3c0bae.tar.gz
version 0.3.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 11 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd5edd6f74ab..a37f8a657d5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = telescope-bin
pkgdesc = w3m-like browser for Gemini.
- pkgver = 0.3
- pkgrel = 2
+ pkgver = 0.3.1
+ pkgrel = 1
url = https://telescope.omarpolo.com
arch = x86_64
license = ISC
@@ -9,11 +9,7 @@ pkgbase = telescope-bin
provides = telescope
conflicts = telescope
conflicts = telescope-git
- source = telescope-bin-0.3::https://github.com/omar-polo/telescope/releases/download/0.3/telescope.linux.amd64
- source = https://raw.githubusercontent.com/omar-polo/telescope/0.3/telescope.1
- source = https://raw.githubusercontent.com/omar-polo/telescope/0.3/LICENSE
- sha256sums = 6e07c62db694791cb4c7ae8c159ea8ef169ab5f1b83c62ae3a8ac633cf6a648c
- sha256sums = 8df526e8aa0f5e534f2d3354bec5351ea356120bdeceec3acc115e0811fc7926
- sha256sums = d74e569d89bef32bc5b9b297e581022674b62e4f9317fa72b971947f9e7ecd67
+ source = https://github.com/omar-polo/telescope/releases/download/0.3.1/telescope-0.3.1-binaries.tar.gz
+ sha256sums = SKIP
pkgname = telescope-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6cf476dff9f9..3b1eae631b9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=telescope-bin
_pkgname=${pkgname%-*}
-pkgver=0.3
-pkgrel=2
+pkgver=0.3.1
+pkgrel=1
pkgdesc='w3m-like browser for Gemini.'
arch=('x86_64')
url='https://telescope.omarpolo.com'
@@ -12,20 +12,13 @@ license=('ISC')
provides=('telescope')
conflicts=('telescope' 'telescope-git')
depends=('libretls')
-source=(
- "$pkgname-$pkgver::https://github.com/omar-polo/$_pkgname/releases/download/$pkgver/$_pkgname.linux.amd64"
- "https://raw.githubusercontent.com/omar-polo/$_pkgname/$pkgver/telescope.1"
- "https://raw.githubusercontent.com/omar-polo/$_pkgname/$pkgver/LICENSE"
-)
-sha256sums=(
- '6e07c62db694791cb4c7ae8c159ea8ef169ab5f1b83c62ae3a8ac633cf6a648c'
- '8df526e8aa0f5e534f2d3354bec5351ea356120bdeceec3acc115e0811fc7926'
- 'd74e569d89bef32bc5b9b297e581022674b62e4f9317fa72b971947f9e7ecd67'
-)
+source=("https://github.com/omar-polo/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver-binaries.tar.gz")
+sha256sums=('SKIP')
package() {
- cd "$srcdir"
- install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
+ cd "$srcdir/$_pkgname-$pkgver-binaries"
+ install -Dm755 "$_pkgname.linux.amd64" "$pkgdir/usr/bin/$_pkgname"
install -Dm644 telescope.1 -t "$pkgdir/usr/share/man/man1"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
}