summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-11-05 23:55:58 +0100
committerMuflone2015-11-05 23:55:58 +0100
commitb6e66af1d2364cc55be669bc4fbc078dc80e2379 (patch)
treeddb5f866d33891f15b4cac562f05a08c73e4ef49
parent660bcb76cd5f3167ecc801e6c41706df1f4476c0 (diff)
downloadaur-b6e66af1d2364cc55be669bc4fbc078dc80e2379.tar.gz
Updated package temp-throttle-git r53.311790a-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
-rw-r--r--temp-throttle@.service9
3 files changed, 17 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a76a0a37f773..7c096b09905c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = temp-throttle-git
pkgdesc = A shell script for throttling system CPU frequency based on a desired maximum temperature.
- pkgver = r37.4199e7e
+ pkgver = r53.311790a
pkgrel = 1
url = https://github.com/Sepero/temp-throttle
arch = any
license = GPL2
makedepends = git
depends = bash
- source = git://github.com/Sepero/temp-throttle.git
- source = temp-throttle@.service
+ conflicts = temp-throttle
+ source = git://github.com/Sepero/temp-throttle.git#branch=testing
sha256sums = SKIP
- sha256sums = 18ae3edd7b41508da279df6d67f1c5d86e1dbfe2daebbc42bbe39c26031b22e0
pkgname = temp-throttle-git
diff --git a/PKGBUILD b/PKGBUILD
index 2e6a078a9ef0..7ef9516c83c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Ryan Young <ry an. ry. young@gmail.com> (omit spaces)
pkgname=temp-throttle-git
-pkgver=r37.4199e7e
+pkgver=r53.311790a
pkgrel=1
pkgdesc="A shell script for throttling system CPU frequency based on a desired maximum temperature."
arch=('any')
@@ -10,10 +10,9 @@ url="https://github.com/Sepero/temp-throttle"
license=('GPL2')
depends=('bash')
makedepends=('git')
-source=('git://github.com/Sepero/temp-throttle.git'
- 'temp-throttle@.service')
-sha256sums=('SKIP'
- '18ae3edd7b41508da279df6d67f1c5d86e1dbfe2daebbc42bbe39c26031b22e0')
+conflicts=("temp-throttle")
+source=("git://github.com/Sepero/${pkgname%-git}.git#branch=testing")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
@@ -22,11 +21,18 @@ pkgver() {
package() {
cd "${pkgname%-git}"
+ # Install executable
install -m 755 -d "${pkgdir}/usr/bin"
- install -m 755 'temp_throttle.sh' "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -m 755 -t "${pkgdir}/usr/bin" "usr/sbin/${pkgname%-git}"
+ # Install configuration file
+ install -m 755 -d "${pkgdir}/etc"
+ install -m 755 -t "${pkgdir}/etc" "etc/${pkgname%-git}.conf"
+ # Install documentation
install -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}"
- install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" "README.md"
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" "usr/share/doc/${pkgname%-git}/README"
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" "usr/share/doc/${pkgname%-git}/credits.txt"
+ # Install systemd service
install -m 755 -d "${pkgdir}/usr/lib/systemd/system"
- install -m 644 -t "${pkgdir}/usr/lib/systemd/system" "${srcdir}/${pkgname%-git}@.service"
+ install -m 644 -t "${pkgdir}/usr/lib/systemd/system" "usr/lib/systemd/system/${pkgname%-git}@.service"
}
diff --git a/temp-throttle@.service b/temp-throttle@.service
deleted file mode 100644
index c20e4f915722..000000000000
--- a/temp-throttle@.service
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=Throttle system CPU frequency based on a maximum temperature
-
-[Service]
-ExecStart=/usr/bin/temp-throttle %i
-Type=simple
-
-[Install]
-WantedBy=multi-user.target