summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2018-10-02 22:49:46 -0700
committerSandy Carter2018-10-02 22:49:46 -0700
commit1a103007fcf4e1ce3ea79c9557d7d21698314fa0 (patch)
tree1d30ac1c5023a9dd7d6d6a16fc94dd757862390c
parent9c75eaf97ea2567eb4ea50022c73432c2a49d9ba (diff)
downloadaur-1a103007fcf4e1ce3ea79c9557d7d21698314fa0.tar.gz
Update to new clang
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bee09f4656a4..f1f5a1319401 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = templight-git
pkgdesc = Template Instantiation Profiler and Debugger
- pkgver = r138.91589f9
- pkgrel = 2
+ pkgver = r140.9624f09
+ pkgrel = 1
url = https://github.com/mikael-s-persson/templight
arch = x86_64
license = custom:University of Illinois/NCSA Open Source License
@@ -20,11 +20,9 @@ pkgbase = templight-git
source = llvm::svn+http://llvm.org/svn/llvm-project/llvm/trunk
source = cfe::svn+http://llvm.org/svn/llvm-project/cfe/trunk
source = git://github.com/mikael-s-persson/templight.git
- source = GetArgumentVectorFix.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = dbc8086e8c2f05ddd4128fd3a0d39261eed19ffd0c9509a50ad656a8a5936c1f
pkgname = templight-git
diff --git a/PKGBUILD b/PKGBUILD
index 5141bdf0eb3a..6ccb8db4a7ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=templight-git
-pkgver=r138.91589f9
-pkgrel=2
+pkgver=r140.9624f09
+pkgrel=1
pkgdesc="Template Instantiation Profiler and Debugger"
arch=('x86_64')
url="https://github.com/mikael-s-persson/templight"
@@ -12,12 +12,10 @@ provides=("templight")
conflicts=("templight" "clang-trunk")
source=(llvm::svn+http://llvm.org/svn/llvm-project/llvm/trunk
cfe::svn+http://llvm.org/svn/llvm-project/cfe/trunk
- git://github.com/mikael-s-persson/templight.git
- GetArgumentVectorFix.patch)
+ git://github.com/mikael-s-persson/templight.git)
sha256sums=('SKIP'
'SKIP'
- 'SKIP'
- 'dbc8086e8c2f05ddd4128fd3a0d39261eed19ffd0c9509a50ad656a8a5936c1f')
+ 'SKIP')
pkgver() {
cd "$srcdir/templight"
@@ -27,10 +25,6 @@ pkgver() {
prepare() {
cd ${srcdir}/templight
- # Patch templight
- # https://github.com/mikael-s-persson/templight/issues/65
- patch -p1 -i ${srcdir}/GetArgumentVectorFix.patch
-
# Checkout minimal clang and add templight to tools
cp -r ${srcdir}/cfe ${srcdir}/llvm/tools/clang
cp -r ${srcdir}/templight ${srcdir}/llvm/tools/clang/tools/templight