summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-10-28 09:28:00 -0600
committeryochananmarqos2019-10-28 09:28:00 -0600
commit5345b836784aa4dbfc29062a14d0c3c406a97f9f (patch)
tree8542b54dcd853aebbe6876a81960ad72b04b797d
downloadaur-5345b836784aa4dbfc29062a14d0c3c406a97f9f.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2ef23f11db4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tempus-themes-xfce4-terminal-git
+ pkgdesc = Tempus themes for Xfce4 Terminal
+ pkgver = r26.04b04e2
+ pkgrel = 1
+ url = https://protesilaos.com/tempus-themes
+ arch = any
+ license = GPL3
+ depends = xfce4-terminal
+ provides = tempus-themes-xfce4-terminal
+ conflicts = tempus-themes-xfce4-terminal
+ source = git+https://gitlab.com/protesilaos/tempus-themes-xfce4-terminal.git
+ sha256sums = SKIP
+
+pkgname = tempus-themes-xfce4-terminal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac62ed478838
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+# Contributor: Protesilaos Stavrou <info at protesilaos dot com>
+pkgname=tempus-themes-xfce4-terminal-git
+pkgver=r26.04b04e2
+pkgrel=1
+pkgdesc="Tempus themes for Xfce4 Terminal"
+arch=('any')
+url="https://protesilaos.com/tempus-themes"
+license=('GPL3')
+depends=('xfce4-terminal')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://gitlab.com/protesilaos/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/xfce4/terminal/colorschemes"
+ install -Dm644 *.theme "$pkgdir/usr/share/xfce4/terminal/colorschemes"
+}