summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoprobelm2023-06-25 20:16:56 -0400
committernoprobelm2023-06-25 20:16:56 -0400
commit24bb787516cfe07d75ae7b0bd8858ab97ba575bc (patch)
tree1ab5dc5fef4182fa96ee74d3e447c9836bf33c89
downloadaur-24bb787516cfe07d75ae7b0bd8858ab97ba575bc.tar.gz
First commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f56d9a865dc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tempy
+ pkgdesc = Render visually pleasing weather reports as rich text to your terminal
+ pkgver = 1.2.1.r69.03ae0fa
+ pkgrel = 1
+ url = https://github.com/noprobelm/tempy.git
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-poetry-core
+ depends = python-rich
+ depends = python-requests
+ provides = tempy
+ source = tempy::git+https://github.com/noprobelm/tempy.git
+ md5sums = SKIP
+
+pkgname = tempy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf847aa1b399
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: noprobelm@protonmail.com
+pkgname=tempy
+pkgver=1.2.1.r75.1a8d27f
+pkgrel=1
+pkgdesc="Render visually pleasing weather reports as rich text to your terminal"
+arch=(any)
+url="https://github.com/noprobelm/tempy.git"
+license=('MIT')
+groups=()
+depends=(python-rich python-requests)
+makedepends=(git python-setuptools python-build python-installer python-wheel python-poetry-core)
+optdepends=()
+provides=(tempy)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname"::"git+$url")
+noextract=()
+md5sums=('SKIP') #autofill using updpkgsums
+
+pkgver() {
+ cd "$pkgname"
+ printf "1.2.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd tempy
+ /usr/bin/python3 -m build --wheel --no-isolation
+}
+
+package() {
+ cd tempy
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}