summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2014-05-05 11:35:21 +0800
committerAllen Zhong2014-05-05 11:35:21 +0800
commit0b6cec0249cee96d6e9d10136b7a3f8f61598a2b (patch)
treec1dca0a28286c373548f66a944eab78a76c78726
downloadaur-0b6cec0249cee96d6e9d10136b7a3f8f61598a2b.tar.gz
newpkg: tengine-extra 2.0.2-1
This package enables some extra features comparing to tengine: + DSO feature * http_flv_module changed to shared * http_mp4_module changed to shared * http_sub_module changed to shared + http_geoip_module added as shared + http_lua_module added as shared + http_memcached_module added as shared + http_secure_link_module added as shared
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD112
-rw-r--r--logrotate9
-rw-r--r--service14
-rw-r--r--tengine.install6
5 files changed, 179 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42401ba71601
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = tengine-extra
+ pkgdesc = A web server based on Nginx and has many advanced features, originated by Taobao. Some extra modules enabled.
+ pkgver = 2.1.0
+ pkgrel = 5
+ url = http://tengine.taobao.org
+ install = tengine.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = lua51
+ makedepends = geoip
+ depends = pcre
+ depends = zlib
+ depends = openssl
+ depends = gperftools
+ optdepends = lua51: needed by http_lua_module
+ optdepends = geoip: needed by http_geoip_module
+ optdepends = memcached: needed by http_memcached_module
+ conflicts = tengine
+ backup = etc/tengine/fastcgi.conf
+ backup = etc/tengine/fastcgi_params
+ backup = etc/tengine/koi-win
+ backup = etc/tengine/koi-utf
+ backup = etc/tengine/mime.types
+ backup = etc/tengine/tengine.conf
+ backup = etc/tengine/scgi_params
+ backup = etc/tengine/uwsgi_params
+ backup = etc/tengine/win-utf
+ backup = etc/logrotate.d/tengine
+ source = http://tengine.taobao.org/download/tengine-2.1.0.tar.gz
+ source = service
+ source = logrotate
+ sha256sums = 6d98e217deb6676438f0704eb51736239e390624479fedb8c59ebf7a8a30e7b3
+ sha256sums = 7abffe0f1ba1ea4d6bd316350a03257cc840a9fbb2e1b640c11e0eb9351a9044
+ sha256sums = 22d7f8f7d8f3c320d3c6af8a76e6cc5b64451670cdeecb9f400000ceea91b4cb
+
+pkgname = tengine-extra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9b7ec4d367b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,112 @@
+# $Id$
+# Maintainer: Allen Zhong <moeallenz@gmail.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Sébastien Luttringer
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Miroslaw Szot <mss@czlug.icis.pcz.pl>
+
+pkgname=tengine-extra
+pkgver=2.0.2
+pkgrel=1
+pkgdesc='A web server based on Nginx and has many advanced features, originated by Taobao. Some extra modules enabled.'
+arch=('i686' 'x86_64')
+url='http://tengine.taobao.org'
+license=('custom')
+depends=('pcre' 'zlib' 'openssl' 'gperftools')
+makedepends=('lua51' 'geoip')
+backup=('etc/tengine/fastcgi.conf'
+ 'etc/tengine/fastcgi_params'
+ 'etc/tengine/koi-win'
+ 'etc/tengine/koi-utf'
+ 'etc/tengine/mime.types'
+ 'etc/tengine/tengine.conf'
+ 'etc/tengine/scgi_params'
+ 'etc/tengine/uwsgi_params'
+ 'etc/tengine/win-utf'
+ 'etc/logrotate.d/tengine')
+install=tengine.install
+conflicts=('tengine' 'tengine-dev')
+optdepends=(
+ 'lua51: needed by http_lua_module'
+ 'geoip: needed by http_geoip_module'
+ 'memcached: needed by http_memcached_module')
+source=($url/download/tengine-$pkgver.tar.gz
+ service
+ logrotate)
+sha256sums=('03aaf217d9ddd43f19f3effb9784e031900e41feb5ef399e3e7b0dabc1b89ec7'
+ '622205fb90998de2ebacac61c8eee748f89c193d14be44ee39e08ae1e257c90f'
+ '245c23906db2a9642fed996ff969e127989a6dcae865c1dd8b422e23ebc94f42')
+
+build() {
+ cd tengine-$pkgver
+
+ ./configure \
+ --prefix=/etc/tengine \
+ --conf-path=/etc/tengine/tengine.conf \
+ --sbin-path=/usr/bin/tengine \
+ --dso-path=/etc/tengine/modules \
+ --dso-tool-path=/etc/tengine/sbin \
+ --pid-path=/run/tengine.pid \
+ --lock-path=/run/lock/tengine.lock \
+ --user=http \
+ --group=http \
+ --http-log-path=/var/log/tengine/access.log \
+ --error-log-path=stderr \
+ --http-client-body-temp-path=/var/lib/tengine/client-body \
+ --http-proxy-temp-path=/var/lib/tengine/proxy \
+ --http-fastcgi-temp-path=/var/lib/tengine/fastcgi \
+ --http-scgi-temp-path=/var/lib/tengine/scgi \
+ --http-uwsgi-temp-path=/var/lib/tengine/uwsgi \
+ --with-imap \
+ --with-imap_ssl_module \
+ --with-ipv6 \
+ --with-pcre-jit \
+ --with-file-aio \
+ --with-google_perftools_module \
+ --with-http_dav_module \
+ --with-http_geoip_module=shared \
+ --with-http_gunzip_module \
+ --with-http_gzip_static_module \
+ --with-http_lua_module=shared \
+ --with-http_memcached_module=shared \
+ --with-http_realip_module \
+ --with-http_secure_link_module=shared \
+ --with-http_spdy_module \
+ --with-http_ssl_module \
+ --with-http_stub_status_module \
+ --with-http_addition_module \
+ --with-http_degradation_module \
+ --with-http_flv_module=shared \
+ --with-http_mp4_module=shared\
+ --with-http_secure_link_module \
+ --with-http_sub_module=shared
+
+ make
+}
+
+package() {
+ cd tengine-$pkgver
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" dso_install
+
+ sed -e 's|\<user\s\+\w\+;|user html;|g' \
+ -e '44s|html|/usr/share/tengine/html|' \
+ -e '54s|html|/usr/share/tengine/html|' \
+ -i "$pkgdir"/etc/tengine/tengine.conf
+ rm "$pkgdir"/etc/tengine/*.default
+
+ install -d "$pkgdir"/var/lib/tengine
+ install -dm700 "$pkgdir"/var/lib/tengine/proxy
+
+ chmod 750 "$pkgdir"/var/log/tengine
+ chown http:log "$pkgdir"/var/log/tengine
+
+ install -d "$pkgdir"/usr/share/tengine
+ mv "$pkgdir"/etc/tengine/html/ "$pkgdir"/usr/share/tengine
+
+ install -Dm644 "$srcdir"/logrotate "$pkgdir"/etc/logrotate.d/tengine
+ install -Dm644 "$srcdir"/service "$pkgdir"/usr/lib/systemd/system/tengine.service
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/tengine/LICENSE
+ rmdir "$pkgdir"/run
+}
+
diff --git a/logrotate b/logrotate
new file mode 100644
index 000000000000..278c2f08c32a
--- /dev/null
+++ b/logrotate
@@ -0,0 +1,9 @@
+/var/log/tengine/*log {
+ missingok
+ create 640 http log
+ sharedscripts
+ compress
+ postrotate
+ test -r /var/run/tengine.pid && kill -USR1 `cat /var/run/tengine.pid`
+ endscript
+}
diff --git a/service b/service
new file mode 100644
index 000000000000..321fd16d417c
--- /dev/null
+++ b/service
@@ -0,0 +1,14 @@
+[Unit]
+Description=A web server based on Nginx and has many advanced features
+After=syslog.target network.target
+
+[Service]
+Type=forking
+PIDFile=/run/tengine.pid
+ExecStartPre=/usr/bin/tengine -t -q -g 'pid /run/tengine.pid; daemon on; master_process on;'
+ExecStart=/usr/bin/tengine -g 'pid /run/tengine.pid; daemon on; master_process on;'
+ExecReload=/usr/bin/tengine -g 'pid /run/tengine.pid; daemon on; master_process on;' -s reload
+ExecStop=/usr/bin/tengine -g 'pid /run/tengine.pid;' -s quit
+
+[Install]
+WantedBy=multi-user.target
diff --git a/tengine.install b/tengine.install
new file mode 100644
index 000000000000..adeffdec0dc7
--- /dev/null
+++ b/tengine.install
@@ -0,0 +1,6 @@
+post_upgrade() {
+ if [[ $(vercmp $2 1.4.3-3) -le 0 ]]; then
+ chmod 750 var/log/tengine
+ chown http:log var/log/tengine
+ fi
+}