summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2023-09-06 09:13:31 +0900
committerAllen Zhong2023-09-06 09:13:31 +0900
commit5ee3f27efdefa0c05441819017ea16708369326b (patch)
treefd61601860c9edf0123aaf7f4f2f3772e34c3d78
parent9aca860af98fa0d2cbffa1bd61b711240078d9e8 (diff)
downloadaur-5ee3f27efdefa0c05441819017ea16708369326b.tar.gz
disable lua for now
* It seems 3.0.0 does not run with luajit in repo, disable for now until I figure out how to fix that
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ce07bf18fcc..68f466988952 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tengine-extra
pkgdesc = A web server based on Nginx and has many advanced features, originated by Taobao. Some extra modules enabled.
pkgver = 3.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://tengine.taobao.org
install = tengine.install
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = tengine-extra
depends = mailcap
depends = libxcrypt
depends = luajit
+ depends = lua-resty-core
depends = libmaxminddb
provides = nginx
provides = tengine
diff --git a/PKGBUILD b/PKGBUILD
index b604ae32f2d3..0a91d5bc338c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,12 +12,23 @@
_tcp_module_gitname=nginx_tcp_proxy_module
pkgname=tengine-extra
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='A web server based on Nginx and has many advanced features, originated by Taobao. Some extra modules enabled.'
arch=('x86_64')
url='http://tengine.taobao.org'
license=('custom')
-depends=('pcre' 'zlib' 'openssl' 'gperftools' 'geoip' 'mailcap' 'libxcrypt' 'luajit' 'libmaxminddb')
+depends=(
+ 'pcre'
+ 'zlib'
+ 'openssl'
+ 'gperftools'
+ 'geoip'
+ 'mailcap'
+ 'libxcrypt'
+ #'luajit'
+ #'lua-resty-core'
+ 'libmaxminddb'
+)
backup=(etc/tengine/fastcgi.conf
etc/tengine/fastcgi_params
etc/tengine/koi-win
@@ -53,8 +64,9 @@ sha256sums=('a47dce983dd34389e4c4d1afda03c74c2d3fe1d7a0a51fc86cc2046d2f4a0e5b'
build() {
cd tengine-$pkgver
- export LUAJIT_LIB=/usr/lib
- export LUAJIT_INC=/usr/include/luajit-2.1
+ #export LUAJIT_LIB=/usr/lib
+ #export LUAJIT_INC=/usr/include/luajit-2.1
+ #--with-ld-opt="${LDFLAGS// /,},-lpcre,-rpath,$LUAJIT_LIB" \
./configure \
--prefix=/etc/tengine \
--conf-path=/etc/tengine/tengine.conf \
@@ -72,7 +84,7 @@ build() {
--http-scgi-temp-path=/var/lib/tengine/scgi \
--http-uwsgi-temp-path=/var/lib/tengine/uwsgi \
--with-cc-opt="$CFLAGS $CPPFLAGS" \
- --with-ld-opt="${LDFLAGS// /,},-lpcre,-rpath,$LUAJIT_LIB" \
+ --with-ld-opt="$LDFLAGS" \
--with-compat \
--with-file-aio \
--with-google_perftools_module \
@@ -84,7 +96,6 @@ build() {
--with-http_geoip_module \
--with-http_gunzip_module \
--with-http_gzip_static_module \
- --with-http_lua_module \
--with-http_mp4_module \
--with-http_realip_module \
--with-http_secure_link_module \