summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2018-06-23 21:34:43 +0800
committerAllen Zhong2018-06-23 21:34:43 +0800
commitf23c874a44440adc5a01dbba1b60eeef9a14ab49 (patch)
tree29530c2ca56ddcf47fa796df4cdab866af1a312b
parent85235f5e668ba2a7c7131dbef49e6179093aa4b1 (diff)
downloadaur-f23c874a44440adc5a01dbba1b60eeef9a14ab49.tar.gz
update tcp proxy module
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a88d5a33588..e3452b717fdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jan 30 06:06:25 UTC 2018
+# Mon Mar 5 04:42:11 UTC 2018
pkgbase = tengine-extra
pkgdesc = A web server based on Nginx and has many advanced features, originated by Taobao. Some extra modules enabled.
pkgver = 2.2.2
- pkgrel = 2
+ pkgrel = 3
url = http://tengine.taobao.org
install = tengine.install
arch = i686
@@ -32,9 +32,11 @@ pkgbase = tengine-extra
backup = etc/tengine/win-utf
backup = etc/logrotate.d/tengine
source = http://tengine.taobao.org/download/tengine-2.2.2.tar.gz
+ source = git+https://github.com/yaoweibin/nginx_tcp_proxy_module.git
source = service
source = logrotate
- sha256sums = 7ba9dabc17d68b43fd777c7bb3e4bf6a2296540d4bfe18e18f7fddf386fb2394
+ sha256sums = f27e9891d4f37d265648963e3af9a78d10f143fa92453263bc533cadf4b2d846
+ sha256sums = SKIP
sha256sums = bbc2a744fcc65b496549a312a19aba2ee87840ad36a523c2e6bc2a585861bbcd
sha256sums = 7d4bd60b9210e1dfb46bc52c344b069d5639e1ba08cd9951c0563360af238f97
diff --git a/PKGBUILD b/PKGBUILD
index 549c34d0d522..b6a26b8b7f8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_tcp_module_gitname=nginx_tcp_proxy_module
pkgname=tengine-extra
pkgver=2.2.2
-pkgrel=2
+pkgrel=3
pkgdesc='A web server based on Nginx and has many advanced features, originated by Taobao. Some extra modules enabled.'
arch=('i686' 'x86_64')
url='http://tengine.taobao.org'
@@ -31,25 +31,19 @@ optdepends=(
'lua51: needed by http_lua_module'
'memcached: needed by http_memcached_module')
source=($url/download/tengine-$pkgver.tar.gz
+ git+https://github.com/yaoweibin/$_tcp_module_gitname.git
service
logrotate
)
-sha256sums=('7ba9dabc17d68b43fd777c7bb3e4bf6a2296540d4bfe18e18f7fddf386fb2394'
+sha256sums=('f27e9891d4f37d265648963e3af9a78d10f143fa92453263bc533cadf4b2d846'
+ 'SKIP'
'bbc2a744fcc65b496549a312a19aba2ee87840ad36a523c2e6bc2a585861bbcd'
'7d4bd60b9210e1dfb46bc52c344b069d5639e1ba08cd9951c0563360af238f97')
prepare() {
cd "$srcdir"
- msg "Applying the TCP Proxy module..."
- msg "Connecting to GIT server..."
- if [ -d $_tcp_module_gitname ]; then
- git fetch https://github.com/yaoweibin/$_tcp_module_gitname.git
- msg "The local files are updated."
- else
- git clone --depth=1 https://github.com/yaoweibin/$_tcp_module_gitname.git
- fi
- msg "GIT checkout done or server timeout"
+ msg "Applying the TCP Proxy module..."
cd "$srcdir"/tengine-$pkgver
patch -p1 -i "$srcdir"/"$_tcp_module_gitname"/tcp.patch
}