summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-15 18:54:57 -0400
committerJean Lucas2019-08-15 18:54:57 -0400
commit93c103608c59baa74a36fbe373c38c5895d90297 (patch)
tree488a56773c428d27c96c48218c6675067ddf12de
parentff1faae1b8c06713592f425b0791be7cbd94b10e (diff)
downloadaur-93c103608c59baa74a36fbe373c38c5895d90297.tar.gz
Add openssl to deps; update pkgver schema
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0f78e0ed92d..243520ed6d16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tenshi-rs-git
pkgdesc = Unbound local-zone generator for curated hosts files (git)
pkgver = 0.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/flacks/tenshi
arch = aarch64
arch = armv6h
@@ -11,6 +11,7 @@ pkgbase = tenshi-rs-git
license = GPL3
makedepends = git
makedepends = cargo
+ depends = openssl
optdepends = sudo: to write to destination as another user
provides = tenshi-rs
conflicts = tenshi-rs
diff --git a/PKGBUILD b/PKGBUILD
index 56f22b88e098..be5514fa4cd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
pkgname=tenshi-rs-git
pkgver=0.2.2
-pkgrel=1
+pkgrel=2
pkgdesc='Unbound local-zone generator for curated hosts files (git)'
arch=(aarch64 armv6h armv7h i686 x86_64)
url=https://github.com/flacks/tenshi
license=(GPL3)
+depends=(openssl)
makedepends=(git cargo)
optdepends=('sudo: to write to destination as another user')
provides=(tenshi-rs)
@@ -16,7 +17,7 @@ sha512sums=(SKIP)
pkgver() {
cd tenshi
- git describe --tags | sed 's#-#+#g'
+ git describe --tags | sed 's#-#+#g;s#+#+r#'
}
build() {