summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-05-19 20:57:29 -0400
committerJean Lucas2019-05-19 20:57:29 -0400
commitd10f1ef8f9511b9ca66c5e883d8571a4d7f8d08a (patch)
treef5289cb11a04a20e102dbc20d825efc795656bf6
downloadaur-d10f1ef8f9511b9ca66c5e883d8571a4d7f8d08a.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43ed17019d5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = tenshi-rs-git
+ pkgdesc = Unbound local-data generator for curated hosts files (git)
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/flacks/tenshi
+ arch = aarch64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = rust
+ optdepends = sudo: to write to destination as unprivileged user
+ provides = tenshi-rs
+ conflicts = tenshi-rs
+ source = git+https://github.com/flacks/tenshi
+ sha512sums = SKIP
+
+pkgname = tenshi-rs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e02de87bf9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=tenshi-rs-git
+pkgver=0.1.3
+pkgrel=1
+pkgdesc='Unbound local-data generator for curated hosts files (git)'
+arch=(aarch64 arm armv6h armv7h i686 x86_64)
+url=https://github.com/flacks/tenshi
+license=(GPL3)
+makedepends=(git rust)
+optdepends=('sudo: to write to destination as unprivileged user')
+provides=(tenshi-rs)
+conflicts=(tenshi-rs)
+source=(git+$url)
+sha512sums=(SKIP)
+
+pkgver() {
+ cd tenshi
+ git describe --tags | sed 's#-#+#g'
+}
+
+build() {
+ cd tenshi
+ cargo build --release --locked
+}
+
+package() {
+ cd tenshi
+ install -D target/release/tenshi "$pkgdir"/usr/bin/tenshi-rs
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/tenshi-rs
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/tenshi-rs
+}