summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-06-11 00:16:37 -0400
committerJean Lucas2019-06-11 00:16:37 -0400
commitff1faae1b8c06713592f425b0791be7cbd94b10e (patch)
tree5ec998d5a53eb5dc2b3fb1e32fb7f4d14f6496d0
parent2f18c5a2f621eee4ee2b54ed729402e00c6e0378 (diff)
downloadaur-ff1faae1b8c06713592f425b0791be7cbd94b10e.tar.gz
Change destination directory and binary name, remove incompatible arch, replace rust with cargo as makedepends, 0.2.2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3824b915a4dc..f0f78e0ed92d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = tenshi-rs-git
pkgdesc = Unbound local-zone generator for curated hosts files (git)
- pkgver = 0.2.1
+ pkgver = 0.2.2
pkgrel = 1
url = https://github.com/flacks/tenshi
arch = aarch64
- arch = arm
arch = armv6h
arch = armv7h
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- makedepends = rust
+ makedepends = cargo
optdepends = sudo: to write to destination as another user
provides = tenshi-rs
conflicts = tenshi-rs
diff --git a/PKGBUILD b/PKGBUILD
index 2ddd97558655..56f22b88e098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=tenshi-rs-git
-pkgver=0.2.1
+pkgver=0.2.2
pkgrel=1
pkgdesc='Unbound local-zone generator for curated hosts files (git)'
-arch=(aarch64 arm armv6h armv7h i686 x86_64)
+arch=(aarch64 armv6h armv7h i686 x86_64)
url=https://github.com/flacks/tenshi
license=(GPL3)
-makedepends=(git rust)
+makedepends=(git cargo)
optdepends=('sudo: to write to destination as another user')
provides=(tenshi-rs)
conflicts=(tenshi-rs)
@@ -26,7 +26,7 @@ build() {
package() {
cd tenshi
- install -D target/release/tenshi "$pkgdir"/usr/bin/tenshi-rs
- install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/tenshi-rs
- install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/tenshi-rs
+ install -D target/release/tenshi -t "$pkgdir"/usr/bin
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/tenshi
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/tenshi
}