aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-12-22 00:29:58 -0500
committeracxz2020-12-22 00:29:58 -0500
commit0bee37e4ab51fde13123f28ffc037d667bd71c5f (patch)
treed7de4f484b6f2d6fb25690aef675e67e9a50cfb1
parent43d4b3d57a605f89713c2af7c07055f3216a2f2b (diff)
downloadaur-0bee37e4ab51fde13123f28ffc037d667bd71c5f.tar.gz
add amdgpu targets based on supported hardware
See https://github.com/RadeonOpenCompute/ROCm#Hardware-and-Software-Support for list and https://llvm.org/docs/AMDGPUUsage.html#processors for gfx codes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64374efa83ac..1a8b80279dc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tensorflow-rocm
pkgdesc = Library for computation using data flow graphs for scalable machine learning
pkgver = 2.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.tensorflow.org/
arch = x86_64
license = APACHE
diff --git a/PKGBUILD b/PKGBUILD
index bf83faacdcf1..29dc8750455f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=()
pkgver=2.4.0
_pkgver=2.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Library for computation using data flow graphs for scalable machine learning"
url="https://www.tensorflow.org/"
license=('APACHE')
@@ -93,6 +93,7 @@ build() {
export TF_NEED_NGRAPH=0
export TF_NEED_IGNITE=0
export TF_NEED_ROCM=1
+ export TF_ROCM_AMDGPU_TARGETS=gfx701,gfx702,gfx803,gfx900,gfx904,gfx906,gfx908
# See https://github.com/tensorflow/tensorflow/blob/master/third_party/systemlibs/syslibs_configure.bzl
export TF_SYSTEM_LIBS="boringssl,curl,cython,gif,icu,libjpeg_turbo,lmdb,nasm,pcre,png,pybind11,zlib"
export TF_SET_ANDROID_WORKSPACE=0