summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnihcam2018-05-06 07:19:08 +0800
committerEnihcam2018-05-06 07:19:08 +0800
commit0adce8869f9d62caa12bcd193ecef45e340a4d1d (patch)
tree6910101ca3cf00865729dd959ccde224271018f1
parent0c7da879c3b70fd6b9379c6e94fcf3892a769c85 (diff)
downloadaur-0adce8869f9d62caa12bcd193ecef45e340a4d1d.tar.gz
- read CFLAGS from makepkg.conf
- fixed that ccache does not work in bazel
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2177b37aa10f..0e20089593e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tensorflow-computecpp
pkgdesc = Library for computation using data flow graphs for scalable machine learning (backend with ComputeCpp)
- pkgver = ComputeCpp+0.6.0+30+g4cc789977d
+ pkgver = ComputeCpp+0.6.0+31+g0367804e7e
pkgrel = 1
url = https://github.com/lukeiwanski/tensorflow
arch = x86_64
@@ -15,6 +15,7 @@ pkgbase = tensorflow-computecpp
makedepends = python-setuptools
depends = opencl-icd-loader
depends = computecpp
+ options = !ccache
source = git+https://github.com/lukeiwanski/tensorflow#branch=dev/amd_gpu
source = 17508.patch
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 668ca7138757..d129745ceb24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=tensorflow-computecpp
pkgname=(tensorflow-computecpp python-tensorflow-computecpp)
-pkgver=ComputeCpp+0.6.0+30+g4cc789977d
+pkgver=ComputeCpp+0.6.0+31+g0367804e7e
pkgrel=1
pkgdesc="Library for computation using data flow graphs for scalable machine learning (backend with ComputeCpp)"
url="https://github.com/lukeiwanski/tensorflow"
@@ -10,6 +10,7 @@ license=('APACHE')
arch=('x86_64')
depends=(opencl-icd-loader computecpp)
makedepends=(git opencl-icd-loader computecpp bazel python-numpy python-pip python-wheel python-setuptools)
+options=(!ccache)
source=("git+${url}#branch=dev/amd_gpu"
17508.patch)
sha512sums=('SKIP'
@@ -26,9 +27,7 @@ prepare() {
# These environment variables influence the behavior of the configure call below.
export PYTHON_BIN_PATH=/usr/bin/python
export USE_DEFAULT_PYTHON_LIB_PATH=1
- export HOST_CXX_COMPILER=/usr/bin/g++
- export HOST_C_COMPILER=/usr/bin/gcc
- export CC_OPT_FLAGS="-march=native -mfpmath=sse -O2 -pipe -fstack-protector-strong"
+ export CC_OPT_FLAGS="${CFLAGS}"
export TF_CUDA_CLANG=0
export TF_NEED_CUDA=0
export TF_NEED_JEMALLOC=0
@@ -45,8 +44,6 @@ prepare() {
export TF_NEED_OPENCL=1
export TF_NEED_OPENCL_SYCL=1
export TF_NEED_COMPUTECPP=1
- export TF_USE_HALF_SYCL=0
- export TF_USE_DOUBLE_SYCL=1
export TF_SYCL_BITCODE_TARGET=spir64
export COMPUTECPP_TOOLKIT_PATH=/opt/ComputeCpp-CE
export COMPUTE=:0