summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnihcam2018-07-22 22:11:32 +0800
committerEnihcam2018-07-22 22:11:32 +0800
commit11ebf893086e2bd5be62078bce183c40c5d4faf6 (patch)
tree80db6e55628a3fb9c1265718761762f4dbc605a5
parente993e467d632b86dd365dcfe647efcb5d42c8492 (diff)
downloadaur-11ebf893086e2bd5be62078bce183c40c5d4faf6.tar.gz
compile from the branch integrations/1.8
-rw-r--r--.SRCINFO7
-rw-r--r--17508.patch28
-rw-r--r--PKGBUILD19
3 files changed, 9 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e20089593e0..c1c7151f2a5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = tensorflow-computecpp
pkgdesc = Library for computation using data flow graphs for scalable machine learning (backend with ComputeCpp)
- pkgver = ComputeCpp+0.6.0+31+g0367804e7e
+ pkgver = 1.8
pkgrel = 1
+ epoch = 1
url = https://github.com/lukeiwanski/tensorflow
arch = x86_64
license = APACHE
@@ -16,10 +17,8 @@ pkgbase = tensorflow-computecpp
depends = opencl-icd-loader
depends = computecpp
options = !ccache
- source = git+https://github.com/lukeiwanski/tensorflow#branch=dev/amd_gpu
- source = 17508.patch
+ source = git+https://github.com/lukeiwanski/tensorflow#branch=integration/1.8
sha512sums = SKIP
- sha512sums = cb2880767532275f55f91ab66b29687fceadcadb8e23608d1e59b35a2899239882367ac38465a5e635f17378286093da0ede115668e23d651776d962ddc35ea9
pkgname = tensorflow-computecpp
provides = tensorflow
diff --git a/17508.patch b/17508.patch
deleted file mode 100644
index feee9c2fa809..000000000000
--- a/17508.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 340327dc8cc637fef01e66f7dd7cae68ce259b94 Mon Sep 17 00:00:00 2001
-From: Yun Peng <pcloudy@google.com>
-Date: Wed, 7 Mar 2018 13:50:31 +0100
-Subject: [PATCH] jpeg.BUILD: Using --cpu instead of --android_cpu
-
----
- third_party/jpeg/jpeg.BUILD | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/third_party/jpeg/jpeg.BUILD b/third_party/jpeg/jpeg.BUILD
-index 87a23925c43..4418ac32fc4 100644
---- a/third_party/jpeg/jpeg.BUILD
-+++ b/third_party/jpeg/jpeg.BUILD
-@@ -526,12 +526,12 @@ config_setting(
-
- config_setting(
- name = "armeabi-v7a",
-- values = {"android_cpu": "armeabi-v7a"},
-+ values = {"cpu": "armeabi-v7a"},
- )
-
- config_setting(
- name = "arm64-v8a",
-- values = {"android_cpu": "arm64-v8a"},
-+ values = {"cpu": "arm64-v8a"},
- )
-
- config_setting(
diff --git a/PKGBUILD b/PKGBUILD
index f226bde98cd6..a9338ba9fef0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,25 @@
pkgbase=tensorflow-computecpp
pkgname=(tensorflow-computecpp python-tensorflow-computecpp)
-pkgver=ComputeCpp+0.6.0+31+g0367804e7e
+pkgver=1.8
pkgrel=1
pkgdesc="Library for computation using data flow graphs for scalable machine learning (backend with ComputeCpp)"
url="https://github.com/lukeiwanski/tensorflow"
+epoch=1
license=('APACHE')
arch=('x86_64')
depends=(opencl-icd-loader computecpp)
makedepends=(git opencl-icd-loader computecpp bazel python-numpy python-pip python-wheel python-setuptools)
options=(!ccache)
-source=("git+${url}#branch=dev/amd_gpu"
- 17508.patch)
-sha512sums=('SKIP'
- 'cb2880767532275f55f91ab66b29687fceadcadb8e23608d1e59b35a2899239882367ac38465a5e635f17378286093da0ede115668e23d651776d962ddc35ea9')
-
-pkgver() {
- cd ${srcdir}/tensorflow
- git describe --tags | sed 's/-/+/g;s/v//;'
-}
+source=("git+${url}#branch=integration/${pkgver}")
+sha512sums=('SKIP')
prepare() {
- patch -Np1 -i ${srcdir}/17508.patch -d tensorflow
-
# These environment variables influence the behavior of the configure call below.
export PYTHON_BIN_PATH=/usr/bin/python
export USE_DEFAULT_PYTHON_LIB_PATH=1
- export CC_OPT_FLAGS="${CXXFLAGS} -no-serial-memop"
+ export CC_OPT_FLAGS="-march=native -mfpmath=sse -O2 -pipe"
+ export TF_DOWNLOAD_CLANG=0
export TF_CUDA_CLANG=0
export TF_NEED_CUDA=0
export TF_NEED_JEMALLOC=0