summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-09-29 15:33:18 +0000
committerDaniel Bermond2020-09-29 15:33:18 +0000
commit1602553f61600c175e849f899907b9970a86d608 (patch)
treed8357ac41f7b4b821cc0106d588a2316dc754136
parent069b30f951245baa6b896ed0c5dd4e7f5b85f96e (diff)
downloadaur-1602553f61600c175e849f899907b9970a86d608.tar.gz
Update TensorRT OSS components to 20.09. Update cub repository.
-rw-r--r--.SRCINFO18
-rw-r--r--020-tensorrt-fix-cub-deprecation-huge-warnings.patch4
-rw-r--r--PKGBUILD20
3 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec8fcdd19b10..361e3538ae3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tensorrt
pkgdesc = A platform for high-performance deep learning inference using NVIDIA hardware
pkgver = 7.2.0.14
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/NVIDIA/TensorRT/
arch = x86_64
license = custom
@@ -17,13 +17,13 @@ pkgbase = tensorrt
makedepends = cudnn
noextract = protobuf-cpp-3.12.4.tar.gz
source = local://TensorRT-7.2.0.14.Ubuntu-18.04.x86_64-gnu.cuda-11.0.cudnn8.0.tar.gz
- source = git+https://github.com/NVIDIA/TensorRT.git#tag=20.08
- source = protobuf-protocolbuffers::git+https://github.com/protocolbuffers/protobuf#branch=3.8.x
- source = git+https://github.com/NVlabs/cub#branch=1.8.0
- source = git+https://github.com/onnx/onnx-tensorrt#branch=7.1
- source = git+https://github.com/onnx/onnx#branch=rel-1.6.0
- source = git+https://github.com/pybind/pybind11
- source = git+https://github.com/google/benchmark
+ source = git+https://github.com/NVIDIA/TensorRT.git#tag=20.09
+ source = protobuf-protocolbuffers::git+https://github.com/protocolbuffers/protobuf.git#branch=3.8.x
+ source = git+https://github.com/NVIDIA/cub.git#tag=1.8.0
+ source = git+https://github.com/onnx/onnx-tensorrt.git#branch=7.1
+ source = git+https://github.com/onnx/onnx.git#branch=rel-1.6.0
+ source = git+https://github.com/pybind/pybind11.git
+ source = git+https://github.com/google/benchmark.git
source = https://github.com/google/protobuf/releases/download/v3.12.4/protobuf-cpp-3.12.4.tar.gz
source = 010-tensorrt-use-local-protobuf-sources.patch
source = 020-tensorrt-fix-cub-deprecation-huge-warnings.patch
@@ -37,7 +37,7 @@ pkgbase = tensorrt
sha256sums = SKIP
sha256sums = ccfbaaba52f67e0e6536a05f3df3f6618620d255513cfca3a07f5935b624e26b
sha256sums = ea25bb1b188d53cbfbec35d242ab2a2fa8d6009c547c9f5f67bc2f1ad127ceac
- sha256sums = bfc2230de7d1afa97febd2bc74c0cca019d86c303008533c347c18c20dea5cd7
+ sha256sums = 6a12e65113b6c1814a73be85b96b4be365850dcdf772f9a3c66476f8647b5ba1
pkgname = tensorrt
depends = cuda
diff --git a/020-tensorrt-fix-cub-deprecation-huge-warnings.patch b/020-tensorrt-fix-cub-deprecation-huge-warnings.patch
index f05bf5473b92..0a9e5a04ac5d 100644
--- a/020-tensorrt-fix-cub-deprecation-huge-warnings.patch
+++ b/020-tensorrt-fix-cub-deprecation-huge-warnings.patch
@@ -1,6 +1,6 @@
--- a/plugin/CMakeLists.txt
+++ b/plugin/CMakeLists.txt
-@@ -118,7 +118,7 @@ set_target_properties(${SHARED_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
+@@ -119,7 +119,7 @@ set_target_properties(${SHARED_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
set_target_properties(${SHARED_TARGET} PROPERTIES VERSION ${TRT_VERSION} SOVERSION ${TRT_SOVERSION} )
@@ -9,7 +9,7 @@
target_link_libraries(${SHARED_TARGET}
${CUBLAS_LIB}
-@@ -158,7 +158,7 @@ set_target_properties(${STATIC_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
+@@ -159,7 +159,7 @@ set_target_properties(${STATIC_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
set_target_properties(${STATIC_TARGET} PROPERTIES VERSION ${TRT_VERSION} SOVERSION ${TRT_SOVERSION} )
diff --git a/PKGBUILD b/PKGBUILD
index d72ec0014de9..4791a50dd3dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Download website:
# https://developer.nvidia.com/tensorrt/
-_tensorrt_tag=20.08
+_tensorrt_tag=20.09
_cudaver=11.0
_cudnnver=8.0
_graphsurgeonver=0.4.5
@@ -15,7 +15,7 @@ _uffver=0.6.9
_ubuntuver=18.04
_protobuf_branch=3.8.x
_protobuf_ver=3.12.4
-_cub_branch=1.8.0
+_cub_tag=1.8.0
_onnx_tensorrt_branch=7.1
_onnx_branch=rel-1.6.0
_onnx_ver=1.7.0
@@ -23,7 +23,7 @@ _onnx_ver=1.7.0
pkgbase=tensorrt
pkgname=('tensorrt' 'tensorrt-doc')
pkgver=7.2.0.14
-pkgrel=1
+pkgrel=2
pkgdesc='A platform for high-performance deep learning inference using NVIDIA hardware'
arch=('x86_64')
url='https://github.com/NVIDIA/TensorRT/'
@@ -32,12 +32,12 @@ makedepends=('git' 'cmake' 'poppler' 'pybind11' 'python' 'python-pip' 'zlib'
'cuda' 'cudnn')
source=("local://TensorRT-${pkgver}.Ubuntu-${_ubuntuver}.${CARCH}-gnu.cuda-${_cudaver}.cudnn${_cudnnver}.tar.gz"
"git+https://github.com/NVIDIA/TensorRT.git#tag=${_tensorrt_tag}"
- 'protobuf-protocolbuffers'::"git+https://github.com/protocolbuffers/protobuf#branch=${_protobuf_branch}"
- "git+https://github.com/NVlabs/cub#branch=${_cub_branch}"
- "git+https://github.com/onnx/onnx-tensorrt#branch=${_onnx_tensorrt_branch}"
- "git+https://github.com/onnx/onnx#branch=${_onnx_branch}"
- 'git+https://github.com/pybind/pybind11'
- 'git+https://github.com/google/benchmark'
+ 'protobuf-protocolbuffers'::"git+https://github.com/protocolbuffers/protobuf.git#branch=${_protobuf_branch}"
+ "git+https://github.com/NVIDIA/cub.git#tag=${_cub_tag}"
+ "git+https://github.com/onnx/onnx-tensorrt.git#branch=${_onnx_tensorrt_branch}"
+ "git+https://github.com/onnx/onnx.git#branch=${_onnx_branch}"
+ 'git+https://github.com/pybind/pybind11.git'
+ 'git+https://github.com/google/benchmark.git'
"https://github.com/google/protobuf/releases/download/v${_protobuf_ver}/protobuf-cpp-${_protobuf_ver}.tar.gz"
'010-tensorrt-use-local-protobuf-sources.patch'
'020-tensorrt-fix-cub-deprecation-huge-warnings.patch')
@@ -52,7 +52,7 @@ sha256sums=('5681d6f7d4a6d6b9ef7239caa5a0508748e6f6cade77cb4d48f89e133295ab60'
'SKIP'
'ccfbaaba52f67e0e6536a05f3df3f6618620d255513cfca3a07f5935b624e26b'
'ea25bb1b188d53cbfbec35d242ab2a2fa8d6009c547c9f5f67bc2f1ad127ceac'
- 'bfc2230de7d1afa97febd2bc74c0cca019d86c303008533c347c18c20dea5cd7')
+ '6a12e65113b6c1814a73be85b96b4be365850dcdf772f9a3c66476f8647b5ba1')
prepare() {
# tensorrt git submodules