summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-10-05 18:45:30 -0300
committerDaniel Bermond2021-10-05 18:45:30 -0300
commit247da6a1da09773b9b8f5f2b391e5e10857428e0 (patch)
treeb435c190104e64d43f0a69a74be402a04957a1c4
parent38d0d3d0b6ee25686e2f8ee26adc08e62a3349c2 (diff)
downloadaur-247da6a1da09773b9b8f5f2b391e5e10857428e0.tar.gz
Update to version 8.0.3.4
-rw-r--r--.SRCINFO10
-rw-r--r--020-tensorrt-fix-cub-deprecation-huge-warnings.patch4
-rw-r--r--PKGBUILD8
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bc9168f7a82..153277361893 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tensorrt
pkgdesc = A platform for high-performance deep learning inference on NVIDIA hardware
- pkgver = 8.0.1.6
+ pkgver = 8.0.3.4
pkgrel = 1
url = https://developer.nvidia.com/tensorrt/
arch = x86_64
@@ -16,8 +16,8 @@ pkgbase = tensorrt
makedepends = python-pip
makedepends = python-wheel
noextract = protobuf-cpp-3.17.3.tar.gz
- source = local://TensorRT-8.0.1.6.Linux.x86_64-gnu.cuda-11.3.cudnn8.2.tar.gz
- source = git+https://github.com/NVIDIA/TensorRT.git#tag=8.0.1
+ source = local://TensorRT-8.0.3.4.Linux.x86_64-gnu.cuda-11.3.cudnn8.2.tar.gz
+ source = git+https://github.com/NVIDIA/TensorRT.git#tag=21.10
source = protobuf-protocolbuffers::git+https://github.com/protocolbuffers/protobuf.git
source = cub-nvlabs::git+https://github.com/NVlabs/cub.git
source = git+https://github.com/onnx/onnx-tensorrt.git
@@ -28,7 +28,7 @@ pkgbase = tensorrt
source = 010-tensorrt-use-local-protobuf-sources.patch
source = 020-tensorrt-fix-cub-deprecation-huge-warnings.patch
source = 030-tensorrt-fix-python.patch
- sha256sums = def6a5ee50bed25a68a9c9e22ec671a8f29ee5414bde47c5767bd279e5596f88
+ sha256sums = 3177435024ff4aa5a6dba8c1ed06ab11cc0e1bf3bb712dfa63a43422f41313f3
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -38,7 +38,7 @@ pkgbase = tensorrt
sha256sums = SKIP
sha256sums = 51cec99f108b83422b7af1170afd7aeb2dd77d2bcbb7b6bad1f92509e9ccf8cb
sha256sums = ea25bb1b188d53cbfbec35d242ab2a2fa8d6009c547c9f5f67bc2f1ad127ceac
- sha256sums = ecde4147042e67a5162082806f15691781bd307f93f7f8a742ac44bf44db7342
+ sha256sums = 053fdce602aa588a576964978c0d1e777fc8ce2ef6b76165a70f0b025e6c3dec
sha256sums = c12d9148b7d6fc436387e7eb7b16a0066358f69e32bbee8cc9ac066b1faa902a
pkgname = tensorrt
diff --git a/020-tensorrt-fix-cub-deprecation-huge-warnings.patch b/020-tensorrt-fix-cub-deprecation-huge-warnings.patch
index 6a042a768937..daf627a074d9 100644
--- a/020-tensorrt-fix-cub-deprecation-huge-warnings.patch
+++ b/020-tensorrt-fix-cub-deprecation-huge-warnings.patch
@@ -1,6 +1,6 @@
--- a/plugin/CMakeLists.txt
+++ b/plugin/CMakeLists.txt
-@@ -122,7 +122,7 @@ set_target_properties(${SHARED_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
+@@ -123,7 +123,7 @@ set_target_properties(${SHARED_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
set_target_properties(${SHARED_TARGET} PROPERTIES VERSION ${TRT_VERSION} SOVERSION ${TRT_SOVERSION} )
@@ -9,7 +9,7 @@
target_link_libraries(${SHARED_TARGET}
${CUBLAS_LIB}
-@@ -162,7 +162,7 @@ set_target_properties(${STATIC_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
+@@ -163,7 +163,7 @@ set_target_properties(${STATIC_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
set_target_properties(${STATIC_TARGET} PROPERTIES VERSION ${TRT_VERSION} SOVERSION ${TRT_SOVERSION} )
diff --git a/PKGBUILD b/PKGBUILD
index 693f00b3eb03..8852c3186bba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
pkgbase=tensorrt
pkgname=('tensorrt' 'python-tensorrt' 'tensorrt-doc')
-pkgver=8.0.1.6
-_tensorrt_tag=8.0.1
+pkgver=8.0.3.4
+_tensorrt_tag=21.10
_cudaver=11.3
_cudnnver=8.2
_protobuf_ver=3.17.3
@@ -37,7 +37,7 @@ source=("local://TensorRT-${pkgver}.Linux.${CARCH}-gnu.cuda-${_cudaver}.cudnn${_
'020-tensorrt-fix-cub-deprecation-huge-warnings.patch'
'030-tensorrt-fix-python.patch')
noextract=("protobuf-cpp-${_protobuf_ver}.tar.gz")
-sha256sums=('def6a5ee50bed25a68a9c9e22ec671a8f29ee5414bde47c5767bd279e5596f88'
+sha256sums=('3177435024ff4aa5a6dba8c1ed06ab11cc0e1bf3bb712dfa63a43422f41313f3'
'SKIP'
'SKIP'
'SKIP'
@@ -47,7 +47,7 @@ sha256sums=('def6a5ee50bed25a68a9c9e22ec671a8f29ee5414bde47c5767bd279e5596f88'
'SKIP'
'51cec99f108b83422b7af1170afd7aeb2dd77d2bcbb7b6bad1f92509e9ccf8cb'
'ea25bb1b188d53cbfbec35d242ab2a2fa8d6009c547c9f5f67bc2f1ad127ceac'
- 'ecde4147042e67a5162082806f15691781bd307f93f7f8a742ac44bf44db7342'
+ '053fdce602aa588a576964978c0d1e777fc8ce2ef6b76165a70f0b025e6c3dec'
'c12d9148b7d6fc436387e7eb7b16a0066358f69e32bbee8cc9ac066b1faa902a')
prepare() {