summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-10-21 17:33:02 +0000
committerDaniel Bermond2020-10-21 17:33:02 +0000
commit4692f3f8d431cea3d587bb1163a95b62b01999d1 (patch)
treed2663bd8867655104f2aa78c1ac2f62eca7d74f3
parent1602553f61600c175e849f899907b9970a86d608 (diff)
downloadaur-4692f3f8d431cea3d587bb1163a95b62b01999d1.tar.gz
Update to version 7.2.1.6
-rw-r--r--.SRCINFO14
-rw-r--r--020-tensorrt-fix-cub-deprecation-huge-warnings.patch4
-rw-r--r--PKGBUILD17
3 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 361e3538ae3d..17e80a012ac7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tensorrt
pkgdesc = A platform for high-performance deep learning inference using NVIDIA hardware
- pkgver = 7.2.0.14
- pkgrel = 2
+ pkgver = 7.2.1.6
+ pkgrel = 1
url = https://github.com/NVIDIA/TensorRT/
arch = x86_64
license = custom
@@ -16,18 +16,18 @@ pkgbase = tensorrt
makedepends = cuda
makedepends = cudnn
noextract = protobuf-cpp-3.12.4.tar.gz
- source = local://TensorRT-7.2.0.14.Ubuntu-18.04.x86_64-gnu.cuda-11.0.cudnn8.0.tar.gz
- source = git+https://github.com/NVIDIA/TensorRT.git#tag=20.09
+ source = local://TensorRT-7.2.1.6.Ubuntu-18.04.x86_64-gnu.cuda-11.1.cudnn8.0.tar.gz
+ source = git+https://github.com/NVIDIA/TensorRT.git#tag=7.2.1
source = protobuf-protocolbuffers::git+https://github.com/protocolbuffers/protobuf.git#branch=3.8.x
source = git+https://github.com/NVIDIA/cub.git#tag=1.8.0
- source = git+https://github.com/onnx/onnx-tensorrt.git#branch=7.1
+ source = git+https://github.com/onnx/onnx-tensorrt.git#branch=7.2.1
source = git+https://github.com/onnx/onnx.git#branch=rel-1.6.0
source = git+https://github.com/pybind/pybind11.git
source = git+https://github.com/google/benchmark.git
source = https://github.com/google/protobuf/releases/download/v3.12.4/protobuf-cpp-3.12.4.tar.gz
source = 010-tensorrt-use-local-protobuf-sources.patch
source = 020-tensorrt-fix-cub-deprecation-huge-warnings.patch
- sha256sums = 5681d6f7d4a6d6b9ef7239caa5a0508748e6f6cade77cb4d48f89e133295ab60
+ sha256sums = eef37d387b74f452c86d1ffe58bc57d0514409591e1ac2ae9d11b3167d8d5e6b
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -37,7 +37,7 @@ pkgbase = tensorrt
sha256sums = SKIP
sha256sums = ccfbaaba52f67e0e6536a05f3df3f6618620d255513cfca3a07f5935b624e26b
sha256sums = ea25bb1b188d53cbfbec35d242ab2a2fa8d6009c547c9f5f67bc2f1ad127ceac
- sha256sums = 6a12e65113b6c1814a73be85b96b4be365850dcdf772f9a3c66476f8647b5ba1
+ sha256sums = e6153bf43c248fb3ed843e41f6b722ff8c3507ad48fe105bfa129b8641741ecf
pkgname = tensorrt
depends = cuda
diff --git a/020-tensorrt-fix-cub-deprecation-huge-warnings.patch b/020-tensorrt-fix-cub-deprecation-huge-warnings.patch
index 0a9e5a04ac5d..df0bf453fc35 100644
--- a/020-tensorrt-fix-cub-deprecation-huge-warnings.patch
+++ b/020-tensorrt-fix-cub-deprecation-huge-warnings.patch
@@ -1,6 +1,6 @@
--- a/plugin/CMakeLists.txt
+++ b/plugin/CMakeLists.txt
-@@ -119,7 +119,7 @@ set_target_properties(${SHARED_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
+@@ -120,7 +120,7 @@ set_target_properties(${SHARED_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
set_target_properties(${SHARED_TARGET} PROPERTIES VERSION ${TRT_VERSION} SOVERSION ${TRT_SOVERSION} )
@@ -9,7 +9,7 @@
target_link_libraries(${SHARED_TARGET}
${CUBLAS_LIB}
-@@ -159,7 +159,7 @@ set_target_properties(${STATIC_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
+@@ -160,7 +160,7 @@ set_target_properties(${STATIC_TARGET} PROPERTIES DEBUG_POSTFIX ${TRT_DEBUG_POST
set_target_properties(${STATIC_TARGET} PROPERTIES VERSION ${TRT_VERSION} SOVERSION ${TRT_SOVERSION} )
diff --git a/PKGBUILD b/PKGBUILD
index 4791a50dd3dd..aa4df522827d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,7 @@
# Download website:
# https://developer.nvidia.com/tensorrt/
-_tensorrt_tag=20.09
-_cudaver=11.0
+_cudaver=11.1
_cudnnver=8.0
_graphsurgeonver=0.4.5
_uffver=0.6.9
@@ -16,14 +15,14 @@ _ubuntuver=18.04
_protobuf_branch=3.8.x
_protobuf_ver=3.12.4
_cub_tag=1.8.0
-_onnx_tensorrt_branch=7.1
+_onnx_tensorrt_branch=7.2.1
_onnx_branch=rel-1.6.0
_onnx_ver=1.7.0
pkgbase=tensorrt
pkgname=('tensorrt' 'tensorrt-doc')
-pkgver=7.2.0.14
-pkgrel=2
+pkgver=7.2.1.6
+pkgrel=1
pkgdesc='A platform for high-performance deep learning inference using NVIDIA hardware'
arch=('x86_64')
url='https://github.com/NVIDIA/TensorRT/'
@@ -31,7 +30,7 @@ license=('custom' 'Apache')
makedepends=('git' 'cmake' 'poppler' 'pybind11' 'python' 'python-pip' 'zlib'
'cuda' 'cudnn')
source=("local://TensorRT-${pkgver}.Ubuntu-${_ubuntuver}.${CARCH}-gnu.cuda-${_cudaver}.cudnn${_cudnnver}.tar.gz"
- "git+https://github.com/NVIDIA/TensorRT.git#tag=${_tensorrt_tag}"
+ "git+https://github.com/NVIDIA/TensorRT.git#tag=${pkgver%.*}"
'protobuf-protocolbuffers'::"git+https://github.com/protocolbuffers/protobuf.git#branch=${_protobuf_branch}"
"git+https://github.com/NVIDIA/cub.git#tag=${_cub_tag}"
"git+https://github.com/onnx/onnx-tensorrt.git#branch=${_onnx_tensorrt_branch}"
@@ -42,7 +41,7 @@ source=("local://TensorRT-${pkgver}.Ubuntu-${_ubuntuver}.${CARCH}-gnu.cuda-${_cu
'010-tensorrt-use-local-protobuf-sources.patch'
'020-tensorrt-fix-cub-deprecation-huge-warnings.patch')
noextract=("protobuf-cpp-${_protobuf_ver}.tar.gz")
-sha256sums=('5681d6f7d4a6d6b9ef7239caa5a0508748e6f6cade77cb4d48f89e133295ab60'
+sha256sums=('eef37d387b74f452c86d1ffe58bc57d0514409591e1ac2ae9d11b3167d8d5e6b'
'SKIP'
'SKIP'
'SKIP'
@@ -52,7 +51,7 @@ sha256sums=('5681d6f7d4a6d6b9ef7239caa5a0508748e6f6cade77cb4d48f89e133295ab60'
'SKIP'
'ccfbaaba52f67e0e6536a05f3df3f6618620d255513cfca3a07f5935b624e26b'
'ea25bb1b188d53cbfbec35d242ab2a2fa8d6009c547c9f5f67bc2f1ad127ceac'
- '6a12e65113b6c1814a73be85b96b4be365850dcdf772f9a3c66476f8647b5ba1')
+ 'e6153bf43c248fb3ed843e41f6b722ff8c3507ad48fe105bfa129b8641741ecf')
prepare() {
# tensorrt git submodules
@@ -98,7 +97,7 @@ build() {
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DTRT_LIB_DIR="${srcdir}/TensorRT-${pkgver}/lib" \
- -DGPU_ARCHS='52 53 60 61 62 70 72 75 80' \
+ -DGPU_ARCHS='52 53 60 61 62 70 72 75 80 86' \
-DPROTOBUF_VERSION="${_protobuf_ver}" \
-DCUDA_VERSION="$_cudaver" \
-DCUDNN_VERSION="$_cudnnver" \