summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-05-14 10:43:13 -0300
committerDaniel Bermond2022-05-14 10:43:13 -0300
commit58ff1bc45bd85ec7e0967e8e3a66607602301bff (patch)
treebb2fae1add80ed3811df172f134d5093cd14c16e
parentd31d186ce364e9e50b9319f63fb7d816b92f9e76 (diff)
downloadaur-58ff1bc45bd85ec7e0967e8e3a66607602301bff.tar.gz
Update to version 8.2.5.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1a6581d2ab3..03b373dd0341 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tensorrt
pkgdesc = A platform for high-performance deep learning inference on NVIDIA hardware
- pkgver = 8.2.4.2
- pkgrel = 2
+ pkgver = 8.2.5.1
+ pkgrel = 1
url = https://developer.nvidia.com/tensorrt/
arch = x86_64
license = custom:NVIDIA-SLA
@@ -18,8 +18,8 @@ pkgbase = tensorrt
makedepends = python-setuptools
makedepends = python-wheel
noextract = protobuf-cpp-3.17.3.tar.gz
- source = local://TensorRT-8.2.4.2.Linux.x86_64-gnu.cuda-11.4.cudnn8.2.tar.gz
- source = git+https://github.com/NVIDIA/TensorRT.git#tag=22.04
+ source = local://TensorRT-8.2.5.1.Linux.x86_64-gnu.cuda-11.4.cudnn8.2.tar.gz
+ source = git+https://github.com/NVIDIA/TensorRT.git#tag=22.05
source = protobuf-protocolbuffers::git+https://github.com/protocolbuffers/protobuf.git
source = cub-nvlabs::git+https://github.com/NVlabs/cub.git
source = git+https://github.com/onnx/onnx-tensorrt.git
@@ -29,7 +29,7 @@ pkgbase = tensorrt
source = https://github.com/google/protobuf/releases/download/v3.17.3/protobuf-cpp-3.17.3.tar.gz
source = 010-tensorrt-use-local-protobuf-sources.patch
source = 020-tensorrt-fix-python.patch
- sha256sums = 826180eaaecdf9a7e76116855b9f1f3400ea9b06e66b06a3f6a0747ba6f863ad
+ sha256sums = 2dc36962f0e24fb01abeaccad4c4658a3a36a8337b8f39e281e4bbed44bbd771
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 09ab2ee7c399..91e5ae41e555 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,15 @@
pkgbase=tensorrt
pkgname=('tensorrt' 'python-tensorrt' 'tensorrt-doc')
-pkgver=8.2.4.2
-_ossver=22.04
+pkgver=8.2.5.1
+_ossver=22.05
_cudaver=11.4
_cudnnver=8.2
_protobuf_ver=3.17.3
_pybind11_ver=2.9.2
_graphsurgeon_ver=0.4.5
_uffver=0.6.9
-pkgrel=2
+pkgrel=1
pkgdesc='A platform for high-performance deep learning inference on NVIDIA hardware'
arch=('x86_64')
url='https://developer.nvidia.com/tensorrt/'
@@ -36,7 +36,7 @@ source=("local://TensorRT-${pkgver}.Linux.${CARCH}-gnu.cuda-${_cudaver}.cudnn${_
'010-tensorrt-use-local-protobuf-sources.patch'
'020-tensorrt-fix-python.patch')
noextract=("protobuf-cpp-${_protobuf_ver}.tar.gz")
-sha256sums=('826180eaaecdf9a7e76116855b9f1f3400ea9b06e66b06a3f6a0747ba6f863ad'
+sha256sums=('2dc36962f0e24fb01abeaccad4c4658a3a36a8337b8f39e281e4bbed44bbd771'
'SKIP'
'SKIP'
'SKIP'
@@ -79,14 +79,13 @@ prepare() {
build() {
export CXXFLAGS+=' -ffat-lto-objects'
- export LDFLAGS+=' -L/usr/lib'
cmake -B build -S TensorRT \
-DBUILD_ONNX_PYTHON:BOOL='ON' \
-DBUILD_SAMPLES:BOOL='OFF' \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DTRT_LIB_DIR="${srcdir}/TensorRT-${pkgver}/lib" \
- -DGPU_ARCHS='52 53 60 61 62 70 72 75 80 86' \
+ -DGPU_ARCHS='53 60 61 62 70 72 75 80 86' \
-DPROTOBUF_VERSION="$_protobuf_ver" \
-DCUDA_VERSION="$_cudaver" \
-DCUDNN_VERSION="$_cudnnver" \