summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-09-29 02:57:42 +0000
committerDaniel Bermond2018-09-29 02:57:42 +0000
commit92e3fadfda8aa7cbe5929c6c70ecf9913757661a (patch)
tree25b2c71097260d379aeafec84c0a561e3042f3d5
parentf93ef6ae192884dd471c10fb043b324e4b4d9106 (diff)
downloadaur-92e3fadfda8aa7cbe5929c6c70ecf9913757661a.tar.gz
Updated to version 5.0.0.10
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD59
2 files changed, 36 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ddbe954b20f..2df65745feca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = tensorrt
- pkgdesc = A high-performance deep learning inference optimizer and runtime for deep learning applications (needs registration at upstream URL and manual download)
- pkgver = 4.0.1.6
+ pkgdesc = A platform for high-performance deep learning inference (needs registration at upstream URL and manual download)
+ pkgver = 5.0.0.10
pkgrel = 1
url = https://developer.nvidia.com/tensorrt/
arch = x86_64
license = custom
makedepends = poppler
makedepends = unzip
+ depends = cuda
depends = cudnn
- depends = python2
depends = python
+ optdepends = python2: for tensorflow python2 modules (python2 only)
+ optdepends = python-tensorflow: for graphsurgeon and uff python3 modules (python3 only)
options = !strip
- source = file://TensorRT-4.0.1.6.Ubuntu-16.04.4.x86_64-gnu.cuda-9.2.cudnn7.1.tar.gz
- sha256sums = fc5fd2ba86225ed62e60870cc24896107770a59829363fcb49229c82bb1f4fb5
+ source = file://TensorRT-5.0.0.10.Ubuntu-18.04.1.x86_64-gnu.cuda-10.0.cudnn7.3.tar.gz
+ sha256sums = f48c0d8147c60beef82dbc2e6f4d19366906303b8395dfae72cf848dd351ff9d
pkgname = tensorrt
diff --git a/PKGBUILD b/PKGBUILD
index 0af558930ed0..9498e7f86073 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,42 +8,36 @@
# https://developer.nvidia.com/tensorrt/
_srcname=TensorRT
-_cudaver=9.2
-_cudnnver=7.1
-_graphsurgeonver=0.2.0
-_uffver=0.4.0
-_ubuntuver=16.04.4
-_ubpy3ver=35
+_cudaver=10.0
+_cudnnver=7.3
+_graphsurgeonver=0.2.2
+_uffver=0.5.1
+_ubuntuver=18.04.1
pkgname=tensorrt
-pkgver=4.0.1.6
+pkgver=5.0.0.10
pkgrel=1
-pkgdesc='A high-performance deep learning inference optimizer and runtime for deep learning applications (needs registration at upstream URL and manual download)'
+pkgdesc='A platform for high-performance deep learning inference (needs registration at upstream URL and manual download)'
arch=('x86_64')
url='https://developer.nvidia.com/tensorrt/'
license=('custom')
-depends=('cudnn' 'python2' 'python')
+depends=('cuda' 'cudnn' 'python')
+optdepends=('python2: for tensorflow python2 modules (python2 only)'
+ 'python-tensorflow: for graphsurgeon and uff python3 modules (python3 only)')
makedepends=('poppler' 'unzip')
options=('!strip')
source=("file://${_srcname}-${pkgver}.Ubuntu-${_ubuntuver}.${CARCH}-gnu.cuda-${_cudaver}.cudnn${_cudnnver}.tar.gz")
-sha256sums=('fc5fd2ba86225ed62e60870cc24896107770a59829363fcb49229c82bb1f4fb5')
+sha256sums=('f48c0d8147c60beef82dbc2e6f4d19366906303b8395dfae72cf848dd351ff9d')
prepare() {
cd "${_srcname}-${pkgver}/python"
+ unzip -oqq "tensorrt-${pkgver}-py2.py3-none-any.whl"
- mkdir -p python{2,3}
-
- cd python2
- unzip -qq "../${pkgname}-${pkgver}-cp27-cp27mu-linux_${CARCH}.whl"
-
- cd ../python3
- unzip -qq "../${pkgname}-${pkgver}-cp${_ubpy3ver}-cp${_ubpy3ver}m-linux_${CARCH}.whl"
-
- cd ../../graphsurgeon
- unzip -qq "graphsurgeon-${_graphsurgeonver}-py2.py3-none-any.whl"
+ cd ../graphsurgeon
+ unzip -oqq "graphsurgeon-${_graphsurgeonver}-py2.py3-none-any.whl"
cd ../uff
- unzip -qq "uff-${_uffver}-py2.py3-none-any.whl"
+ unzip -oqq "uff-${_uffver}-py2.py3-none-any.whl"
cd ../doc
pdftotext -layout TensorRT-License.pdf
@@ -52,7 +46,8 @@ prepare() {
package() {
cd "${_srcname}-${pkgver}"
- local _pythonver="$(python --version | sed 's/^Python[[:space:]]//' | grep -o '^[0-9]*\.[0-9]*')"
+ local _pythonver
+ _pythonver="$(python --version | awk '{ print $2 }' | grep -o '^[0-9]*\.[0-9]*')"
mkdir -p "${pkgdir}/usr/lib/python"{2.7,"${_pythonver}"}
@@ -63,25 +58,29 @@ package() {
install -D -m644 include/* -t "${pkgdir}/usr/include"
# libraries
- cp -af lib/* "${pkgdir}/usr/lib"
+ cp -a lib/*.so* "${pkgdir}/usr/lib"
+ cp -a lib/*_static.a* "${pkgdir}/usr/lib"
# python 2
- cp -af python/python2/tensorrt "${pkgdir}/usr/lib/python2.7"
+ cp -a python/tensorrt "${pkgdir}/usr/lib/python2.7"
# python 3
- cp -af python/python3/tensorrt "${pkgdir}/usr/lib/python${_pythonver}"
+ ### broken until ubuntu supports python 3.7
+ #cp -a python/tensorrt "${pkgdir}/usr/lib/python${_pythonver}"
# graphsurgeon
- cp -af graphsurgeon/graphsurgeon "${pkgdir}/usr/lib/python2.7"
- cp -af graphsurgeon/graphsurgeon "${pkgdir}/usr/lib/python${_pythonver}"
+ ### python3 only because there is no python2-tensorflow package
+ #cp -a graphsurgeon/graphsurgeon "${pkgdir}/usr/lib/python2.7"
+ cp -a graphsurgeon/graphsurgeon "${pkgdir}/usr/lib/python${_pythonver}"
# uff
- cp -af uff/uff "${pkgdir}/usr/lib/python2.7"
- cp -af uff/uff "${pkgdir}/usr/lib/python${_pythonver}"
+ ### python3 only because there is no python2-tensorflow package
+ #cp -a uff/uff "${pkgdir}/usr/lib/python2.7"
+ cp -a uff/uff "${pkgdir}/usr/lib/python${_pythonver}"
# documentation
install -D -m644 doc/TensorRT-Developer-Guide.pdf -t "${pkgdir}/usr/share/doc/${pkgname}"
- cp -af doc/{common,graphics,html} "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -a doc/{common,graphics,html,python} "${pkgdir}/usr/share/doc/${pkgname}"
# license
install -D -m644 doc/TensorRT-License.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"