summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-07-28 20:52:56 -0300
committerDaniel Bermond2022-07-28 20:52:56 -0300
commite9ed251f292a0afce1c86d7a122c714654af9eaf (patch)
tree84a3bd34776aa28004387080500f99bf1ea41d22
parent58ff1bc45bd85ec7e0967e8e3a66607602301bff (diff)
downloadaur-e9ed251f292a0afce1c86d7a122c714654af9eaf.tar.gz
Update to version 8.4.1.5
-rw-r--r--.SRCINFO13
-rw-r--r--020-tensorrt-fix-python.patch11
-rw-r--r--PKGBUILD57
-rw-r--r--TensorRT-SLA-2022.07.25.txt447
4 files changed, 481 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03b373dd0341..05f64096044f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tensorrt
pkgdesc = A platform for high-performance deep learning inference on NVIDIA hardware
- pkgver = 8.2.5.1
+ pkgver = 8.4.1.5
pkgrel = 1
url = https://developer.nvidia.com/tensorrt/
arch = x86_64
@@ -8,7 +8,6 @@ pkgbase = tensorrt
license = Apache
makedepends = git
makedepends = cmake
- makedepends = poppler
makedepends = cuda
makedepends = cudnn
makedepends = python
@@ -18,8 +17,8 @@ pkgbase = tensorrt
makedepends = python-setuptools
makedepends = python-wheel
noextract = protobuf-cpp-3.17.3.tar.gz
- source = local://TensorRT-8.2.5.1.Linux.x86_64-gnu.cuda-11.4.cudnn8.2.tar.gz
- source = git+https://github.com/NVIDIA/TensorRT.git#tag=22.05
+ source = local://TensorRT-8.4.1.5.Linux.x86_64-gnu.cuda-11.6.cudnn8.4.tar.gz
+ source = git+https://github.com/NVIDIA/TensorRT.git#tag=22.07
source = protobuf-protocolbuffers::git+https://github.com/protocolbuffers/protobuf.git
source = cub-nvlabs::git+https://github.com/NVlabs/cub.git
source = git+https://github.com/onnx/onnx-tensorrt.git
@@ -29,7 +28,8 @@ pkgbase = tensorrt
source = https://github.com/google/protobuf/releases/download/v3.17.3/protobuf-cpp-3.17.3.tar.gz
source = 010-tensorrt-use-local-protobuf-sources.patch
source = 020-tensorrt-fix-python.patch
- sha256sums = 2dc36962f0e24fb01abeaccad4c4658a3a36a8337b8f39e281e4bbed44bbd771
+ source = TensorRT-SLA-2022.07.25.txt
+ sha256sums = 8107861af218694130f170e071f49814fa3e27f1386ce7cb6d807ac05a7fcf0e
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -39,7 +39,8 @@ pkgbase = tensorrt
sha256sums = SKIP
sha256sums = 51cec99f108b83422b7af1170afd7aeb2dd77d2bcbb7b6bad1f92509e9ccf8cb
sha256sums = ea25bb1b188d53cbfbec35d242ab2a2fa8d6009c547c9f5f67bc2f1ad127ceac
- sha256sums = c9b83508768836158abf5990419951e4a9389a221fcb7d1f1c3425fdfbacc6e1
+ sha256sums = ab18bcaebc59620a0b97b67c4bfb7646d9310fffbeb15b8441552c600b0212c9
+ sha256sums = 0e28e9bc9a633f0e8b5587321859e30f78cf5116bd8d5c379fc18d17b7efadd2
pkgname = tensorrt
depends = cuda
diff --git a/020-tensorrt-fix-python.patch b/020-tensorrt-fix-python.patch
index ebd53e39d884..30daa00b037b 100644
--- a/020-tensorrt-fix-python.patch
+++ b/020-tensorrt-fix-python.patch
@@ -27,18 +27,9 @@
if (MSVC)
include_directories(${MSVC_COMPILER_DIR}/include ${MSVC_COMPILER_DIR}/../ucrt/include ${NV_WDKSDK_INC}/um ${NV_WDKSDK_INC}/shared)
-@@ -127,7 +127,7 @@ endif()
-
- # -------- START BUILD PROCESS --------
-
--if (${CMAKE_BUILD_TYPE} STREQUAL Release)
-+if (${CMAKE_BUILD_TYPE} STREQUAL Release OR ${CMAKE_BUILD_TYPE} STREQUAL None OR ${CMAKE_BUILD_TYPE} STREQUAL "")
- message(STATUS "Building in Release mode")
- if (ENABLE_INETWORK_SERIALIZE)
- set(TRT_LIBS nvinfer nvonnxparser nvparsers nvinfer_plugin nvserialize)
--- a/python/build.sh
+++ b/python/build.sh
-@@ -33,8 +33,9 @@ cmake .. -DCMAKE_BUILD_TYPE=Release \
+@@ -35,8 +35,9 @@ cmake .. -DCMAKE_BUILD_TYPE=Release \
-DEXT_PATH=${EXT_PATH} \
-DCUDA_INCLUDE_DIRS=${CUDA_ROOT}/include \
-DTENSORRT_ROOT=${ROOT_PATH} \
diff --git a/PKGBUILD b/PKGBUILD
index 91e5ae41e555..8964a5bf185f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,21 +9,22 @@
pkgbase=tensorrt
pkgname=('tensorrt' 'python-tensorrt' 'tensorrt-doc')
-pkgver=8.2.5.1
-_ossver=22.05
-_cudaver=11.4
-_cudnnver=8.2
+pkgver=8.4.1.5
+_ossver=22.07
+_cudaver=11.6
+_cudnnver=8.4
_protobuf_ver=3.17.3
_pybind11_ver=2.9.2
-_graphsurgeon_ver=0.4.5
+_graphsurgeon_ver=0.4.6
_uffver=0.6.9
+_license_ver=2022.07.25
pkgrel=1
pkgdesc='A platform for high-performance deep learning inference on NVIDIA hardware'
arch=('x86_64')
url='https://developer.nvidia.com/tensorrt/'
license=('custom:NVIDIA-SLA' 'Apache')
-makedepends=('git' 'cmake' 'poppler' 'cuda' 'cudnn' 'python' 'python-build'
- 'python-installer' 'python-onnx' 'python-setuptools' 'python-wheel')
+makedepends=('git' 'cmake' 'cuda' 'cudnn' 'python' 'python-build' 'python-installer' 'python-onnx'
+ 'python-setuptools' 'python-wheel')
source=("local://TensorRT-${pkgver}.Linux.${CARCH}-gnu.cuda-${_cudaver}.cudnn${_cudnnver}.tar.gz"
"git+https://github.com/NVIDIA/TensorRT.git#tag=${_ossver}"
'protobuf-protocolbuffers'::'git+https://github.com/protocolbuffers/protobuf.git'
@@ -34,9 +35,10 @@ source=("local://TensorRT-${pkgver}.Linux.${CARCH}-gnu.cuda-${_cudaver}.cudnn${_
'git+https://github.com/google/benchmark.git'
"https://github.com/google/protobuf/releases/download/v${_protobuf_ver}/protobuf-cpp-${_protobuf_ver}.tar.gz"
'010-tensorrt-use-local-protobuf-sources.patch'
- '020-tensorrt-fix-python.patch')
+ '020-tensorrt-fix-python.patch'
+ "TensorRT-SLA-${_license_ver}.txt")
noextract=("protobuf-cpp-${_protobuf_ver}.tar.gz")
-sha256sums=('2dc36962f0e24fb01abeaccad4c4658a3a36a8337b8f39e281e4bbed44bbd771'
+sha256sums=('8107861af218694130f170e071f49814fa3e27f1386ce7cb6d807ac05a7fcf0e'
'SKIP'
'SKIP'
'SKIP'
@@ -46,7 +48,8 @@ sha256sums=('2dc36962f0e24fb01abeaccad4c4658a3a36a8337b8f39e281e4bbed44bbd771'
'SKIP'
'51cec99f108b83422b7af1170afd7aeb2dd77d2bcbb7b6bad1f92509e9ccf8cb'
'ea25bb1b188d53cbfbec35d242ab2a2fa8d6009c547c9f5f67bc2f1ad127ceac'
- 'c9b83508768836158abf5990419951e4a9389a221fcb7d1f1c3425fdfbacc6e1')
+ 'ab18bcaebc59620a0b97b67c4bfb7646d9310fffbeb15b8441552c600b0212c9'
+ '0e28e9bc9a633f0e8b5587321859e30f78cf5116bd8d5c379fc18d17b7efadd2')
prepare() {
# tensorrt git submodules
@@ -95,14 +98,14 @@ build() {
# python bindings
local _pyver
_pyver="$(python -c 'import sys; print("%s.%s" %sys.version_info[0:2])')"
- export PYTHON_MAJOR_VERSION="${_pyver%%.*}"
- export PYTHON_MINOR_VERSION="${_pyver#*.}"
- export TARGET_ARCHITECTURE="$CARCH"
- export TRT_OSSPATH="${srcdir}/TensorRT"
- export CUDA_ROOT='/opt/cuda'
- export ROOT_PATH="${srcdir}/TensorRT"
- export EXT_PATH="$srcdir"
- export TRT_NONOSS_ROOT="${srcdir}/TensorRT-${pkgver}"
+ local -x PYTHON_MAJOR_VERSION="${_pyver%%.*}"
+ local -x PYTHON_MINOR_VERSION="${_pyver#*.}"
+ local -x TARGET_ARCHITECTURE="$CARCH"
+ local -x TRT_OSSPATH="${srcdir}/TensorRT"
+ local -x CUDA_ROOT='/opt/cuda'
+ local -x ROOT_PATH="${srcdir}/TensorRT"
+ local -x EXT_PATH="$srcdir"
+ local -x TRT_NONOSS_ROOT="${srcdir}/TensorRT-${pkgver}"
git -C pybind11 checkout v${_pybind11_ver}
cd TensorRT/python
./build.sh
@@ -114,9 +117,6 @@ build() {
cd "${srcdir}/TensorRT/tools/${_dir}"
python -m build --wheel --no-isolation
done
-
- # license
- pdftotext -layout "${srcdir}/TensorRT-${pkgver}/doc/pdf/TensorRT-SLA.pdf"
}
package_tensorrt() {
@@ -131,7 +131,7 @@ package_tensorrt() {
ln -s "libnvinfer_builder_resource.so.${pkgver%.*}" "${pkgdir}/usr/lib/libnvinfer_builder_resource.so.${pkgver%%.*}"
ln -s "libnvinfer_builder_resource.so.${pkgver%%.*}" "${pkgdir}/usr/lib/libnvinfer_builder_resource.so"
- install -D -m644 "TensorRT-${pkgver}/doc/pdf/TensorRT-SLA.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "TensorRT-SLA-${_license_ver}.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 "TensorRT-${pkgver}/doc/Acknowledgements.txt" "${pkgdir}/usr/share/licenses/${pkgname}/ACKNOWLEDGEMENTS"
install -D -m644 TensorRT/NOTICE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
@@ -162,10 +162,8 @@ package_python-tensorrt() {
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-graphsurgeon"
ln -s "../../../lib/python${_pyver}/site-packages/uff-${_uffver}.dist-info/LICENSE.txt" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-uff"
- install -D -m644 "${srcdir}/TensorRT-${pkgver}/doc/pdf/TensorRT-SLA.txt" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-NVIDIA-SLA"
- install -D -m644 "${srcdir}/TensorRT-${pkgver}/doc/Acknowledgements.txt" \
- "${pkgdir}/usr/share/licenses/${pkgname}/ACKNOWLEDGEMENTS"
+ install -D -m644 "${srcdir}/TensorRT-SLA-${_license_ver}.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-NVIDIA-SLA"
+ install -D -m644 "${srcdir}/TensorRT-${pkgver}/doc/Acknowledgements.txt" "${pkgdir}/usr/share/licenses/${pkgname}/ACKNOWLEDGEMENTS"
install -D -m644 "${srcdir}/TensorRT/NOTICE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
@@ -174,11 +172,8 @@ package_tensorrt-doc() {
arch=('any')
license=('custom:NVIDIA-SLA')
- install -D -m644 "TensorRT-${pkgver}/doc/pdf/TensorRT-Developer-Guide.pdf" -t "${pkgdir}/usr/share/doc/${pkgbase}"
- install -D -m644 "TensorRT-${pkgver}/doc/pdf/TensorRT-Quick-Start-Guide.pdf" -t "${pkgdir}/usr/share/doc/${pkgbase}"
- install -D -m644 "TensorRT-${pkgver}/doc/pdf/TensorRT-Support-Matrix-Guide.pdf" -t "${pkgdir}/usr/share/doc/${pkgbase}"
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
cp -dr --no-preserve='ownership' "TensorRT-${pkgver}/doc"/{cpp,python} "${pkgdir}/usr/share/doc/${pkgbase}"
-
- install -D -m644 "TensorRT-${pkgver}/doc/pdf/TensorRT-SLA.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "TensorRT-SLA-${_license_ver}.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 "TensorRT-${pkgver}/doc/Acknowledgements.txt" "${pkgdir}/usr/share/licenses/${pkgname}/ACKNOWLEDGEMENTS"
}
diff --git a/TensorRT-SLA-2022.07.25.txt b/TensorRT-SLA-2022.07.25.txt
new file mode 100644
index 000000000000..578ec08f2426
--- /dev/null
+++ b/TensorRT-SLA-2022.07.25.txt
@@ -0,0 +1,447 @@
+NVIDIA TensorRT
+
+Software License Agreement | NVIDIA Docs
+
+
+
+
+SLA-08835-001 _v8.4.2 | July 2022
+ Table of Contents
+Chapter 1. License................................................................................................................1
+ 1.1. Grant.......................................................................................................................................... 1
+ 1.2. Distribution Requirements....................................................................................................... 1
+ 1.3. Authorized Users.......................................................................................................................2
+ 1.4. Pre-Release SDK...................................................................................................................... 2
+ 1.5. Updates...................................................................................................................................... 2
+ 1.6. Third Party Licenses.................................................................................................................2
+ 1.7. Reservation of Rights................................................................................................................3
+Chapter 2. Limitations.......................................................................................................... 4
+Chapter 3. Ownership........................................................................................................... 5
+Chapter 4. No Warranties.................................................................................................... 6
+Chapter 5. Limitations of Liability........................................................................................7
+Chapter 6. Termination........................................................................................................ 8
+Chapter 7. General............................................................................................................... 9
+
+
+
+
+ NVIDIA TensorRT SLA-08835-001 _v8.4.2 | ii
+ Chapter 1. License.
+
+
+
+
+1.1. Grant
+Subject to the terms of this Agreement, NVIDIA hereby grants you a non-exclusive, non-
+transferable license, without the right to sublicense (except as expressly provided in this
+Agreement) to:
+1. Install and use the SDK,
+2. Modify and create derivative works of sample source code delivered in the SDK, and
+3. Distribute those portions of the SDK that are identified in this Agreement as distributable,
+ as incorporated in object code format into a software application that meets the
+ distribution requirements indicated in this Agreement.
+
+
+
+1.2. Distribution Requirements
+These are the distribution requirements for you to exercise the distribution grant:
+1. Your application must have material additional functionality, beyond the included portions
+ of the SDK.
+2. The distributable portions of the SDK shall only be accessed by your application.
+3. The following notice shall be included in modifications and derivative works of sample
+ source code distributed: “This software contains source code provided by NVIDIA
+ Corporation.”
+4. Unless a developer tool is identified in this Agreement as distributable, it is delivered for
+ your internal use only.
+5. The terms under which you distribute your application must be consistent with the terms
+ of this Agreement, including (without limitation) terms relating to the license grant and
+ license restrictions and protection of NVIDIA’s intellectual property rights. Additionally, you
+ agree that you will protect the privacy, security and legal rights of your application users.
+6. You agree to notify NVIDIA in writing of any known or suspected distribution or use of the
+ SDK not in compliance with the requirements of this Agreement, and to enforce the terms
+ of your agreements with respect to distributed SDK.
+
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 1
+ License.
+
+
+
+
+1.3. Authorized Users
+You may allow employees and contractors of your entity or of your subsidiary(ies) to access
+and use the SDK from your secure network to perform work on your behalf.
+If you are an academic institution you may allow users enrolled or employed by the academic
+institution to access and use the SDK from your secure network.
+You are responsible for the compliance with the terms of this Agreement by your authorized
+users. If you become aware that your authorized users didn’t follow the terms of this
+Agreement, you agree to take reasonable steps to resolve the non-compliance and prevent
+new occurrences.
+
+
+
+1.4. Pre-Release SDK
+The SDK versions identified as alpha, beta, preview or otherwise as pre-release, may not
+be fully functional, may contain errors or design flaws, and may have reduced or different
+security, privacy, accessibility, availability, and reliability standards relative to commercial
+versions of NVIDIA software and materials. Use of a pre-release SDK may result in unexpected
+results, loss of data, project delays or other unpredictable damage or loss.
+You may use a pre-release SDK at your own risk, understanding that pre-release SDKs are not
+intended for use in production or business-critical systems.
+NVIDIA may choose not to make available a commercial version of any pre-release SDK.
+NVIDIA may also choose to abandon development and terminate the availability of a pre-
+release SDK at any time without liability.
+
+
+
+1.5. Updates
+NVIDIA may, at its option, make available patches, workarounds or other updates to this SDK.
+Unless the updates are provided with their separate governing terms, they are deemed part of
+the SDK licensed to you as provided in this Agreement.
+You agree that the form and content of the SDK that NVIDIA provides may change without prior
+notice to you. While NVIDIA generally maintains compatibility between versions, NVIDIA may in
+some cases make changes that introduce incompatibilities in future versions of the SDK.
+
+
+
+1.6. Third Party Licenses
+The SDK may come bundled with, or otherwise include or be distributed with, third party
+software licensed by a NVIDIA supplier and/or open source software provided under an open
+source license. Use of third party software is subject to the third-party license terms, or in the
+absence of third party terms, the terms of this Agreement. Copyright to third party software is
+held by the copyright holders indicated in the third-party software or license.
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 2
+ License.
+
+
+
+
+1.7. Reservation of Rights
+NVIDIA reserves all rights, title and interest in and to the SDK not expressly granted to you
+under this Agreement.
+
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 3
+ Chapter 2. Limitations.
+
+
+
+The following license limitations apply to your use of the SDK:
+
+2.1 You may not reverse engineer, decompile or disassemble, or remove copyright or other
+proprietary notices from any portion of the SDK or copies of the SDK.
+
+2.2 Except as expressly provided in this Agreement, you may not copy, sell, rent, sublicense,
+transfer, distribute, modify, or create derivative works of any portion of the SDK.
+
+2.3 Unless you have an agreement with NVIDIA for this purpose, you may not indicate that an
+application created with the SDK is sponsored or endorsed by NVIDIA.
+
+2.4 You may not bypass, disable, or circumvent any encryption, security, digital rights
+management or authentication mechanism in the SDK.
+
+2.5 You may not use the SDK in any manner that would cause it to become subject to an open
+source software license. As examples, licenses that require as a condition of use, modification,
+and/or distribution that the SDK be (i) disclosed or distributed in source code form; (ii) licensed
+for the purpose of making derivative works; or (iii) redistributable at no charge.
+
+2.6 You acknowledge that the SDK as delivered is not tested or certified by NVIDIA for use in
+connection with the design, construction, maintenance, and/or operation of any system where
+the use or failure of such system could result in a situation that threatens the safety of human
+life or results in catastrophic damages (each, a "Critical Application"). Examples of Critical
+Applications includes use of avionics, navigation, autonomous vehicle applications, ai solutions
+for automotive products, military, medical, life support or other life critical applications.
+NVIDIA shall not be liable to you or any third party, in whole or in part, for any claims or
+damages arising from such uses. You are solely responsible for ensuring that any product
+or service developed with the SDK as a whole includes sufficient features to comply with all
+applicable legal and regulatory standards and requirements.
+
+2.7 You agree to defend, indemnify and hold harmless NVIDIA and its affiliates, and their
+respective employees, contractors, agents, officers and directors, from and against any and all
+claims, damages, obligations, losses, liabilities, costs or debt, fines, restitutions and expenses
+(including but not limited to attorney’s fees and costs incident to establishing the right of
+indemnification) arising out of or related to products or services that use the SDK in or for
+Critical Applications, and for use of the SDK outside of the scope of this Agreement or not in
+compliance with its terms.
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 4
+ Chapter 3. Ownership.
+
+
+
+3.1 NVIDIA or its licensors hold all rights, title and interest in and to the SDK and its
+modifications and derivative works, including their respective intellectual property rights,
+subject to your rights under Section 3.2. This SDK may include software and materials from
+NVIDIA’s licensors, and these licensors are intended third party beneficiaries that may enforce
+this Agreement with respect to their intellectual property rights.
+3.2 You hold all rights, title and interest in and to your applications and your derivative works
+of the sample source code delivered in the SDK, including their respective intellectual property
+rights, subject to NVIDIA’s rights under section 3.1.
+3.3 You may, but don’t have to, provide to NVIDIA suggestions, feature requests or other
+feedback regarding the SDK, including possible enhancements or modifications to the SDK.
+For any feedback that you voluntarily provide, you hereby grant NVIDIA and its affiliates a
+perpetual, non-exclusive, worldwide, irrevocable license to use, reproduce, modify, license,
+sublicense (through multiple tiers of sublicensees), and distribute (through multiple tiers of
+distributors) it without the payment of any royalties or fees to you. NVIDIA will use feedback
+at its choice. NVIDIA is constantly looking for ways to improve its products, so you may send
+feedback to NVIDIA through the developer portal at https://developer.nvidia.com.
+
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 5
+ Chapter 4. No Warranties.
+
+
+
+THE SDK IS PROVIDED BY NVIDIA "ASIS" AND "WITH ALL FAULTS." TO THE MAXIMUM
+EXTENT PERMITTED BY LAW, NVIDIA AND ITS AFFILIATES EXPRESSLY DISCLAIM ALL
+WARRANTIES OF ANY KIND OR NATURE, WHETHER EXPRESS, IMPLIED OR STATUTORY,
+INCLUDING, BUT NOT LIMITED TO, ANY WARRANTIES OF MERCHANTABILITY, FITNESS FOR
+A PARTICULAR PURPOSE, TITLE, NON-INFRINGEMENT, OR THE ABSENCE OF ANY DEFECTS
+THEREIN, WHETHER LATENT OR PATENT. NO WARRANTY IS MADE ON THE BASIS OF TRADE
+USAGE, COURSE OF DEALING OR COURSE OF TRADE.
+
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 6
+ Chapter 5. Limitations of Liability.
+
+
+
+TO THE MAXIMUM EXTENT PERMITTED BY LAW, NVIDIA AND ITS AFFILIATES SHALL NOT
+BE LIABLE FOR ANY SPECIAL, INCIDENTAL, PUNITIVE OR CONSEQUENTIAL DAMAGES, OR
+ANY LOST PROFITS, LOSS OF USE, LOSS OF DATA OR LOSS OF GOODWILL, OR THE COSTS
+OF PROCURING SUBSTITUTE PRODUCTS, ARISING OUT OF OR IN CONNECTION WITH THIS
+AGREEMENT OR THE USE OR PERFORMANCE OF THE SDK, WHETHER SUCH LIABILITY
+ARISES FROM ANY CLAIM BASED UPON BREACH OF CONTRACT, BREACH OF WARRANTY,
+TORT (INCLUDING NEGLIGENCE), PRODUCT LIABILITY OR ANY OTHER CAUSE OF ACTION OR
+THEORY OF LIABILITY. IN NO EVENT WILL NVIDIA’S AND ITS AFFILIATES TOTAL CUMULATIVE
+LIABILITY UNDER OR ARISING OUT OF THIS AGREEMENT EXCEED US$10.00. THE NATURE
+OF THE LIABILITY OR THE NUMBER OF CLAIMS OR SUITS SHALL NOT ENLARGE OR EXTEND
+THIS LIMIT.
+These exclusions and limitations of liability shall apply regardless if NVIDIA or its affiliates
+have been advised of the possibility of such damages, and regardless of whether a remedy
+fails its essential purpose. These exclusions and limitations of liability form an essential
+basis of the bargain between the parties, and, absent any of these exclusions or limitations of
+liability, the provisions of this Agreement, including, without limitation, the economic terms,
+would be substantially different.
+
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 7
+ Chapter 6. Termination.
+
+
+
+6.1 This Agreement will continue to apply until terminated by either you or NVIDIA as
+described below.
+6.2 If you want to terminate this Agreement, you may do so by stopping to use the SDK.
+6.3 NVIDIA may, at any time, terminate this Agreement if: (i) you fail to comply with any term
+of this Agreement and the non-compliance is not fixed within thirty (30) days following notice
+from NVIDIA (or immediately if you violate NVIDIA’s intellectual property rights); (ii) you
+commence or participate in any legal proceeding against NVIDIA with respect to the SDK; or
+(iii) NVIDIA decides to no longer provide the SDK in a country or, in NVIDIA’s sole discretion,
+the continued use of it is no longer commercially viable.
+6.4 Upon any termination of this Agreement, you agree to promptly discontinue use of the SDK
+and destroy all copies in your possession or control. Your prior distributions in accordance
+with this Agreement are not affected by the termination of this Agreement. Upon written
+request, you will certify in writing that you have complied with your commitments under this
+section. Upon any termination of this Agreement all provisions survive except for the licenses
+granted to you.
+
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 8
+ Chapter 7. General.
+
+
+
+If you wish to assign this Agreement or your rights and obligations, including by merger,
+consolidation, dissolution or operation of law, contact NVIDIA to ask for permission. Any
+attempted assignment not approved by NVIDIA in writing shall be void and of no effect. NVIDIA
+may assign, delegate or transfer this Agreement and its rights and obligations, and if to a non-
+affiliate you will be notified.
+You agree to cooperate with NVIDIA and provide reasonably requested information to verify
+your compliance with this Agreement.
+This Agreement will be governed in all respects by the laws of the United States and of the
+State of Delaware as those laws are applied to contracts entered into and performed entirely
+within Delaware by Delaware residents, without regard to the conflicts of laws principles.
+The United Nations Convention on Contracts for the International Sale of Goods is specifically
+disclaimed. You agree to all terms of this Agreement in the English language.
+The state or federal courts residing in Santa Clara County, California shall have exclusive
+jurisdiction over any dispute or claim arising out of this Agreement. Notwithstanding this, you
+agree that NVIDIA shall still be allowed to apply for injunctive remedies or an equivalent type
+of urgent legal relief in any jurisdiction.
+If any court of competent jurisdiction determines that any provision of this Agreement is
+illegal, invalid or unenforceable, such provision will be construed as limited to the extent
+necessary to be consistent with and fully enforceable under the law and the remaining
+provisions will remain in full force and effect. Unless otherwise specified, remedies are
+cumulative.
+Each party acknowledges and agrees that the other is an independent contractor in the
+performance of this Agreement.
+The SDK has been developed entirely at private expense and is “commercial items” consisting
+of “commercial computer software” and “commercial computer software documentation”
+provided with RESTRICTED RIGHTS. Use, duplication or disclosure by the U.S. Government
+or a U.S. Government subcontractor is subject to the restrictions in this Agreement pursuant
+to DFARS 227.7202-3(a) or as set forth in subparagraphs (b)(1) and (2) of the Commercial
+Computer Software - Restricted Rights clause at FAR 52.227-19, as applicable. Contractor/
+manufacturer is NVIDIA, 2788 San Tomas Expressway, Santa Clara, CA 95051.
+The SDK is subject to United States export laws and regulations. You agree that you will not
+ship, transfer or export the SDK into any country, or use the SDK in any manner, prohibited
+by the United States Bureau of Industry and Security or economic sanctions regulations
+administered by the U.S. Department of Treasury’s Office of Foreign Assets Control (OFAC),
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 9
+ General.
+
+
+
+
+or any applicable export laws, restrictions or regulations. These laws include restrictions on
+destinations, end users and end use. By accepting this Agreement, you confirm that you are
+not a resident or citizen of any country currently embargoed by the U.S. and that you are not
+otherwise prohibited from receiving the SDK.
+Any notice delivered by NVIDIA to you under this Agreement will be delivered via mail, email
+or fax. You agree that any notices that NVIDIA sends you electronically will satisfy any legal
+communication requirements. Please direct your legal notices or other correspondence to
+NVIDIA Corporation, 2788 San Tomas Expressway, Santa Clara, California 95051, United States
+of America, Attention: Legal Department.
+This Agreement and any exhibits incorporated into this Agreement constitute the entire
+agreement of the parties with respect to the subject matter of this Agreement and supersede
+all prior negotiations or documentation exchanged between the parties relating to this SDK
+license. Any additional and/or conflicting terms on documents issued by you are null, void,
+and invalid. Any amendment or waiver under this Agreement shall be in writing and signed by
+representatives of both parties.
+(v. May 24, 2021)
+
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 10
+ Chapter 8. TensorRT SUPPLEMENT
+ TO SOFTWARE LICENSE
+ AGREEMENT FOR NVIDIA
+ SOFTWARE DEVELOPMENT
+ KITS
+
+
+
+The terms in this supplement govern your use of the NVIDIA TensorRT SDK under the terms of
+your license agreement (“Agreement”) as modified by this supplement. Capitalized terms used
+but not defined below have the meaning assigned to them in the Agreement.
+This supplement is an exhibit to the Agreement and is incorporated as an integral part of the
+Agreement. In the event of conflict between the terms in this supplement and the terms in the
+Agreement, the terms in this supplement govern.
+4.1 License Scope. The SDK is licensed for you to develop applications only for use in systems
+with NVIDIA GPUs.
+2 Distribution. The following portions of the SDK are distributable under the Agreement: the
+runtime files .so and .dll.
+In addition to the rights above, for parties that are developing software intended solely for
+use on Jetson development kits or Jetson modules and running Linux for Tegra software
+the following shall apply: the SDK may be distributed in its entirety, as provided by NVIDIA
+and without separation of its components, for you and/or your licensees to create software
+development kits for use only on the Jetson platform and running Linux for Tegra software.
+3 Licensing. If the distribution terms in this Agreement are not suitable for your organization,
+or for any questions regarding this Agreement, please contact NVIDIA at nvidia-compute-
+license-questions@nvidia.com.
+(v. February 25, 2021)
+
+
+
+
+NVIDIA TensorRT SLA-08835-001 _v8.4.2 | 11
+ Notice
+This document is provided for information purposes only and shall not be regarded as a warranty of a certain functionality, condition, or quality of a product. NVIDIA
+Corporation (“NVIDIA”) makes no representations or warranties, expressed or implied, as to the accuracy or completeness of the information contained in this
+document and assumes no responsibility for any errors contained herein. NVIDIA shall have no liability for the consequences or use of such information or for any
+infringement of patents or other rights of third parties that may result from its use. This document is not a commitment to develop, release, or deliver any Material
+(defined below), code, or functionality.
+
+NVIDIA reserves the right to make corrections, modifications, enhancements, improvements, and any other changes to this document, at any time without notice.
+
+Customer should obtain the latest relevant information before placing orders and should verify that such information is current and complete.
+
+NVIDIA products are sold subject to the NVIDIA standard terms and conditions of sale supplied at the time of order acknowledgement, unless otherwise agreed
+in an individual sales agreement signed by authorized representatives of NVIDIA and customer (“Terms of Sale”). NVIDIA hereby expressly objects to applying any
+customer general terms and conditions with regards to the purchase of the NVIDIA product referenced in this document. No contractual obligations are formed
+either directly or indirectly by this document.
+
+NVIDIA products are not designed, authorized, or warranted to be suitable for use in medical, military, aircraft, space, or life support equipment, nor in applications
+where failure or malfunction of the NVIDIA product can reasonably be expected to result in personal injury, death, or property or environmental damage. NVIDIA
+accepts no liability for inclusion and/or use of NVIDIA products in such equipment or applications and therefore such inclusion and/or use is at customer’s own risk.
+
+NVIDIA makes no representation or warranty that products based on this document will be suitable for any specified use. Testing of all parameters of each product
+is not necessarily performed by NVIDIA. It is customer’s sole responsibility to evaluate and determine the applicability of any information contained in this document,
+ensure the product is suitable and fit for the application planned by customer, and perform the necessary testing for the application in order to avoid a default of
+the application or the product. Weaknesses in customer’s product designs may affect the quality and reliability of the NVIDIA product and may result in additional
+or different conditions and/or requirements beyond those contained in this document. NVIDIA accepts no liability related to any default, damage, costs, or problem
+which may be based on or attributable to: (i) the use of the NVIDIA product in any manner that is contrary to this document or (ii) customer product designs.
+
+No license, either expressed or implied, is granted under any NVIDIA patent right, copyright, or other NVIDIA intellectual property right under this document.
+Information published by NVIDIA regarding third-party products or services does not constitute a license from NVIDIA to use such products or services or a warranty
+or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property rights of the third party,
+or a license from NVIDIA under the patents or other intellectual property rights of NVIDIA.
+
+Reproduction of information in this document is permissible only if approved in advance by NVIDIA in writing, reproduced without alteration and in full compliance
+with all applicable export laws and regulations, and accompanied by all associated conditions, limitations, and notices.
+
+THIS DOCUMENT AND ALL NVIDIA DESIGN SPECIFICATIONS, REFERENCE BOARDS, FILES, DRAWINGS, DIAGNOSTICS, LISTS, AND OTHER DOCUMENTS
+(TOGETHER AND SEPARATELY, “MATERIALS”) ARE BEING PROVIDED “AS IS.” NVIDIA MAKES NO WARRANTIES, EXPRESSED, IMPLIED, STATUTORY, OR
+OTHERWISE WITH RESPECT TO THE MATERIALS, AND EXPRESSLY DISCLAIMS ALL IMPLIED WARRANTIES OF NONINFRINGEMENT, MERCHANTABILITY, AND
+FITNESS FOR A PARTICULAR PURPOSE. TO THE EXTENT NOT PROHIBITED BY LAW, IN NO EVENT WILL NVIDIA BE LIABLE FOR ANY DAMAGES, INCLUDING
+WITHOUT LIMITATION ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL, PUNITIVE, OR CONSEQUENTIAL DAMAGES, HOWEVER CAUSED AND REGARDLESS OF
+THE THEORY OF LIABILITY, ARISING OUT OF ANY USE OF THIS DOCUMENT, EVEN IF NVIDIA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
+Notwithstanding any damages that customer might incur for any reason whatsoever, NVIDIA’s aggregate and cumulative liability towards customer for the products
+described herein shall be limited in accordance with the Terms of Sale for the product.
+
+Arm
+Arm, AMBA and Arm Powered are registered trademarks of Arm Limited. Cortex, MPCore and Mali are trademarks of Arm Limited. "Arm" is used to represent Arm
+Holdings plc; its operating company Arm Limited; and the regional subsidiaries Arm Inc.; Arm KK; Arm Korea Limited.; Arm Taiwan Limited; Arm France SAS; Arm
+Consulting (Shanghai) Co. Ltd.; Arm Germany GmbH; Arm Embedded Technologies Pvt. Ltd.; Arm Norway, AS and Arm Sweden AB.
+
+HDMI
+HDMI, the HDMI logo, and High-Definition Multimedia Interface are trademarks or registered trademarks of HDMI Licensing LLC.
+
+Blackberry/QNX
+Copyright © 2020 BlackBerry Limited. All rights reserved.
+
+Trademarks, including but not limited to BLACKBERRY, EMBLEM Design, QNX, AVIAGE, MOMENTICS, NEUTRINO and QNX CAR are the trademarks or registered
+trademarks of BlackBerry Limited, used under license, and the exclusive rights to such trademarks are expressly reserved.
+
+Google
+Android, Android TV, Google Play and the Google Play logo are trademarks of Google, Inc.
+
+
+
+
+NVIDIA Corporation | 2788 San Tomas Expressway, Santa Clara, CA 95051
+http://www.nvidia.com
+ Trademarks
+NVIDIA, the NVIDIA logo, and BlueField, CUDA, DALI, DRIVE, JetPack, Jetson AGX Xavier, Jetson Nano, Kepler, Maxwell, NGC, Nsight, Orin, Pascal, Quadro, Tegra,
+TensorRT, Triton, Turing and Volta are trademarks and/or registered trademarks of NVIDIA Corporation in the United States and other countries. Other company
+and product names may be trademarks of the respective companies with which they are associated.
+
+Copyright
+© 2017-2022 NVIDIA Corporation & affiliates. All rights reserved.
+
+
+
+
+NVIDIA Corporation | 2788 San Tomas Expressway, Santa Clara, CA 95051
+http://www.nvidia.com
+ \ No newline at end of file