summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllison Smith2022-10-13 04:53:11 +1100
committerAllison Smith2022-10-13 04:53:11 +1100
commit52df43c7ede18291a50092bd2aae97f82adaaf5c (patch)
tree4ab9fc45ca8b75bbd564e8e9f5632b250da06ed9
parentb43eae5077947b1a3923e1c140f0cdf9a60c1c66 (diff)
downloadaur-52df43c7ede18291a50092bd2aae97f82adaaf5c.tar.gz
Strip .so files
-rw-r--r--PKGBUILD11
1 files changed, 1 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 531bd8c81dee..68ed8b08a438 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,18 +50,9 @@ package() {
rm Terasology.bat
rm -r natives/macosx
rm -r natives/windows
- #mkdir -p natives/linux
-
- #link the lwjgl libraries
- #ln -sf /usr/share/lwjgl2/native/linux/liblwjgl64.so natives/linux
- #ln -sf /usr/share/lwjgl2/native/linux/libjinput-linux64.so natives/linux
- #ln -sf /usr/share/lwjgl2/native/linux/liblwjgl.so natives/linux
- #ln -sf /usr/share/lwjgl2/native/linux/libjinput-linux.so natives/linux
+ strip -s natives/linux/libbullet-linux-amd64.so natives/linux/libbullet-linux-i686.so
chmod a+w "$srcdir" # Terrible permissions hack to get the game to start
cp -ra "$srcdir" "${pkgdir}/usr/share/${pkgname}"
- # Copy this file (not entirely sure about this, but doesn't start without it)
- #install -Dm 644 "${srcdir}/rendering.cfg" "${pkgdir}/usr/share/${pkgname}/configs/engine/rendering.cfg"
- #rm "${pkgdir}/usr/share/${pkgname}/rendering.cfg"
}