summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Bruckner2017-09-04 09:58:48 +0200
committerMax Bruckner2017-09-04 09:58:48 +0200
commit9fb0de8ad761d857e395f88393d6acf8a8373041 (patch)
tree2a9f58d50d42c3d8020bb1a39a60987cd27079c9
parent5d442d113635d72a46bf445ef349d7d75a4afa38 (diff)
downloadaur-9fb0de8ad761d857e395f88393d6acf8a8373041.tar.gz
terasology-1:1.5.0alpha8-4
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89e12ecfd354..356e0828cadc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 3 08:49:50 UTC 2017
+# Mon Sep 4 07:58:30 UTC 2017
pkgbase = terasology
pkgdesc = Yet another high resolution game with blocks like Minecraft!
pkgver = 1.5.0alpha8
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = http://terasology.org
arch = x86_64
@@ -15,6 +15,7 @@ pkgbase = terasology
depends = libxcursor
depends = libxxf86vm
depends = libxrandr
+ depends = lwjgl2
options = !strip
source = terasology
source = terasology.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 836eba6080a0..ffbfb18550b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@ pkgname=terasology
_version=1.5.0
_version_postfix=alpha8
pkgver=${_version}${_version_postfix}
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="Yet another high resolution game with blocks like Minecraft!"
arch=('x86_64' 'i686')
license=('Apache')
url="http://terasology.org"
options=('!strip')
-depends=('java-environment-openjdk=8' 'openal' 'libxcursor' 'libxxf86vm' 'libxrandr')
+depends=('java-environment-openjdk=8' 'openal' 'libxcursor' 'libxxf86vm' 'libxrandr' 'lwjgl2')
makedepends=('unzip')
source=(
"$pkgname"
@@ -41,15 +41,16 @@ package() {
popd
rm -r org
- #remove files/dirs for other operating systems
+ #remove files/dirs for other operating systems and native libraries
rm run_macosx.command Terasology.{x86,x64}.exe
- rm -r natives/{macosx,windows}
- rm natives/linux/libopenal*
- if [[ "$CARCH" == 'x86_64' ]]; then
- rm natives/linux/lib{jinput-linux,lwjgl}.so
- elif [[ "$CARCH" == 'i686' ]]; then
- rm natives/linux/lib{jinput-linux,lwjgl}64.so
- fi
+ rm -r natives
+ mkdir -p natives/linux
+
+ #link the lwjgl libraries
+ ln -sf /usr/share/lwjgl2/native/linux/liblwjgl64.so natives/linux
+ ln -sf /usr/share/lwjgl2/native/linux/libjinput-linux64.so natives/linux
+ ln -sf /usr/share/lwjgl2/native/linux/liblwjgl.so natives/linux
+ ln -sf /usr/share/lwjgl2/native/linux/libjinput-linux.so natives/linux
cp -ra "$srcdir" "${pkgdir}/usr/share/${pkgname}"
}