summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2021-04-17 20:25:57 -0500
committerAnthony Wang2021-04-17 20:25:57 -0500
commitd4698d24ac826c64fe9e474a4d6f1f4e922ecae6 (patch)
tree56e430c8265c9e89b6a4bba3581ed1eedcb86200
parent8a350938e535e51521144bf564e2e1997fa8245e (diff)
downloadaur-d4698d24ac826c64fe9e474a4d6f1f4e922ecae6.tar.gz
Fix permissions problems with a bad hack
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae7d70619543..97bcf79d5c25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,10 +55,10 @@ package() {
#ln -sf /usr/share/lwjgl2/native/linux/libjinput-linux64.so natives/linux
#ln -sf /usr/share/lwjgl2/native/linux/liblwjgl.so natives/linux
#ln -sf /usr/share/lwjgl2/native/linux/libjinput-linux.so natives/linux
-
+
+ chmod a+w "$srcdir" # Terrible permissions hack to get the game to start
cp -ra "$srcdir" "${pkgdir}/usr/share/${pkgname}"
- # install -Dm 755 "${srcdir}" "$pkgdir/usr/share/${pkgname}"
-
+
# Copy this file (not entirely sure about this, but doesn't start without it)
#install -Dm 644 "${srcdir}/rendering.cfg" "${pkgdir}/usr/share/${pkgname}/configs/engine/rendering.cfg"
#rm "${pkgdir}/usr/share/${pkgname}/rendering.cfg"