summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnima2022-05-15 22:34:28 +1200
committerAnima2022-05-15 22:34:28 +1200
commit07a5cdbbe8edbd5c010260c88af3a76ea6c123e6 (patch)
tree3b53635f36ec1aff84c6fb50bea559c9616190da
downloadaur-07a5cdbbe8edbd5c010260c88af3a76ea6c123e6.tar.gz
initial release
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD45
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..377484092e8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = teres
+ pkgdesc = Easily and efficiently add motion blur and or framerate to videos through interpolation and frameblending
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/animafps/teres
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ makedepends = cargo
+ makedepends = python
+ makedepends = gtk3
+ depends = vapoursynth-plugin-havsfunc
+ depends = vapoursynth
+ depends = ffmpeg
+ depends = vapoursynth-plugin-svpflow1
+ depends = ffms2
+ depends = vapoursynth-plugin-svpflow2-bin
+ depends = vapoursynth-plugin-mvsfunc-git
+ optdepends = vapoursynth-plugin-rife-ncnn-vulkan-git: RIFE-NCNN Vulkan support
+ optdepends = vapoursynth-plugin-vsrife-git: RIFE CUDA support
+ source = teres-0.2.3.tar.gz::https://github.com/animafps/teres/archive/v0.2.3.tar.gz
+ sha256sums = SKIP
+
+pkgname = teres
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ff71679242bd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/*.tar.xyz
+/*.tar.gz
+/*.tar.zst
+/pkg
+/src
+/teres*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a39875b5f17b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Anima <contact@animafps.xyz>
+pkgname=teres
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="Easily and efficiently add motion blur and or framerate to videos through interpolation and frameblending"
+depends=('vapoursynth-plugin-havsfunc' 'vapoursynth' 'ffmpeg' 'vapoursynth-plugin-svpflow1' 'ffms2' 'vapoursynth-plugin-svpflow2-bin' 'vapoursynth-plugin-mvsfunc-git')
+optdepends=('vapoursynth-plugin-rife-ncnn-vulkan-git: RIFE-NCNN Vulkan support'
+'vapoursynth-plugin-vsrife-git: RIFE CUDA support')
+makedepends=('rust' 'cargo' 'python' 'gtk3')
+arch=('x86_64')
+license=('GPL3')
+url="https://github.com/animafps/teres"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/animafps/teres/archive/v$pkgver.tar.gz")
+sha256sums=(SKIP)
+
+prepare() {
+ cd $pkgname-$pkgver
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd $pkgname-$pkgver
+ curl https://github.com/couleurm/vs-frameblender/releases/download/1.2/vs-frameblender-1.2.so -o vs-frameblender-1.2.so
+ install -Dt "$pkgdir/usr/lib/vapoursynth/" vs-frameblender-1.2.so
+ python plugins/weighting.py install
+ python plugins/filldrops.py install
+
+ install -Dm0755 -t "$pkgdir/usr/bin" "target/release/$pkgname"
+
+ install -Dm644 README.md "$pkgdir/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}