diff options
author | Felipe | 2023-07-31 07:18:14 -0400 |
---|---|---|
committer | Felipe | 2023-07-31 07:18:14 -0400 |
commit | c186cc1c95f75a256f51e41d2652e29c0680940a (patch) | |
tree | a2f07eb8b71185368624bfd8eae908fcdf832c84 | |
parent | 1cdf3fcd27cba14d97884f2c63c90b8716fc5bf1 (diff) | |
download | aur-c186cc1c95f75a256f51e41d2652e29c0680940a.tar.gz |
Updates v.1.0.4
-rw-r--r-- | PKGBUILD | 15 |
1 files changed, 6 insertions, 9 deletions
@@ -15,18 +15,15 @@ sha256sums=('ee0993e675697753282e874a79bce68fb433b1ecd1ca87736737ebbfba477558') build() { # Extract the source code directly to the $srcdir tar xf "v.${pkgver}.tar.gz" -C "$srcdir" --strip-components=1 - cd "$srcdir" - - # Ensure term_notes_linux.c is present in the build directory - cp term_notes_linux.c "$srcdir"/TermNotes-"$pkgver"/src/term_notes_linux.c - - # Use term_notes_linux.c for the build - gcc -o term-notes "$srcdir"/TermNotes-"$pkgver"/src/term_notes_linux.c -} + cd "$srcdir"/TermNotes-"$pkgver"/src + # Use symbolic link for term_notes_linux.c + ln -s term_notes_linux.c term_notes.c + gcc -o term-notes term_notes.c +} package() { - cd "$srcdir" + cd "$srcdir"/TermNotes-"$pkgver"/src install -Dm755 term-notes "${pkgdir}/usr/bin/term-notes" } |