summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2021-02-07 17:12:59 +0300
committerorhun2021-02-07 17:12:59 +0300
commit7b1090fdf95c22be7610322eb89f2549267eb842 (patch)
treec0ccedd18673271e5ba5e0cb1781786bbdf3f3c1
parent824593a8275b69912eced2da39694a9b601b6713 (diff)
downloadaur-7b1090fdf95c22be7610322eb89f2549267eb842.tar.gz
upgpkg: termchat-git 1.2.0.r3.g2398e84-1
Add '--all-features'
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 637b39598052..25544ff23e9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = termchat-git
pkgdesc = Terminal chat through the LAN (git)
- pkgver = 1.2.0.r2.g83356d4
+ pkgver = 1.2.0.r3.g2398e84
pkgrel = 1
url = https://github.com/lemunozm/termchat
arch = x86_64
license = Apache
makedepends = rust
+ makedepends = clang
makedepends = git
depends = gcc-libs
provides = termchat
diff --git a/PKGBUILD b/PKGBUILD
index ff559fe126a6..589747c0d082 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# https://github.com/orhun/pkgbuilds
pkgname=termchat-git
-pkgver=1.2.0.r2.g83356d4
+pkgver=1.2.0.r3.g2398e84
pkgrel=1
pkgdesc="Terminal chat through the LAN (git)"
arch=('x86_64')
url="https://github.com/lemunozm/termchat"
license=('Apache')
depends=('gcc-libs')
-makedepends=('rust' 'git')
+makedepends=('rust' 'clang' 'git')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+${url}")
@@ -22,12 +22,12 @@ pkgver() {
build() {
cd "${pkgname%-git}"
- cargo build --release --locked
+ cargo build --release --locked --all-features
}
check() {
cd "${pkgname%-git}"
- cargo test --release --locked
+ cargo test --release --locked --all-features
}
package() {