summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorotreblan2020-04-12 17:25:58 -0500
committerotreblan2020-04-12 17:25:58 -0500
commit78009c9cacaf22bdf9cc4993f11f0b2e3a33115d (patch)
tree6c72184a8e2cea56ca3a5fdb61505ea052bd593f
downloadaur-78009c9cacaf22bdf9cc4993f11f0b2e3a33115d.tar.gz
First commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD38
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48895357a1f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = termcolor
+ pkgdesc = A header-only C++ library for printing colored messages to the terminal
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/ikalnytskyi/termcolor
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ source = termcolor-1.0.1.tar.gz::https://github.com/ikalnytskyi/termcolor/archive/v1.0.1.tar.gz
+ sha256sums = 612f9ff785c74dcbe081bb82e8c915858572cf97dcf396ea7bd6a7d21cf6026a
+
+pkgname = termcolor
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f281b37469ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Otreblan <otreblain@gmail.com>
+
+pkgname=termcolor
+pkgver=1.0.1
+pkgrel=1
+epoch=
+pkgdesc="A header-only C++ library for printing colored messages to the terminal"
+arch=('x86_64')
+url="https://github.com/ikalnytskyi/termcolor"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('cmake')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=("612f9ff785c74dcbe081bb82e8c915858572cf97dcf396ea7bd6a7d21cf6026a")
+
+prepare() {
+ mkdir -p "$pkgname-$pkgver/build"
+}
+
+build() {
+ cd "$pkgname-$pkgver/build"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_UNITY_BUILD=ON \
+ -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
+ ..
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}