summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2021-07-30 19:07:55 +0200
committerkleintux2021-07-30 19:07:55 +0200
commit96c66b795bc926f9e7429c69d6904f03bd64fb4a (patch)
tree46b86f591c9f87ddb7381bad16e9d9b6527002d7
parent1cc765a17abece7cf81792686233c0d95ab22579 (diff)
downloadaur-96c66b795bc926f9e7429c69d6904f03bd64fb4a.tar.gz
package adopted and updated to newest version. Fixed some stuff
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b2b14ad8bea..1f56c3cf8c59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Jul 20 11:46:42 UTC 2018
pkgbase = terminal-parrot
pkgdesc = Party parrot (http://cultofthepartyparrot.com) for your terminal
- pkgver = 1.1.0
+ pkgver = 1.1.1
pkgrel = 1
url = https://github.com/jmhobbs/terminal-parrot
arch = any
@@ -11,8 +9,7 @@ pkgbase = terminal-parrot
conflicts = terminal-parrot-git
options = !strip
options = !emptydirs
- source = terminal-parrot-1.1.0.tar.gz::https://github.com/jmhobbs/terminal-parrot/archive/1.1.0.tar.gz
- sha256sums = beba7a1fb643b72e3d2f23f5371936828653e60c1bb1339cf732026e15b8370d
+ source = terminal-parrot-1.1.1.tar.gz::https://github.com/jmhobbs/terminal-parrot/archive/1.1.1.tar.gz
+ sha256sums = 93acae68396c8cb9e7a7ef4911503f03656e427b5791f4c2e5c9b3f8e56dce8d
pkgname = terminal-parrot
-
diff --git a/PKGBUILD b/PKGBUILD
index ea14f1404728..64fc6752c3e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Alexis "Horgix" Chotard <alexis.horgix.chotard@gmail.com>
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
pkgname=terminal-parrot
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
conflicts=('terminal-parrot-git')
pkgdesc="Party parrot (http://cultofthepartyparrot.com) for your terminal"
@@ -11,7 +12,7 @@ license=('MIT')
makedepends=('go')
options=('!strip' '!emptydirs')
source=($pkgname-$pkgver.tar.gz::"https://github.com/jmhobbs/terminal-parrot/archive/$pkgver.tar.gz")
-sha256sums=('beba7a1fb643b72e3d2f23f5371936828653e60c1bb1339cf732026e15b8370d')
+sha256sums=('93acae68396c8cb9e7a7ef4911503f03656e427b5791f4c2e5c9b3f8e56dce8d')
prepare() {
mkdir -p go
@@ -24,13 +25,18 @@ build() {
export GOPATH="$srcdir/go"
cd "$pkgname-$pkgver"
- go build
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
+ .
}
package() {
cd "$pkgname-$pkgver"
- install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
- # To be included in later version
- #install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}