summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexis 'Horgix' Chotard2016-09-13 01:26:48 +0200
committerAlexis 'Horgix' Chotard2016-09-13 01:26:48 +0200
commitcf407826281a115938f564969dcb86313e498bad (patch)
treecc79bc578e2f6bdb2c5d151b1918dcdc2fc6cda9
downloadaur-cf407826281a115938f564969dcb86313e498bad.tar.gz
Initial commit: v1.0.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a7e29605029
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Sep 12 23:26:05 UTC 2016
+pkgbase = terminal-parrot
+ pkgdesc = Party parrot (http://cultofthepartyparrot.com) for your terminal
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/jmhobbs/terminal-parrot
+ arch = any
+ license = MIT
+ makedepends = go
+ conflicts = terminal-parrot-git
+ options = !strip
+ options = !emptydirs
+ source = terminal-parrot-1.0.1.tar.gz::https://github.com/jmhobbs/terminal-parrot/archive/1.0.1.tar.gz
+ sha256sums = 11377c31e14d21f40a6d307dd14356642e88113a2a540c7d1160baca9dd07f56
+
+pkgname = terminal-parrot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..351913dc1577
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Alexis "Horgix" Chotard <alexis.horgix.chotard@gmail.com>
+
+pkgname=terminal-parrot
+pkgver=1.0.1
+pkgrel=1
+conflicts=('terminal-parrot-git')
+pkgdesc="Party parrot (http://cultofthepartyparrot.com) for your terminal"
+arch=('any')
+url="https://github.com/jmhobbs/terminal-parrot"
+license=('MIT')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/jmhobbs/terminal-parrot/archive/$pkgver.tar.gz")
+sha256sums=('11377c31e14d21f40a6d307dd14356642e88113a2a540c7d1160baca9dd07f56')
+
+prepare() {
+ mkdir -p go
+ echo $srcdir
+ export GOPATH="$srcdir/go"
+ go get github.com/nsf/termbox-go
+}
+
+build() {
+ export GOPATH="$srcdir/go"
+ cd "$pkgname-$pkgver"
+
+ go build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
+ # To be included in later version
+ #install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}