summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimlonghao2020-09-13 14:13:38 +0000
committerimlonghao2020-09-13 14:13:38 +0000
commit611979384a4ca4e56847251c850730ab43ffc83e (patch)
treed68901ff66898b1d617079f688773eff8e17c737
parente2c665468adaefeb8ac11d377a9fa83ba2aacc98 (diff)
downloadaur-611979384a4ca4e56847251c850730ab43ffc83e.tar.gz
New version 3.4.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0da30c1b1d5..65a1d00a029f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = terminal-to-html
pkgdesc = Converts arbitrary shell output (with ANSI) into beautifully rendered HTML
- pkgver = 3.3.0
+ pkgver = 3.4.0
pkgrel = 1
url = https://github.com/buildkite/terminal-to-html
arch = x86_64
arch = i686
license = MIT
- makedepends = go-pie
+ makedepends = go
+ makedepends = go-bindata
depends = glibc
provides = terminal-to-html
conflicts = terminal-to-html
- source = terminal-to-html-3.3.0.tar.gz::https://github.com/buildkite/terminal-to-html/archive/v3.3.0.tar.gz
+ source = terminal-to-html-3.4.0.tar.gz::https://github.com/buildkite/terminal-to-html/archive/v3.4.0.tar.gz
source = LICENSE
- sha256sums = b0a250e85e5c5f7b22e7eaea482db372de11d5398bcfee3defec490d47f01e22
+ sha256sums = bd6584245c1224d139e9a5b57e9326bbd68b0961dad85374cdbe5ad36fd70356
sha256sums = ad8a919cd390f9475ed22addad10d283539f5b9afec268b03427c667e60b9ae5
pkgname = terminal-to-html
diff --git a/PKGBUILD b/PKGBUILD
index d77c0cf664f4..5de1eedf2706 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hao Long <aur@esd.cc>
pkgname=terminal-to-html
-pkgver=3.3.0
+pkgver=3.4.0
pkgrel=1
pkgdesc="Converts arbitrary shell output (with ANSI) into beautifully rendered HTML"
arch=("x86_64" "i686")
@@ -10,18 +10,24 @@ license=('MIT')
provides=('terminal-to-html')
conflicts=('terminal-to-html')
depends=('glibc')
-makedepends=('go-pie')
+makedepends=('go' 'go-bindata')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"LICENSE")
-sha256sums=('b0a250e85e5c5f7b22e7eaea482db372de11d5398bcfee3defec490d47f01e22'
+sha256sums=('bd6584245c1224d139e9a5b57e9326bbd68b0961dad85374cdbe5ad36fd70356'
'ad8a919cd390f9475ed22addad10d283539f5b9afec268b03427c667e60b9ae5')
build() {
- cd ${pkgname}-${pkgver}/cmd/${pkgname}
- go build -trimpath -ldflags "-extldflags ${LDFLAGS}" .
+ cd ${pkgname}-${pkgver}
+ go-bindata -o ./cmd/bindata.go assets/
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build ./cmd/${pkgname}
}
package() {
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm755 "$pkgname-$pkgver/cmd/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
}