summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmaël Bouya2017-02-02 10:26:29 +0100
committerIsmaël Bouya2017-02-02 10:26:29 +0100
commitb00b24a7ff37355fe795e015b785a269250805c8 (patch)
tree3b7abd657dd5020fc14219a9c8f84a5eda325baf
parentdff3ca6744077a5c12d5240a73d2e7aee060c7e2 (diff)
downloadaur-b00b24a7ff37355fe795e015b785a269250805c8.tar.gz
Remove patch which was applied upstream
-rw-r--r--.SRCINFO6
-rw-r--r--001_fix_shell_escape.patch31
-rw-r--r--PKGBUILD5
3 files changed, 3 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 906138fd5321..4d84487f05a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jan 19 12:25:53 UTC 2017
+# Thu Feb 2 09:26:10 UTC 2017
pkgbase = terminal_velocity-git
pkgdesc = A fast note-taking app for the UNIX terminal (patched)
- pkgver = 0.1a7.r19.g1beb614
+ pkgver = 0.1a7.r21.gbb2000b
pkgrel = 1
url = https://github.com/vhp/terminal_velocity
arch = any
@@ -11,10 +11,8 @@ pkgbase = terminal_velocity-git
depends = python2-urwid
depends = python2-chardet
source = git://github.com/vhp/terminal_velocity.git
- source = 001_fix_shell_escape.patch
source = 002_sort_found_notes.patch
sha1sums = SKIP
- sha1sums = 92addaf76d635bf0ece018c8b35bb6a70740a1ae
sha1sums = 426613e5620251c37854e489b21e4790c6c7df3b
pkgname = terminal_velocity-git
diff --git a/001_fix_shell_escape.patch b/001_fix_shell_escape.patch
deleted file mode 100644
index 961d72ed4c66..000000000000
--- a/001_fix_shell_escape.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/urwid_ui.py
-+++ b/urwid_ui.py
-@@ -5,6 +5,7 @@ Implemented using the console user interface library urwid.
- """
- import subprocess
- import shlex
-+import pipes
- import logging
- logger = logging.getLogger(__name__)
-
-@@ -322,16 +323,16 @@ class MainFrame(urwid.Frame):
-
- elif key in ["enter"]:
- if self.selected_note:
-- system(self.editor + " '" + self.selected_note.abspath + "'", self.loop)
-+ system(self.editor + ' ' + pipes.quote(self.selected_note.abspath), self.loop)
- else:
- if self.search_box.edit_text:
- try:
- note = self.notebook.add_new(self.search_box.edit_text)
-- system(self.editor + " '" + note.abspath + "'", self.loop)
-+ system(self.editor + ' ' + pipes.quote(note.abspath), self.loop)
- except notebook.NoteAlreadyExistsError:
- # Try to open the existing note instead.
-- system(self.editor + " '" + self.search_box.edit_text +
-- self.notebook.extension + "'",
-+ system(self.editor + ' ' + pipes.quote(self.search_box.edit_text +
-+ self.notebook.extension),
- self.loop)
- except notebook.InvalidNoteTitleError:
- # TODO: Display error message to user.
diff --git a/PKGBUILD b/PKGBUILD
index 4e4e7a1af62e..677371604378 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=terminal_velocity
pkgname=terminal_velocity-git
-pkgver=0.1a7.r19.g1beb614
+pkgver=0.1a7.r21.gbb2000b
pkgrel=1
pkgdesc="A fast note-taking app for the UNIX terminal (patched)"
arch=('any')
@@ -12,11 +12,9 @@ depends=("python2-urwid" "python2-chardet")
makedepends=('git')
source=(
'git://github.com/vhp/terminal_velocity.git'
- '001_fix_shell_escape.patch'
'002_sort_found_notes.patch'
)
sha1sums=('SKIP'
- '92addaf76d635bf0ece018c8b35bb6a70740a1ae'
'426613e5620251c37854e489b21e4790c6c7df3b')
pkgver() {
@@ -26,7 +24,6 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname/$_pkgname"
- patch -p1 < ../../001_fix_shell_escape.patch
patch -p1 < ../../002_sort_found_notes.patch
cd "$srcdir/$_pkgname"
python2 setup.py build