summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmaël Bouya2017-01-19 09:33:53 +0100
committerIsmaël Bouya2017-01-19 09:33:53 +0100
commite682b5589778e3db8eb7292c119c9c8ffb54ba27 (patch)
treed5de2f1843aff8b110b2d2208c2a94272ad89d49
parentac596e9c4da2f53757e7e4979d48f209cdf0b1b7 (diff)
downloadaur-e682b5589778e3db8eb7292c119c9c8ffb54ba27.tar.gz
Update patches for last version
-rw-r--r--.SRCINFO8
-rw-r--r--001_fix_shell_escape.patch16
-rw-r--r--PKGBUILD6
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9bdbaf31af0..c49eef0c0971 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Mar 14 01:59:15 UTC 2016
+# Thu Jan 19 08:33:29 UTC 2017
pkgbase = terminal_velocity-git
pkgdesc = A fast note-taking app for the UNIX terminal (patched)
- pkgver = 0.96.5667177
- pkgrel = 3
+ pkgver = 0.102.9062e85
+ pkgrel = 1
url = https://github.com/seanh/terminal_velocity
arch = any
license = GPL
@@ -14,7 +14,7 @@ pkgbase = terminal_velocity-git
source = 001_fix_shell_escape.patch
source = 002_sort_found_notes.patch
sha1sums = SKIP
- sha1sums = 7b04f0f28a4801931f7a0e499f5131d5a5c3653c
+ sha1sums = 92addaf76d635bf0ece018c8b35bb6a70740a1ae
sha1sums = 426613e5620251c37854e489b21e4790c6c7df3b
pkgname = terminal_velocity-git
diff --git a/001_fix_shell_escape.patch b/001_fix_shell_escape.patch
index c3c28c3e8cf9..961d72ed4c66 100644
--- a/001_fix_shell_escape.patch
+++ b/001_fix_shell_escape.patch
@@ -1,6 +1,6 @@
---- a/urwid_ui.py 2016-03-14 02:28:17.425313918 +0100
-+++ b/urwid_ui.py 2016-03-14 02:29:22.807844809 +0100
-@@ -5,6 +5,7 @@
+--- a/urwid_ui.py
++++ b/urwid_ui.py
+@@ -5,6 +5,7 @@ Implemented using the console user interface library urwid.
"""
import subprocess
import shlex
@@ -8,22 +8,22 @@
import logging
logger = logging.getLogger(__name__)
-@@ -323,16 +324,16 @@
+@@ -322,16 +323,16 @@ class MainFrame(urwid.Frame):
elif key in ["enter"]:
if self.selected_note:
-- system(self.editor + ' ' + self.selected_note.abspath, self.loop)
+- system(self.editor + " '" + self.selected_note.abspath + "'", self.loop)
+ system(self.editor + ' ' + pipes.quote(self.selected_note.abspath), self.loop)
else:
if self.search_box.edit_text:
try:
note = self.notebook.add_new(self.search_box.edit_text)
-- system(self.editor + ' ' + note.abspath, self.loop)
+- system(self.editor + " '" + note.abspath + "'", self.loop)
+ system(self.editor + ' ' + pipes.quote(note.abspath), self.loop)
except notebook.NoteAlreadyExistsError:
# Try to open the existing note instead.
-- system(self.editor + ' ' + self.search_box.edit_text +
-- self.notebook.extension,
+- system(self.editor + " '" + self.search_box.edit_text +
+- self.notebook.extension + "'",
+ system(self.editor + ' ' + pipes.quote(self.search_box.edit_text +
+ self.notebook.extension),
self.loop)
diff --git a/PKGBUILD b/PKGBUILD
index 2242376b2e1c..084d3511ff4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=terminal_velocity
pkgname=terminal_velocity-git
-pkgver=0.96.5667177
-pkgrel=3
+pkgver=0.102.9062e85
+pkgrel=1
pkgdesc="A fast note-taking app for the UNIX terminal (patched)"
arch=('any')
url="https://github.com/seanh/terminal_velocity"
@@ -16,7 +16,7 @@ source=(
'002_sort_found_notes.patch'
)
sha1sums=('SKIP'
- '7b04f0f28a4801931f7a0e499f5131d5a5c3653c'
+ '92addaf76d635bf0ece018c8b35bb6a70740a1ae'
'426613e5620251c37854e489b21e4790c6c7df3b')
pkgver() {