summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmaël Bouya2016-03-14 02:38:33 +0100
committerIsmaël Bouya2016-03-14 02:38:33 +0100
commitff8c1c853c1b200a481e8026898da2a5f0c450d7 (patch)
treee795c7ee66bee61b32f94014b085956978fd31ef
downloadaur-ff8c1c853c1b200a481e8026898da2a5f0c450d7.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..750bf5107068
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Mar 14 01:38:20 UTC 2016
+pkgbase = terminal_velocity-git
+ pkgdesc = A fast note-taking app for the UNIX terminal
+ pkgver = 0.96.5667177
+ pkgrel = 1
+ url = https://github.com/seanh/terminal_velocity
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2-urwid
+ depends = python2-chardet
+ source = git://github.com/seanh/terminal_velocity.git
+ sha1sums = SKIP
+
+pkgname = terminal_velocity-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5c5965d41fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ismaël Bouya <ismael.bouya@normalesup.org>
+
+_pkgname=terminal_velocity
+pkgname=terminal_velocity-git
+pkgver=0.96.5667177
+pkgrel=1
+pkgdesc="A fast note-taking app for the UNIX terminal"
+arch=('any')
+url="https://github.com/seanh/terminal_velocity"
+license=('GPL')
+depends=("python2-urwid" "python2-chardet")
+makedepends=('git')
+source=(
+ 'git://github.com/seanh/terminal_velocity.git'
+)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "0.$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}