summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2019-07-29 14:47:29 -0700
committerGavin Lloyd2019-07-29 14:47:29 -0700
commitda7bdcf340b954947e75d53bd3933dff117f560f (patch)
treef61d43747abf9bb5aadb45e30e3fc5411f7efc72
downloadaur-da7bdcf340b954947e75d53bd3933dff117f560f.tar.gz
Init commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD53
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e815a64c77d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = terminus-font-td1-ttf
+ pkgdesc = Fixed-width bitmap font (td1 patch) (TTF version)
+ pkgver = 4.47
+ pkgrel = 1
+ url = https://files.ax86.net/terminus-ttf
+ arch = any
+ license = GPL2
+ license = custom:OFL
+ makedepends = python
+ makedepends = fontforge
+ makedepends = potrace
+ makedepends = mkbold-mkitalic
+ makedepends = git
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ depends = fontconfig
+ provides = terminus-font-ttf
+ conflicts = terminus-font-ttf
+ source = https://downloads.sourceforge.net/project/terminus-font/terminus-font-4.47/terminus-font-4.47.tar.gz
+ source = git+https://github.com/Tblue/mkttf
+ sha256sums = 0f1b205888e4e26a94878f746b8566a65c3e3742b33cf9a4e6517646d5651297
+ sha256sums = SKIP
+
+pkgname = terminus-font-td1-ttf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09364936ddfb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: Gavin Lloyd <gavinhungry@gmail.com>
+# Contributor: Dan Elkouby <streetwalrus@codewalr.us>
+# Contributor: Braden Pellett (daBrado) <aurcontact@dabrado.net>
+# Contributor: Vesa Kaihlavirta <vegai@iki.fi>
+# Contributor: Kristoffer Fossgård <kfs1@online.no>
+
+_pkgname=terminus-font
+pkgname=${_pkgname}-td1-ttf
+pkgver=4.47
+pkgrel=1
+pkgdesc="Fixed-width bitmap font (td1 patch) (TTF version)"
+arch=("any")
+url="https://files.ax86.net/terminus-ttf"
+license=("GPL2" "custom:OFL")
+depends=("xorg-fonts-encodings" "xorg-font-utils" "fontconfig")
+makedepends=("python" "fontforge" "potrace" "mkbold-mkitalic" "git")
+conflicts=("terminus-font-ttf")
+provides=("terminus-font-ttf")
+source=("https://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+ "git+https://github.com/Tblue/mkttf")
+sha256sums=('0f1b205888e4e26a94878f746b8566a65c3e3742b33cf9a4e6517646d5651297'
+ 'SKIP')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch < alt/td1.diff
+
+ sed -i -e "s/-A ' -a -1' -V \"\${FONTVER}\" -O/-A ' -a -1' -V \"\${FONTVER}\"/" \
+ "${srcdir}/mkttf/mkttf.sh"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./configure --prefix=/usr --x11dir=/usr/share/fonts/misc --psfdir=/usr/share/kbd/consolefonts
+ make
+
+ cd "${srcdir}/mkttf"
+ # MALLOC_CHECK_ is a temporary workaround to avoid crashing in fontforge code
+ # It will print errors but they are harmless
+ MALLOC_CHECK_=1 ./mkttf.sh "${srcdir}/${_pkgname}-${pkgver}" "${pkgver}" "TerminusTTF" "Terminus (TTF)"
+}
+
+package() {
+ cd "${srcdir}/mkttf"
+
+ for i in {Normal,Bold,Italic}/*.ttf; do
+ local destname="$(basename "$i" | sed -E 's/-[[:digit:].]+\.ttf$/.ttf/')"
+ install -Dm 644 "$i" "${pkgdir}/usr/share/fonts/TTF/${destname}"
+ done
+
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -Dm644 OFL.TXT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}