summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302021-10-02 12:07:18 +0200
committerM0Rf302021-10-02 12:07:18 +0200
commite0549dd1888452b9d0e792eca7d4655fc5bd1ffc (patch)
tree8618cf59a82f556f16668c613b2b361cd7ed648d
parent4dbe26e6fb25e91d843ca87c80f8dcf07f99af28 (diff)
downloadaur-e0549dd1888452b9d0e792eca7d4655fc5bd1ffc.tar.gz
termistor-git: update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62384e4d5171..b9c6cf212d69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Dec 27 16:53:23 UTC 2015
pkgbase = termistor-git
pkgdesc = A drop-down terminal for Wayland
- pkgver = 43.0fe1765
+ pkgver = 50.bc0843f
pkgrel = 1
url = https://github.com/giucam/termistor
arch = i686
@@ -11,8 +9,9 @@ pkgbase = termistor-git
makedepends = git
depends = wayland
depends = libxkbcommon
- source = termistor::git+https://github.com/giucam/termistor.git
+ provides = termistor
+ conflicts = termistor
+ source = termistor::git+https://github.com/giucam/termistor
md5sums = SKIP
pkgname = termistor-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 468a647adc51..ea0872b52e5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
# Maintainer: robertfoster
pkgname=termistor-git
-pkgver=43.0fe1765
+pkgver=50.bc0843f
pkgrel=1
pkgdesc="A drop-down terminal for Wayland"
arch=('i686' 'x86_64')
url="https://github.com/giucam/termistor"
license=('GPL3')
-depends=(wayland libxkbcommon)
+depends=('wayland' 'libxkbcommon')
makedepends=('git')
-source=('termistor::git+https://github.com/giucam/termistor.git')
+provides=("${pkgname%%-git}")
+conflicts=("${pkgname%%-git}")
+source=("${pkgname%%-git}::git+${url}")
build() {
- cd termistor
+ cd "${srcdir}/${pkgname%%-git}"
cmake .
make
}
package(){
- cd termistor
+ cd "${srcdir}/${pkgname%%-git}"
make DESTDIR=$pkgdir install
}
pkgver() {
- cd termistor
+ cd "${srcdir}/${pkgname%%-git}"
echo $(git rev-list --count master).$(git rev-parse --short master)
}