summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRintim2019-06-24 10:44:56 +0800
committerRintim2019-06-24 10:44:56 +0800
commit46ea2dd88eb3660915f97eb24e5fab1b710a9ed1 (patch)
tree5f61b632592ad25f96ae82e16b30846c6e036350
downloadaur-46ea2dd88eb3660915f97eb24e5fab1b710a9ed1.tar.gz
Upload New File
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD23
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65fc266060a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = termius-app
+ pkgdesc = the SSH client that works on Desktop
+ pkgver = 4.7.2
+ pkgrel = 1
+ url = https://www.termius.com/
+ arch = x86_64
+ license = GPL
+ depends = desktop-file-utils
+ depends = gconf
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk2
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ noextract = Termius.deb
+ source = https://www.termius.com/download/linux/Termius.deb
+ md5sums = 2b82c796e2b9bf17f14d93d31511e097
+
+pkgname = termius-app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd3c200b2412
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=termius-app
+pkgver=4.7.2
+pkgrel=1
+pkgdesc="the SSH client that works on Desktop"
+arch=('x86_64')
+url="https://www.termius.com/"
+license=('GPL')
+depends=('desktop-file-utils' 'gconf' 'hicolor-icon-theme' 'libappindicator-gtk2' 'libnotify' 'libxss' 'libxtst' 'nss')
+source=("https://www.termius.com/download/linux/Termius.deb")
+noextract=("Termius.deb")
+md5sums=("2b82c796e2b9bf17f14d93d31511e097")
+validpgpkeys=()
+
+prepare() {
+ ar -x Termius.deb
+ mkdir ${pkgname}-${pkgver}
+ tar -xf data.tar.xz --directory="${pkgname}-${pkgver}"
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ cp -r ./ ${pkgdir}/
+}