aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK2019-06-11 02:28:56 +0200
committerTBK2019-06-11 02:43:34 +0200
commit157a96ab8d44480dd168809df564e56a9dbfba27 (patch)
treeb205e3d8cffef2a782ae127f9ee5feb9c63fc592
downloadaur-157a96ab8d44480dd168809df564e56a9dbfba27.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD60
-rw-r--r--README.md17
-rw-r--r--termius-beta.desktop9
-rw-r--r--tos.html103
6 files changed, 217 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..982557ce4721
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = termius-beta
+ pkgdesc = Desktop SSH Client
+ pkgver = 4.2.7
+ pkgrel = 1
+ url = https://www.termius.com/
+ arch = x86_64
+ license = custom
+ makedepends = squashfs-tools
+ depends = gtk3
+ depends = nss
+ depends = libxtst
+ depends = gconf
+ depends = pulseaudio
+ depends = gnutls
+ depends = libxss
+ source = termius-beta-4.2.7.snap::https://api.snapcraft.io/api/v1/snaps/download/yyZzRdoyiRz3EM7iuvjhaIjDfnlFJcZs_64.snap
+ source = termius-beta.desktop
+ source = tos.html
+ sha256sums = 3ff6f8dfab1955be6c2398a55c36df3cf8345e41f9b5b27f60d514b23080fefb
+ sha256sums = 3bc6261d5749c5c9795dbcf3d23476d83c2f4251aa2ec6b1293a6022adaecf68
+ sha256sums = 9c969cc82314240860737dc09d48970271c798c9b1116ceb91556f75959788a2
+
+pkgname = termius-beta
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4c6144772280
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/*
+src/*
+*.pkg.tar.xz
+*.snap
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68a44daba8b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: TBK <aur@jjtc.eu>
+# Contributor: TBK <aur@jjtc.eu>
+
+pkgname=termius-beta
+pkgver=4.2.7
+pkgrel=1
+pkgdesc="Desktop SSH Client"
+url="https://www.termius.com/"
+arch=('x86_64')
+license=('custom')
+depends=('gtk3' 'nss' 'libxtst' 'gconf' 'pulseaudio' 'gnutls' 'libxss')
+makedepends=('squashfs-tools')
+# Get latest version + link from https://uappexplorer.com/snap/ubuntu/termius-beta || snap info termius-beta || run the following
+# curl -H 'X-Ubuntu-Series: 16' https://api.snapcraft.io/api/v1/snaps/details/termius-beta | jq '.download_url' -r
+# curl -H 'X-Ubuntu-Series: 16' https://api.snapcraft.io/api/v1/snaps/details/termius-beta | jq '.version' -r
+source=(
+ "${pkgname}-${pkgver}.snap::https://api.snapcraft.io/api/v1/snaps/download/yyZzRdoyiRz3EM7iuvjhaIjDfnlFJcZs_64.snap"
+ "termius-beta.desktop"
+ "tos.html"
+)
+sha256sums=('3ff6f8dfab1955be6c2398a55c36df3cf8345e41f9b5b27f60d514b23080fefb'
+ '3bc6261d5749c5c9795dbcf3d23476d83c2f4251aa2ec6b1293a6022adaecf68'
+ '9c969cc82314240860737dc09d48970271c798c9b1116ceb91556f75959788a2')
+
+prepare() {
+ mkdir ${pkgname}
+ unsquashfs -f -d ${pkgname} ${pkgname}-${pkgver}.snap
+}
+
+package() {
+ # Option 1 - copy only the needed files ~183 MiB
+ mkdir -p "$pkgdir"/opt/${pkgname}
+
+ cd "$srcdir"/${pkgname}
+
+ cp -r icudtl.dat \
+ libffmpeg.so \
+ locales \
+ natives_blob.bin \
+ resources \
+ resources.pak \
+ termius-beta \
+ v8_context_snapshot.bin \
+ "$pkgdir"/opt/${pkgname}
+
+ cd "$srcdir"
+ # Option 2 - copy all files from the .snap file ~503 MiB
+ #mkdir -p "$pkgdir"/opt/
+ #cp -r "$srcdir"/${pkgname} "$pkgdir"/opt/${pkgname}
+
+ find "$pkgdir"/opt/${pkgname}/ -type f -exec chmod 644 {} \;
+ chmod 755 "$pkgdir"/opt/${pkgname}/termius-beta
+
+ mkdir -p "${pkgdir}"/usr/bin
+ ln -sf /opt/${pkgname}/termius-beta "${pkgdir}"/usr/bin/${pkgname}
+ install -Dm0644 tos.html "${pkgdir}"/usr/share/licenses/${pkgname}/tos.html
+ install -Dm0644 ${pkgname}/LICENSE* "${pkgdir}"/usr/share/licenses/${pkgname}/
+ install -Dm0644 ${pkgname}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
+ install -Dm0644 ${pkgname}/meta/gui/icon.png "${pkgdir}"/usr/share/pixmaps/${pkgname}.png
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..03f230acb23c
--- /dev/null
+++ b/README.md
@@ -0,0 +1,17 @@
+# Termius Beta
+ Arch User Repository Termius Beta - Desktop SSH Client
+
+## Update package
+
+* Update package version in PKGBUILD
+* Generate new checksums with
+
+```$ updpkgsums```
+
+* Test install
+
+```$ makepkg -si```
+
+* Update .SRCINFO
+
+```$ makepkg --printsrcinfo > .SRCINFO```
diff --git a/termius-beta.desktop b/termius-beta.desktop
new file mode 100644
index 000000000000..890795afb1f3
--- /dev/null
+++ b/termius-beta.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Termius Beta
+Comment=Desktop SSH Client
+Exec=termius-beta
+Terminal=false
+Type=Application
+StartupNotify=true
+Icon=termius-beta
+Categories=System;TerminalEmulator;
diff --git a/tos.html b/tos.html
new file mode 100644
index 000000000000..6e7fea30d388
--- /dev/null
+++ b/tos.html
@@ -0,0 +1,103 @@
+<h1>Terms and Conditions</h1>
+<p>Last updated: May 30, 2018</p>
+<p>These Terms and Conditions ("Terms", "Terms and Conditions") govern your relationship with https://www.termius.com
+ website and Termius mobile application (the "Service") operated by Crystalnix Limited ("us", "we", or "our").</p>
+<p>Please read these Terms and Conditions carefully before using our website and Termius mobile application (the
+ "Service").</p>
+<p>Your access to and use of the Service is conditioned on your acceptance of and compliance with these Terms. These
+ Terms apply to all visitors, users and others who access or use the Service.</p>
+<p>By accessing or using the Service you agree to be bound by these Terms. If you disagree with any part of the terms
+ then you may not access the Service.</p>
+<h2>Subscriptions</h2>
+<p>Some parts of the Service are billed on a subscription basis ("Subscription(s)"). You will be billed in advance on a
+ recurring and periodic basis ("Billing Cycle"). Billing cycles are set either on a monthly or annual basis,
+ depending on the type of subscription plan you select when purchasing a Subscription.</p>
+<p>At the end of each Billing Cycle, your Subscription will automatically renew under the exact same conditions unless
+ you cancel it or Crystalnix Limited cancels it. You may cancel your Subscription renewal either through your online
+ account management page or by contacting Crystalnix Limited customer support team.</p>
+<p>A valid payment method, including credit card or PayPal, is required to process the payment for your Subscription.
+ You shall provide Crystalnix Limited with accurate and complete billing information including full name, address,
+ state, zip code, telephone number, and a valid payment method information. By submitting such payment information,
+ you automatically authorize Crystalnix Limited to charge all Subscription fees incurred through your account to any
+ such payment instruments.</p>
+<p>Should automatic billing fail to occur for any reason, Crystalnix Limited will issue an electronic invoice
+ indicating that you must proceed manually, within a certain deadline date, with the full payment corresponding to
+ the billing period as indicated on the invoice.</p>
+<h2>Free Trial</h2>
+<p>Crystalnix Limited may, at its sole discretion, offer a Subscription with a free trial for a limited period of time
+ ("Free Trial").</p>
+<p>You may be required to enter your billing information in order to sign up for the Free Trial.</p>
+<p>If you do enter your billing information when signing up for the Free Trial, you will not be charged by Crystalnix
+ Limited until the Free Trial has expired. On the last day of the Free Trial period, unless you cancelled your
+ Subscription, you will be automatically charged the applicable Subscription fees for the type of Subscription you
+ have selected.</p>
+<p>At any time and without notice, Crystalnix Limited reserves the right to (i) modify the terms and conditions of the
+ Free Trial offer, or (ii) cancel such Free Trial offer.</p>
+<h2>Fee Changes</h2>
+<p>Crystalnix Limited, in its sole discretion and at any time, may modify the Subscription fees for the Subscriptions.
+ Any Subscription fee change will become effective at the end of the then-current Billing Cycle.</p>
+<p>Crystalnix Limited will provide you with a reasonable prior notice of any change in Subscription fees to give you an
+ opportunity to terminate your Subscription before such change becomes effective.</p>
+<p>Your continued use of the Service after the Subscription fee change comes into effect constitutes your agreement to
+ pay the modified Subscription fee amount.</p>
+<h2>Refunds</h2>
+<p>Certain refund requests for Subscriptions may be considered by Crystalnix Limited on a case-by-case basis and
+ granted in sole discretion of Crystalnix Limited.</p>
+<h2>Accounts</h2>
+<p>When you create an account with us, you must provide us information that is accurate, complete, and current at all
+ times. Failure to do so constitutes a breach of the Terms, which may result in immediate termination of your
+ account on our Service.</p>
+<p>You are responsible for safeguarding the password that you use to access the Service and for any activities or
+ actions under your password, whether your password is with our Service or a third-party service.</p>
+<p>You agree not to disclose your password to any third party. You must notify us immediately upon becoming aware of
+ any breach of security or unauthorized use of your account.</p>
+<p>You may not use as a username the name of another person or entity or that is not lawfully available for use, a name
+ or trade mark that is subject to any rights of another person or entity other than you without appropriate
+ authorization, or a name that is otherwise offensive, vulgar or obscene.</p>
+<h2>Intellectual Property</h2>
+<p>The Service and its original content, features and functionality are and will remain the exclusive property of
+ Crystalnix Limited and its licensors. The Service is protected by copyright, trademark, and other laws of both the
+ New Zealand and foreign countries. Our trademarks and trade dress may not be used in connection with any product or
+ service without the prior written consent of Crystalnix Limited.</p>
+<h2>Links To Other Web Sites</h2>
+<p>Our Service may contain links to third-party web sites or services that are not owned or controlled by Crystalnix
+ Limited.</p>
+<p>Crystalnix Limited has no control over, and assumes no responsibility for, the content, privacy policies, or
+ practices of any third party web sites or services. You further acknowledge and agree that Crystalnix Limited shall
+ not be responsible or liable, directly or indirectly, for any damage or loss caused or alleged to be caused by or
+ in connection with use of or reliance on any such content, goods or services available on or through any such web
+ sites or services.</p>
+<p>We strongly advise you to read the terms and conditions and privacy policies of any third-party web sites or
+ services that you visit.</p>
+<h2>Limitation Of Liability</h2>
+<p>In no event shall Crystalnix Limited, nor its directors, employees, partners, agents, suppliers, or affiliates, be
+ liable for any indirect, incidental, special, consequential or punitive damages, including without limitation, loss
+ of profits, data, use, goodwill, or other intangible losses, resulting from (i) your access to or use of or
+ inability to access or use the Service; (ii) any conduct or content of any third party on the Service; (iii) any
+ content obtained from the Service; and (iv) unauthorized access, use or alteration of your transmissions or
+ content, whether based on warranty, contract, tort (including negligence) or any other legal theory, whether or not
+ we have been informed of the possibility of such damage, and even if a remedy set forth herein is found to have
+ failed of its essential purpose.</p>
+<h2>Disclaimer</h2>
+<p>Your use of the Service is at your sole risk. The Service is provided on an "AS IS" and "AS AVAILABLE" basis. The
+ Service is provided without warranties of any kind, whether express or implied, including, but not limited to,
+ implied warranties of merchantability, fitness for a particular purpose, non-infringement or course of performance.</p>
+<p>Crystalnix Limited its subsidiaries, affiliates, and its licensors do not warrant that a) the Service will function
+ uninterrupted, secure or available at any particular time or location; b) any errors or defects will be corrected;
+ c) the Service is free of viruses or other harmful components; or d) the results of using the Service will meet
+ your requirements.</p>
+<h2>Governing Law</h2>
+<p>These Terms shall be governed and construed in accordance with the laws of New Zealand, without regard to its
+ conflict of law provisions.</p>
+<p>Our failure to enforce any right or provision of these Terms will not be considered a waiver of those rights. If any
+ provision of these Terms is held to be invalid or unenforceable by a court, the remaining provisions of these Terms
+ will remain in effect. These Terms constitute the entire agreement between us regarding our Service, and supersede
+ and replace any prior agreements we might have between us regarding the Service.</p>
+<h2>Changes</h2>
+<p>We reserve the right, at our sole discretion, to modify or replace these Terms at any time. If a revision is
+ material we will try to provide at least 30 days notice prior to any new terms taking effect. What constitutes a
+ material change will be determined at our sole discretion.</p>
+<p>By continuing to access or use our Service after those revisions become effective, you agree to be bound by the
+ revised terms. If you do not agree to the new terms, please stop using the Service.</p>
+<h2>Contact Us</h2>
+<p>If you have any questions about these Terms, please contact us.</p> \ No newline at end of file