summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchitekton2018-11-29 14:42:11 +1100
committerArchitekton2018-11-29 14:42:11 +1100
commitd82cb8a1495b5563845d279fe7b0e44358ab9f37 (patch)
tree0b07985d0ffde8eddc384ab44616130c5f0a2e57
parentdd3536f041ccc7ce63912e7cba58d5a98d8a5c33 (diff)
downloadaur-d82cb8a1495b5563845d279fe7b0e44358ab9f37.tar.gz
bump to 2.0.5
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48d4239bbdfb..e342cb437d1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
pkgbase = termplay
pkgdesc = Play an image/video in your terminal!
- pkgver = 2.0.0
- pkgrel = 2
+ pkgver = 2.0.5
+ pkgrel = 1
url = https://github.com/jD91mZM2/termplay
arch = x86_64
license = MIT
- license = custom
makedepends = rust
makedepends = openal
makedepends = libsndfile
makedepends = gstreamer
makedepends = gst-plugins-base
makedepends = gst-plugins-bad
+ depends = gstreamer
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gst-plugins-ugly
+ depends = gst-plugins-bad
depends = libsixel
optdepends = ffmpeg: Video support
optdepends = maim: Screen-mirroring support
optdepends = youtube-dl: YouTube support
- source = https://github.com/jD91mZM2/termplay/archive/2.0.0.tar.gz
- sha256sums = 26140b14e93336b606c457e03e7c5bcbb243373cf1e0a2cd2d0a0197d3cf9394
+ source = termplay-2.0.5.tar.gz::https://github.com/jD91mZM2/termplay/archive/2.0.5.tar.gz
+ sha512sums = 0d8e14301137c01e51294ab571507310d77cd1aa7c51fb47b85a637edc9110cce2466da7b5bfc43271d92560df65fe5bac8585be24021be98396056adf410fbb
pkgname = termplay
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 4df5cbd2d036..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!.SRCINFO
-!.gitignore
-!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 8887c7df0422..ffb8f78d79aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: jD91mZM2 <me@krake.one>
pkgname=termplay
-pkgver=2.0.4
+pkgver=2.0.5
pkgrel=1
pkgdesc="Play an image/video in your terminal!"
arch=("x86_64")
@@ -10,18 +10,23 @@ makedepends=("rust" "openal" "libsndfile" "gstreamer" "gst-plugins-base" "gst-pl
optdepends=(
"ffmpeg: Video support"
"maim: Screen-mirroring support"
- "youtube-dl: YouTube support"
-)
+ "youtube-dl: YouTube support")
depends=("gstreamer" "gst-plugins-base" "gst-plugins-good" "gst-plugins-ugly" "gst-plugins-bad" "libsixel")
-source=("https://github.com/jD91mZM2/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('54673b3f09920a724fbc8c2b7fe0dff1ed9bdf5695fdc48631f42bb994028681')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jD91mZM2/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('0d8e14301137c01e51294ab571507310d77cd1aa7c51fb47b85a637edc9110cce2466da7b5bfc43271d92560df65fe5bac8585be24021be98396056adf410fbb')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- cargo build --release --features bin
+ cd "$pkgname-$pkgver"
+ cargo build --release --features bin
}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test
+}
+
package() {
- cd "$srcdir/$pkgname-$pkgver"
- install -Dm 755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}