summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Killy2018-01-30 14:53:56 +0100
committerPierre Killy2018-01-30 14:53:56 +0100
commit89e3b33f939999fb88bade1cfb82bbf08f80c488 (patch)
tree62b493000a10223d37825b5697f9e03c9af4e265
parent6034d77061d39f1b0831fb10c3a1cba7ddd7d59d (diff)
downloadaur-89e3b33f939999fb88bade1cfb82bbf08f80c488.tar.gz
fix(include $pkgver in the downloaded filename to avoid conflicts when upgrading)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 394b66d00ed2..7b5724d35606 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = termshot
pkgdesc = Turns a cli command's output into a screenshot including colors and interactive text
pkgver = 1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pierrekilly/shell-utils
arch = any
groups = pk-shell-utils
@@ -10,8 +10,8 @@ pkgbase = termshot
depends = imagemagick
depends = ptyget
depends = aha
- source = https://raw.githubusercontent.com/pierrekilly/shell-utils/v1.1/termshot/termshot
- source = https://raw.githubusercontent.com/pierrekilly/shell-utils/v1.1/LICENSE
+ source = termshot-1.1::https://raw.githubusercontent.com/pierrekilly/shell-utils/v1.1/termshot/termshot
+ source = LICENSE-1.1::https://raw.githubusercontent.com/pierrekilly/shell-utils/v1.1/LICENSE
sha512sums = 73d457722c78682dea5950f735f2c8365ebd7e29494f886781375709ade6c591311f63ea4a04dd360d81f5d087ccbe390103fe3a525eefdd96fdb6127af823f7
sha512sums = d5b15c6b6ecc1e496b487ce982ff767c2c1ca0dba73e2f64e5bfff4873332ac99efbe34f0bebac676de8a300fdef7b2029e6ea6e66671b9d31ad28a3c37baaf0
diff --git a/PKGBUILD b/PKGBUILD
index e018ab1e36b5..4acb9134b9e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=termshot
pkgver="1.1"
-pkgrel=1
+pkgrel=2
pkgdesc="Turns a cli command's output into a screenshot including colors and interactive text"
arch=('any')
url="https://github.com/pierrekilly/shell-utils"
@@ -10,8 +10,8 @@ license=('MIT')
groups=('pk-shell-utils')
depends=('phantomjs' 'imagemagick' 'ptyget' 'aha')
source=(
- "https://raw.githubusercontent.com/pierrekilly/shell-utils/v${pkgver}/termshot/termshot"
- "https://raw.githubusercontent.com/pierrekilly/shell-utils/v${pkgver}/LICENSE"
+ "termshot-${pkgver}"::"https://raw.githubusercontent.com/pierrekilly/shell-utils/v${pkgver}/termshot/termshot"
+ "LICENSE-${pkgver}"::"https://raw.githubusercontent.com/pierrekilly/shell-utils/v${pkgver}/LICENSE"
)
sha512sums=(
'73d457722c78682dea5950f735f2c8365ebd7e29494f886781375709ade6c591311f63ea4a04dd360d81f5d087ccbe390103fe3a525eefdd96fdb6127af823f7'
@@ -19,7 +19,7 @@ sha512sums=(
)
package(){
- install -D termshot "${pkgdir}/usr/bin/termshot"
- install -D LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D "termshot-${pkgver}" "${pkgdir}/usr/bin/termshot"
+ install -D "LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}