summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-10-11 12:29:42 +0200
committerwillemw122023-10-11 12:29:42 +0200
commitc7273409d40c07d7fdd1b28dbbf04f2d612f42f8 (patch)
treea2847b0213206f7386427a536b5b51fb222226ad
parent0c7cefda6ec86629d5d6b3a6e89f30599fe95f1a (diff)
downloadaur-c7273409d40c07d7fdd1b28dbbf04f2d612f42f8.tar.gz
Disable LTO compile option
Avoid build errors for systems with LTO enabled. Get version number from git instead of Cargo.toml. Rename license file to LICENSE.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7903e1df264d..026a786cd005 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,6 +22,7 @@ pkgbase = termusic-git
optdepends = yt-dlp: download files
provides = termusic
conflicts = termusic
+ options = !lto
source = termusic-git::git+https://github.com/tramhao/termusic.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3420b2c42bce..88df42c10ffa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=termusic-git
-pkgver=0.7.11.r1505.2882d9c
+pkgver=0.7.11.r1507.57429ab
pkgrel=1
pkgdesc='Music Player TUI written in Rust'
arch=(x86_64)
@@ -12,12 +12,15 @@ makedepends=(cargo git)
optdepends=('ffmpeg: extract audio by downloader' 'yt-dlp: download files')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
+options=(!lto)
source=("$pkgname::git+$url.git")
sha256sums=(SKIP)
pkgver() {
- cd $pkgname
- printf '%s.r%s.%s' "$(sed -n 's/^version = "\(.*\)"/\1/p' Cargo.toml)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #cd $pkgname
+ #printf '%s.r%s.%s' "$(sed -n 's/^version = "\(.*\)"/\1/p' Cargo.toml)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+ git -C $pkgname describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -34,5 +37,5 @@ check() {
package() {
install -Dm755 "target/release/${pkgname%-git}"{,-server} -t "$pkgdir/usr/bin"
- install -Dm644 $pkgname/LICENSE_MIT -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+ install -Dm644 $pkgname/LICENSE_MIT "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
}