summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Whited2020-06-11 07:05:27 -0400
committerSam Whited2020-06-11 07:05:27 -0400
commit9dfd814c458b392e500fb6a502c2918c35b1d3c3 (patch)
tree4b3cea5c2c5fa767e6ce13bd24c7b5fb618384ec
downloadaur-9dfd814c458b392e500fb6a502c2918c35b1d3c3.tar.gz
Initial version 1.4.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD30
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa318893b566
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = terraform-provider-stripe
+ pkgdesc = Terraform provider for Stripe
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/franckverrot/terraform-provider-stripe
+ arch = x86_64
+ license = MPL
+ makedepends = go
+ makedepends = git
+ depends = glibc
+ source = terraform-provider-stripe-1.4.0.tar.gz::https://github.com/franckverrot/terraform-provider-stripe/archive/1.4.0.tar.gz
+ sha256sums = 7af24f4443f4abeadb487dbe8540de94aa9fe565748aea7a601447491f7035eb
+
+pkgname = terraform-provider-stripe
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..edae0a1b5ae3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.tar
+*.tar.gz
+*.tar.xz
+*.tar.zstd
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ca58655ffd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sam Whited <sam@samwhited.com>
+
+pkgname=terraform-provider-stripe
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Terraform provider for Stripe"
+url="https://github.com/franckverrot/terraform-provider-stripe"
+license=("MPL")
+arch=("x86_64")
+depends=(glibc)
+makedepends=("go" "git")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/franckverrot/terraform-provider-stripe/archive/$pkgver.tar.gz")
+sha256sums=('7af24f4443f4abeadb487dbe8540de94aa9fe565748aea7a601447491f7035eb')
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o $pkgname
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: