summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTommaso Sardelli2021-03-21 11:30:17 +0100
committerTommaso Sardelli2021-03-21 11:30:17 +0100
commit9cfe66dc1ac20a1c419ac4b489dc8e558525d60a (patch)
tree01e2e64140a6f43275cd010b08f36b237533765b
downloadaur-9cfe66dc1ac20a1c419ac4b489dc8e558525d60a.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c917a0ffdeeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = terraform13
+ pkgdesc = HashiCorp tool for building and updating infrastructure as code idempotently
+ pkgver = 0.13.6
+ pkgrel = 1
+ url = https://www.terraform.io/
+ arch = x86_64
+ license = MPL
+ makedepends = go
+ source = terraform-0.13.6.tar.gz::https://github.com/hashicorp/terraform/archive/v0.13.6.tar.gz
+ sha512sums = 63368d4e30dbf66fe7f486ae7348c3eb9285386ef452a6c8c01f8e034fcc57cf647165ab38aed8e4624f00f7eb1ba0103264366bccc4513796dc36634361b22a
+
+pkgname = terraform13
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecd4ccb02097
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tommaso Sardelli <lacapannadelloziotom at gmail dot com>
+# Contributor: Jerome Leclanche <jerome@leclan.ch>
+# Contributor: Christian Rebischke <chris.rebischke@archlinux.org>
+
+pkgname=terraform13
+_pkgname=terraform
+pkgver=0.13.6
+pkgrel=1
+pkgdesc="HashiCorp tool for building and updating infrastructure as code idempotently"
+url="https://www.terraform.io/"
+arch=("x86_64")
+license=("MPL")
+makedepends=("go")
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/hashicorp/terraform/archive/v$pkgver.tar.gz")
+sha512sums=('63368d4e30dbf66fe7f486ae7348c3eb9285386ef452a6c8c01f8e034fcc57cf647165ab38aed8e4624f00f7eb1ba0103264366bccc4513796dc36634361b22a')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o terraform-binary
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ install -Dm755 terraform-binary "$pkgdir/opt/terraform13/terraform"
+}